LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-08-2005, 03:36 PM   #1
<Ol>Origy
Member
 
Registered: Aug 2003
Location: Slovenia
Distribution: Arch, Debian, Embedded
Posts: 136

Rep: Reputation: 15
Mouse wheel not working in KDE (solved)


Can someone help me get the mouse wheel working in KDE, please?
I have a Slackware 10.1 linux and I use KDE as the X window desktop/interface. I have an optical mouse from Logitech (image) where all the buttons work fine including the middle one but for some reason it just doesn't want to scroll using the wheel. It kind of bothers me as I am used to scroll a lot when browsing the internet.

Here's a piece of my xorg.conf file:
Code:
Section "InputDevice"

# Identifier and driver

    Identifier	"Mouse1"
    Driver	"mouse"

# On platforms where PnP mouse detection is supported the following
# protocol setting can be used when using a newer PnP mouse:

#    Option     "Protocol"      "Auto"

# The available mouse protocols types that you can set below are:
#    Auto BusMouse GlidePoint GlidePointPS/2 IntelliMouse IMPS/2
#    Logitech Microsoft MMHitTab MMSeries Mouseman MouseManPlusPS/2
#    MouseSystems NetMousePS/2 NetScrollPS/2 OSMouse PS/2 SysMouse
#    ThinkingMouse ThinkingMousePS/2 Xqueue
    Option "Protocol"    "PS/2"

# The mouse device.  The device is normally set to /dev/mouse,
# which is usually a symbolic link to the real device.

    Option "Device"      "/dev/mouse"
#   Option "Device"      "/dev/psaux"
#   Option "Device"      "/dev/ttyS0"
#   Option "Device"      "/dev/ttyS1"

# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.

#    Option "Protocol"	"Xqueue"

# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.

#    Option "BaudRate"		"9600"
#    Option "SampleRate"	"150"

# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)

#    Option "Emulate3Buttons"
#    Option "Emulate3Timeout"    "50"

# ChordMiddle is an option for some 3-button Logitech mice

#    Option "ChordMiddle"        "true"

# Mouse wheel!
     Option "ZAxisMapping" "4 5"

EndSection
Now I have manually added the last two lines of the section but it doesn't make any changes even after restart. Suggestions?

P.S. I never used the xconf file generated by the xorg configuration script as KDE refused to run. I had to restore the original.

Thanks in advance!

Last edited by <Ol>Origy; 08-08-2005 at 04:02 PM.
 
Old 08-08-2005, 03:40 PM   #2
rnicolson
Member
 
Registered: Jul 2004
Location: Winnipeg
Distribution: Slackware 11
Posts: 74

Rep: Reputation: 15
I am using a Microsoft mouse and my Xorg.conf looks like this;

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/mouse"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"

I know you are using a logitech mouse but I think you need the imps/2 protocol instead of the PS/2 protocol. I would give it a try and see what happens, you can always change it back.
 
Old 08-08-2005, 03:44 PM   #3
<Ol>Origy
Member
 
Registered: Aug 2003
Location: Slovenia
Distribution: Arch, Debian, Embedded
Posts: 136

Original Poster
Rep: Reputation: 15
Hmph. It is originally a USB mouse but I use a plug that converts it to PS/2. I'll give it a try now.

EDIT: Yes it seems to function properly now. Thank you for your answer, rnicolson.

I'll post my part of xorg.conf here in case somebody has a similar problem so that he can find this thread using search.

This is how my part of the config file looks like now:
Code:
Section "InputDevice"

# Identifier and driver

    Identifier	"Mouse1"
    Driver	"mouse"

# On platforms where PnP mouse detection is supported the following
# protocol setting can be used when using a newer PnP mouse:

#    Option     "Protocol"      "Auto"

# The available mouse protocols types that you can set below are:
#    Auto BusMouse GlidePoint GlidePointPS/2 IntelliMouse IMPS/2
#    Logitech Microsoft MMHitTab MMSeries Mouseman MouseManPlusPS/2
#    MouseSystems NetMousePS/2 NetScrollPS/2 OSMouse PS/2 SysMouse
#    ThinkingMouse ThinkingMousePS/2 Xqueue
    Option "Protocol"    "IMPS/2"

# The mouse device.  The device is normally set to /dev/mouse,
# which is usually a symbolic link to the real device.

    Option "Device"      "/dev/mouse"
#   Option "Device"      "/dev/psaux"
#   Option "Device"      "/dev/ttyS0"
#   Option "Device"      "/dev/ttyS1"

# When using XQUEUE, comment out the above two lines, and uncomment
# the following line.

#    Option "Protocol"	"Xqueue"

# Baudrate and SampleRate are only for some Logitech mice. In
# almost every case these lines should be omitted.

#    Option "BaudRate"		"9600"
#    Option "SampleRate"	"150"

# Emulate3Buttons is an option for 2-button Microsoft mice
# Emulate3Timeout is the timeout in milliseconds (default is 50ms)

#    Option "Emulate3Buttons"
#    Option "Emulate3Timeout"    "50"

# ChordMiddle is an option for some 3-button Logitech mice

#    Option "ChordMiddle"        "true"

# Buttons
     Option "Buttons" "5"

# Mouse wheel!
     Option "ZAxisMapping" "4 5"

EndSection
Keywords: mouse logitech wheel optical kde slackware xorg xorg.conf linux working scroll configuration

Last edited by <Ol>Origy; 08-08-2005 at 04:01 PM.
 
Old 08-09-2005, 12:39 AM   #4
<Ol>Origy
Member
 
Registered: Aug 2003
Location: Slovenia
Distribution: Arch, Debian, Embedded
Posts: 136

Original Poster
Rep: Reputation: 15
Unfortunately I just found out that this causes another problem for me!
My Slack will boot into the console by default. The mouse seems to work fine right after boot. But when I start the X window system by typing "startx" and then exit it or use a different tty (ctrl+alt+F-keys), my mouse refuses to work properly. When I try to move it, the cursor just stays on the top right of the screen and acts as if I pressed enter a lot of times which I can see on the prompt lines.

The configuration I use for X window system seems to work fine for it but unfortunately it corrupts the console mouse service after loaded.
 
Old 08-09-2005, 01:35 AM   #5
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Origy if you don't use too much the mouse at console you can stop gpm service which provides mouse support on console. It's reported to cause some problems sometimes.
You can do that by issuing: chmod -x /etc/rc.d/rc.gpm
 
Old 08-09-2005, 10:19 AM   #6
<Ol>Origy
Member
 
Registered: Aug 2003
Location: Slovenia
Distribution: Arch, Debian, Embedded
Posts: 136

Original Poster
Rep: Reputation: 15
That would be an option. I don't really need a wheel in console mode however its nice (and more 1337) to have a mouse working like when I need to copy/paste some text. The protocol seems to be the problem here. When the PS/2 protocol was used, the mouse worked fine in console mode but the wheel didn't in KDE. I now use the following line to select protocol:

Option "Protocol" "Auto"

This seems to work just as fine in KDE but has the same effect in console mode.


EDIT: Okay I believe I fixed it. It seems to work fine in console now.
The thing I did was edit the file you pointed me to (thanks): /etc/rc.d/rc.gpm and now it looks like this:

Code:
#!/bin/sh
# Start/stop/restart the GPM mouse server:

if [ "$1" = "stop" ]; then
  echo "Stopping gpm..."
  /usr/sbin/gpm -k
elif [ "$1" = "restart" ]; then
  echo "Restarting gpm..."
  /usr/sbin/gpm -k
  sleep 1
  /usr/sbin/gpm -m /dev/mouse -t exps2
else # assume $1 = start:
  echo "Starting gpm:  /usr/sbin/gpm -m /dev/mouse -t exps2"
  /usr/sbin/gpm -m /dev/mouse -t exps2
fi
There. I hope there will be no more problems from now on.
Speaking about the rc.gpm, I have a quick question. Is every file inside rc.d folder that begins on rc.(something) supposet to execute at startup or something?

Last edited by <Ol>Origy; 08-09-2005 at 11:07 AM.
 
Old 08-09-2005, 05:12 PM   #7
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Quote:
Originally posted by <Ol>Origy

Speaking about the rc.gpm, I have a quick question. Is every file inside rc.d folder that begins on rc.(something) supposet to execute at startup or something?
Yes, files under /etc/rc.d/ are system initialization scripts. Those with names like rc.X (where the X is a number or uppercase letter) are the main script, which are called depending on the runlevel linux is. They're in charge of calling the other scripts there which starts with rc. and execute them if they're executables.
More info here: http://www.slackbook.org/html/system...FIGURATION-RCD
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PS2 wheel mouse/wheel not working jayhel Linux - Hardware 2 06-18-2006 07:54 PM
mouse wheel not working mike_savoie Debian 2 07-28-2005 11:34 AM
mouse wheel not working? Oh Cisco Debian 8 07-30-2004 04:21 AM
mouse wheel not working edu2 Linux - Newbie 9 09-28-2003 07:00 PM
how to get Mouse wheel working fwee Slackware 13 07-06-2003 03:09 PM


All times are GMT -5. The time now is 02:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration