LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-06-2004, 11:01 AM   #1
mooreted
Member
 
Registered: May 2003
Posts: 598

Rep: Reputation: 30
Mouse Takes a While to Wake Up


I have a Microsoft Optical USB mouse which works fine in Slack except I have to wake it up every session. When I bootup or restart the X server, I have to move the mouse around for awhile until it wakes up and starts working. It will remain stuck until I move it around for awhile. Any way to fix that?

Ted.
 
Old 03-06-2004, 11:39 AM   #2
Cdzin
Member
 
Registered: Jul 2003
Location: Campinas-SP, Brazil
Distribution: Slackware
Posts: 61

Rep: Reputation: 15
Hii, i'm afraid this happens with all the USB mouses ... I have a Logitech MX310 and i have to move up for about 3 seconds before it actually starts to work ... If anyone have a clue on how to solve this, pleasee help us.
 
Old 03-06-2004, 08:58 PM   #3
mooreted
Member
 
Registered: May 2003
Posts: 598

Original Poster
Rep: Reputation: 30
I fixed it! In your XF86config file look for Imput Device for your mouse and edit it like so:

Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"

That should do the trick.
 
Old 03-07-2004, 07:10 PM   #4
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
What did it look like before that caused the problem?

Was it protocol set to "Auto" ?
I've never experienced this with my Logitech USB Optical.

--Shade
 
Old 03-08-2004, 08:37 AM   #5
mooreted
Member
 
Registered: May 2003
Posts: 598

Original Poster
Rep: Reputation: 30
Yeah, it was set to auto. I had to set it to IMPS/2 to get imwheel working so the wheel on my mouse would work and it fixed the sticking pointer problem too.

Ted.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Middle mouse button takes me to strange websites? BajaNick General 24 10-22-2006 09:03 PM
mozilla takes ages to load and mouse crashes in flulbox hubabuba Linux - Software 1 12-12-2004 10:44 AM
Can't Wake Up mushman Mandriva 2 08-26-2004 01:27 PM
my mouse input is takes as keyboard input in BASH e1000 Slackware 5 12-08-2003 03:00 PM
Wake Up!!! adam_boz Linux From Scratch 3 10-02-2002 10:05 PM


All times are GMT -5. The time now is 12:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration