LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 11-17-2012, 09:20 AM   #1
Laertiades
Member
 
Registered: Jul 2012
Location: Pacific Northwest
Distribution: Arch
Posts: 51

Rep: Reputation: Disabled
mouse problem in gui - Slackware 14.0


I'm new to Linux. I installed Slackware 14.0 two days ago. My mouse works fine at the command line but when I startx it's motions become delayed by several seconds and it is choppy. I am not sure what info would be most relevant. I noticed the problem immediately after installation. Since then I have switched to a generic kernel, I made a xorg.conf file, I tried adding the line: Option "HWcursor" "Off", I tried stopping gpm before startx. Problem occurs with different (usb) mice and different windows managers. Any help would be greatly appreciated.

Last edited by Laertiades; 11-17-2012 at 01:09 PM. Reason: thread addressed too many different issues
 
Old 11-18-2012, 02:08 AM   #2
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware-14.0 on a Lenovo T61 6457-4XG
Posts: 3,635

Rep: Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827
Which mouse is it? If is an USB one, unplug it then plug it in and 15 seconds later type as root "dmesg | tail". please provide the output as well as the brand / model.

Also please attach an X log to your next post.
 
Old 11-18-2012, 09:12 AM   #3
Laertiades
Member
 
Registered: Jul 2012
Location: Pacific Northwest
Distribution: Arch
Posts: 51

Original Poster
Rep: Reputation: Disabled
more info

Thank you Didier. Mouse is Dell KM632 usb wireless optical, part of keyboard/mouse pair. I will include the outputs which you suggested as attachments. the x log is the contents of /var/log/Xorg.0.log after closing my most recent kde session. I should mention that I started xfce to post this response and after about 5 minutes, while connecting to my internet service, the mouse started working perfectly, out of the blue. I will log out, copy my x log, and report back on my next session.
Thanks again Didier.
Attached Files
File Type: log dmesgout.log (1.2 KB, 7 views)
File Type: log xlogfile.log (34.6 KB, 4 views)
 
Old 11-18-2012, 10:19 AM   #4
Laertiades
Member
 
Registered: Jul 2012
Location: Pacific Northwest
Distribution: Arch
Posts: 51

Original Poster
Rep: Reputation: Disabled
mouse not working again

I logged out, copied /var/log/Xorg.0.log, and logged back in. My mouse is not functioning properly again. I will attach log of session in which it started working. I will add that the buttons and wheel work fine so long as the mouse isn't moved, but if I move the mouse, they stop working until the pointer comes to rest.
Attached Files
File Type: log xlogfile.log (34.1 KB, 1 views)
 
Old 11-22-2012, 08:41 AM   #5
Laertiades
Member
 
Registered: Jul 2012
Location: Pacific Northwest
Distribution: Arch
Posts: 51

Original Poster
Rep: Reputation: Disabled
given up

I have given up on this problem and switched operating systems. Thanks for the help,though.
 
Old 11-22-2012, 09:02 AM   #6
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Hi,

it seems to be too late, but I would ask which files you have in /etc/X11/xorg.conf.d/

Markus
 
Old 11-22-2012, 10:06 AM   #7
Laertiades
Member
 
Registered: Jul 2012
Location: Pacific Northwest
Distribution: Arch
Posts: 51

Original Poster
Rep: Reputation: Disabled
Appreciate the help

Thanks again Markus. The Slackware community has been very helpful but I am not yet ready for the challenges Slackware presents. Perhaps in the Future. I installed Arch over my Slackware installation. I do appreciate your help.

Last edited by Laertiades; 11-22-2012 at 10:07 AM.
 
Old 11-22-2012, 10:14 AM   #8
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,970

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Quote:
Originally Posted by Laertiades View Post
Thanks again Markus. The Slackware community has been very helpful but I am not yet ready for the challenges Slackware presents. Perhaps in the Future. I installed Arch over my Slackware installation. I do appreciate your help.
Good luck, you will be back to Slackware sooner or later.

Markus
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot wake from suspend with keyboard or mouse on Dell XPS 17 L702X Ahaaa Linux - Hardware 4 05-02-2012 06:19 PM
synergy: mouse movement does not wake up client hedpe Linux - Software 0 11-25-2006 06:41 PM
Mouse wont wake after sleep mode icedfusion Ubuntu 3 09-11-2006 09:23 PM
Mouse Takes a While to Wake Up mooreted Slackware 4 03-08-2004 08:37 AM
Mandrake 9.1 'wake-up' problems FlyingSmurf Linux - Newbie 1 08-28-2003 05:18 PM


All times are GMT -5. The time now is 12:13 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration