LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Mouse not responding after installation (http://www.linuxquestions.org/questions/slackware-14/mouse-not-responding-after-installation-406550/)

Steve50 01-22-2006 11:12 AM

Mouse not responding after installation
 
So I took the plunge and finally installed slackware after 18 months using other distros. The installation procedure was relatively straightforward to my surprise, and startx even takes my into KDE. My problem is that the mouse (ps2 not usb) doesn't appear to be recognised. I see the pointer on screen but I can't move it - which makes navigating KDE a bit of a problem. I would appreciate any advice about how to fix this.

detpenguin 01-22-2006 11:47 AM

take a look at your /etc/X11/xorg.conf file and find the part that says this:
Quote:

Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/mouse"
that is mine. you might need to adjust it to say "IMPS/2" if it already doesn't?

also, if it's a scroll mouse, adding the lines Buttons and ZAxisMapping will enable the scroll wheel...

Steve50 01-22-2006 12:05 PM

Thanks for this. I'll give it a try.

lestoil 01-22-2006 12:12 PM

What kind of mouse is it? Some ps2 mice need explorer or MS or logitec choice. Mouseconfig command can help you config the mouse from cli. Good luck.

Franklin 01-22-2006 12:24 PM

If you set up GPM to use the wrong type of mouse this might happen as well.

You can use pkgtool to re-run the setup script for GPM and be certain to choose the the same mouse as specified in your xorg.conf file. Either imps2 or ps2 would be correct choices based on what you said in your first post (i.e. imps2 if you specified imps2 in xorg.conf). You can also make /etc/rc.d/rc.gpm non-executable: chmod -x /etc/rc.d/rc.gpm. This will stop gpm from loadin at boot and may give you a functional mouse. This could also be done from the same start-up script I mentioned above.

Steve50 01-22-2006 01:04 PM

Quote:

Originally Posted by detpenguin
take a look at your /etc/X11/xorg.conf file and find the part that says this:

that is mine. you might need to adjust it to say "IMPS/2" if it already doesn't?

also, if it's a scroll mouse, adding the lines Buttons and ZAxisMapping will enable the scroll wheel...


Unfortunately none of this worked I also tried changing teh protocol to microsoft but no difference. I'll give some of the other suggestions a try. For information, it's a cheap no-name two-button mouse with a scroll wheel.

Steve50 01-23-2006 12:54 PM

Tried all the suggestions and nothing worked. So I reinstalled but this time went with the default kernel rather than the 2.6. I also selected not to have GPM load at startup. Result: it now works. Now I just need to install ndiswrapper to get my wireless connection working and sort out sound (I think it's just a mixer issue). Thanks for the fast replies everyone. Once I've progressed a little further I'll post queries about how to change default KDE to XFCE and how to get a graphical login manager working (GDM or KDM).


All times are GMT -5. The time now is 10:40 PM.