LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 06-12-2004, 11:56 PM   #1
usercsr
Member
 
Registered: Sep 2003
Location: Little Rock, Arkansas
Distribution: Slackware-Current
Posts: 129

Rep: Reputation: 15
Mouse jerky at 100% cpu


hi,
I'm running Slack-current with kernel 2.6.6. Earlier I used to configure everything by myself when compiling the 2.6 kernel and everything worked fine. This time I took the .config file for the 'bareacpi' kernel and used to it to compile the 2.6.6 kernel (Made changes to some sections though). Now the problem is that the mouse movement becomes jerky whenever the cpu utilization goes to the maximum (100%). I can only guess that the mouse interrupts are getting a low priority. I have a Sony Vaio with a synaptics touchpad but mostly use a Logitech usb mouse. The problem comes for both of them. Here is my '/proc/interrupts' file if it can tell something :

Code:
~$ cat /proc/interrupts
           CPU0
  0:    5083466          XT-PIC  timer
  1:       4050          XT-PIC  i8042
  2:          0          XT-PIC  cascade
  8:          1          XT-PIC  rtc
  9:     719051          XT-PIC  acpi, eth0, ohci1394, Intel 82801CA-ICH3, uhci_hcd, uhci_hcd, uhci_hcd, radeon@PCI:1:0:0
 12:       2762          XT-PIC  i8042
 14:      26458          XT-PIC  ide0
 15:         21          XT-PIC  ide1
NMI:          0
ERR:          0
Would appreciate any help
 
Old 06-13-2004, 12:05 AM   #2
irfanhab
Member
 
Registered: Jan 2004
Location: Pakistan
Distribution: OpenSuse 10.2, Slackware 11, Solaris 10
Posts: 415

Rep: Reputation: 34
Well, I think that something highpriority may be jammed or something, blocked interrupts of I/O devices such as mouse input
 
Old 06-13-2004, 12:44 AM   #3
usercsr
Member
 
Registered: Sep 2003
Location: Little Rock, Arkansas
Distribution: Slackware-Current
Posts: 129

Original Poster
Rep: Reputation: 15
okay, I found out another thing. The mouse gets blocked only when the cpu utilization goes to 100% because of disk activity. I wrote a program to go into an infinite loop (which will take the processor usage to 100%) and upon running it there is no problem, the mouse works fine. Is this normal behaviour or I need to change some settings for the disk.
 
Old 06-13-2004, 10:36 AM   #4
cratos
Member
 
Registered: Feb 2003
Posts: 95

Rep: Reputation: 15
I had a problem similar to this when I first compiled 2.6.x. It had me wondering why people were saying that 2.6 was faster than 2.4. It turned out to be a config file problem because after staring over with a friends config file, it just went away. I also had a similar experience with an nvidia network driver. Everytime I went on the internet I would get 100% cpu usage and the transfer rate was capped by the cpu. Moving to an older nvidia driver (linux 2.4.x) or using the included forcedeth drivers in 2.6.x took care of this.
 
Old 06-13-2004, 05:48 PM   #5
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
You probably have to re-enable hdparm -- hard drive tuning tool.
The mouse becomes jumpy because of i/o wait -- load up top in an xterm and do something harddrive intensive, you'll see a column for % taken by Input/Output wait.

hdparm /dev/hda -tT

will give you some handy values for comparing the performance of your drive, and whether it can be tuned more.

Check out the hdarpm HOWTO or man hdparm.

--Shade
 
Old 06-13-2004, 06:00 PM   #6
usercsr
Member
 
Registered: Sep 2003
Location: Little Rock, Arkansas
Distribution: Slackware-Current
Posts: 129

Original Poster
Rep: Reputation: 15
Here is the output of 'hdparm -tT /dev/hda'

Code:
Timing buffer-cache reads:    1460 MB in 2.00 seconds = 729.38 MB/sec
Timing buffered disk reads:    74 MB in 3.02 seconds = 24.54 MB/sec
and the output of 'hdparm /dev/hda'

Code:
/dev/hda:
 multcount    =  0 (off)
 IO_support   =  0 (default 16-bit)
 unmaskirq    =  0 (off)
 using_dma    =  1 (on)
 keepsettings =  0 (off)
 readonly     =  0 (off)
 readahead    = 256 (on)
 geometry     = 65535/16/63, sectors = 78140160, start = 0
Cany anyone suggest what parameters needs to be changed. I've read that these parameters drastically affect performance and I don't want to mess things up.

Thank you
 
Old 06-13-2004, 06:07 PM   #7
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
Well, hdparm can tell you what the best settings for your drive are.

Like I said, man hdparm

There's also a giant thread around here about hdparm settings that folks use. Use the search and dig that one up.

hdparm -i /dev/hda
(it might be a capital I, can't recall)
Will give you info on what your drive is capable.

Ignore the PIO modes, as those don't affect much...

--Shade
 
Old 06-13-2004, 06:36 PM   #8
usercsr
Member
 
Registered: Sep 2003
Location: Little Rock, Arkansas
Distribution: Slackware-Current
Posts: 129

Original Poster
Rep: Reputation: 15
okay, I'll try that.
Thank you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
100 % Cpu Volcano Linux - Newbie 27 10-05-2005 11:58 PM
cpu nearly always at 100% xround Linux - Hardware 6 09-17-2004 06:51 AM
'Jerky' PS2 mouse movement - Increasing refresh rate Daem0hn Linux - Hardware 1 06-23-2004 02:43 AM
jerky mouse paradoxni Mandriva 0 06-13-2004 11:55 AM
Cpu @ 100% kpzani Linux - General 4 03-20-2003 01:46 PM


All times are GMT -5. The time now is 03:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration