LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   mouse freezes after kernel update (http://www.linuxquestions.org/questions/slackware-14/mouse-freezes-after-kernel-update-620501/)

DonaldUK 02-12-2008 02:23 AM

mouse freezes after kernel update
 
Hello,

I'm running Slackware 12 on my desktop computer. I update every so often using slackpkg update and then slackpkg upgrade-all. the latest of these updated the kernel to 2.6.23.15. I have lost my nvidia driver but more seriously my mouse is now frozen in the middle of the screen. I have tried changing the xorg.conf file, changing IMPS/2 to Auto and PS/2, both with no effect.

Has anyone else had this problem, and if so, how did you solve it?

Donald

simcox1 02-12-2008 02:38 AM

Did you run lilo after the upgrade? Auto-upgrading the kernel is not recommended using slackpkg.

mRgOBLIN 02-12-2008 03:30 AM

and try re-running the nvidia installer

DonaldUK 02-12-2008 01:23 PM

I use Grub, multibooting various Linux OSs, of which Slackware is only one.

Donald

frandalla 02-12-2008 01:26 PM

first of all your bootloader should be aware of kernel changes, after that nvidia installer again.
probably your mouse is freezed because you are lacking the modules for it.

smurfed 02-13-2008 07:16 PM

Have you made sure that you're loading the imps2 modules after the compile?

If not, try editing your /etc/rc.d/rc.modules file and uncomment the line that loads the imps2 module.

This should give you your mouse back ^_^

Also, make sure that the /etc/rc.d/rc.modules file is pointing to the correct path. It's no good having it point to your old kernel modules instead of your new ones...

Cheers,
- Smurfed

orbit 02-13-2008 07:23 PM

Hi DonaldUK,

Whenever I do a kernel upgrade on my Slackware12 system, one of the things I do to overcome the issue you are experiencing is to edit the /etc/rc.d/rc.modules file, and check that the following line is uncommented:

/sbin/modprobe psmouse proto=imps

This will enable your mouse to work correctly again on the new kernel.

It is also advisable that you ensure that your /etc/rc.d/@rc.modules symlink is pointing to the correct rc.modules-2.6.xx.xx file.

Hope this helps :)

Cheers

Orbit

DonaldUK 02-14-2008 01:48 AM

Thanks Smurfed and Orbit - that did the trick. I'll remember for next time.

Donald


All times are GMT -5. The time now is 02:56 AM.