LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   mouse cursor distorted on dual head monitor (http://www.linuxquestions.org/questions/slackware-14/mouse-cursor-distorted-on-dual-head-monitor-915466/)

stu_c 11-25-2011 05:58 AM

mouse cursor distorted on dual head monitor
 
Hello,

I've recently upgraded one of my computers from Slackware 13.1 to 13.37. I have installed all the latest patches too. The computer in question is a Dell Optiplex 760, which has an ATI Radeon HD 3450 graphics card, with two monitors attached. I was successfully running the system dual-headed on Slack 13.1 using the proprietary ATI driver.

Since upgrading to Slack 13.37 and re-installing the ATI driver, I have got the dual-headed display back, the mouse cursor appears normal on the left hand screen, but is distorted when moved across to the right hand screen. When distorted the cursor appears square shaped, much larger (approx x5) than the original mouse cursor, with random pixels highlighted (sorry that's about the best description I can manage...) The mouse functions fine in terms of button clicks - once you've worked out where to click...

I have tried upgrading the mesa and nouveau packages (using the ones from /testing) but this hasn't helped. I'm using the xfce4 window manager, logging on via xdm. Interestingly, if I log on to KDE via kdm, the mouse cursor appears normal on both monitors.

Any suggestions?
Thanks,
S

jamesf 11-25-2011 10:32 AM

Here's what I'd try: 1) Log in via KDM but specify xfce as the environment to log in to; 2) If there is still a problem, create a new user, log in via xdm and kdm specifying xfce and see if the problem repeats.

1 will tell you whether it is an xdm or kdm problem setting things up. 2 will likely tell you whether it is like a system-level problem (new user affected) or a user-configuration problem (new user normal).

stu_c 11-28-2011 05:06 AM

I tried creating a new user, but the new account also had a distorted mouse cursor on one monitor only (as did the root account). I couldn't sus out how to get kdm use a window manager other than it's own - I went through the settings and think I found out where to change this, but I got an error when I actually tried to "configure" a different WM.

I did try starting the (xfce) window manager via "startx" rather than xdm, this still produced a distorted mouse cursor on the one monitor.

S

jamesf 11-28-2011 08:47 AM

Exactly how you get the KDM login screen to use a different window manager depends upon you configuration. On a default Slackware 13.37 I have two buttons on the login screen. One for power-off, the other lets me pick which of Blackbox, fluxbox, kde, xfce, etc. to use.

On another 13.37 box that I've reconfigured a bit the buttons are text buttons. One for login, the other for startup type, remote, login, etc.

Try looking around on the KDM screen unless you know that you might have reconfigured those options away?

stu_c 11-29-2011 03:59 AM

Ok, I've managed to select xfce from the KDM display manager (thanks for pointing out where the button was!). However, the mouse cursor remains distorted on the right hand monitor only. I have also tried changing the screen resolution (from within xfce) but this didn't help. So it looks like a xfce problem but I'll try a few other window managers just to see if they have a problem too.

S

jamesf 11-29-2011 01:54 PM

Ok, so now we know: xfce problem for all users, existing and new; kde no problem (existing user), but what about the new one?

Something I noticed in your first post that concerned me was that you had the proprietary ATI driver installed but you also mentioned upgrading mesa and nouveau from /testing. IIRC, the proprietary NVidia and ATI drivers replace some X libraries with their own stuff. Did you install the mesa/nouveau drivers after the ATI? It sounded like you did.

After installing mesa/nouveau did you ever re-install ATI? While that might not help immediately it could get you back to a 'good' ATI driver setup. Since I don't have any ATI cards using ATI drivers right now this is admittedly a shot in the dark.

Are you sure you're using the latest ATI drivers? Are you sure that they're approved for the kernel version you're using?

I got nothing else...

stu_c 12-01-2011 05:27 AM

Ok, I checked to see if more recent drivers were available (they were) and installing these drivers seems to have have fixed the problem. So thanks for that suggestion which I really should have thought of myself! - I'd only mucked around upgrading mesa & nouveau because that fixed a graphics/display problem I'd had with a different computer (with also a different graphics card).

For the record, before doing the ATI driver upgrade I checked to see if any other window managers had a distorted mouse cursor on one monitor (for root and my user account) - they all did. But switching back to the KDE WM on the root account now had a distorted mouse cursor on one monitor. Strange. I also noticed that the (undistorted) mouse cursor had changed from the normal KDE mouse cursor shape to a shape more similar (probably the same) as all the other window managers. Since I don't normally user the root account I deleted all the config files/directories relating to the various WM's I'd just been using and this restored the 'normal' KDE mouse cursor at next login, and got rid of the distorted mouse cursor on the one monitor. So it seems the problem is related to the rendering of the mouse cursor somehow?

Thanks for your help!
Stuart

polrus 11-26-2012 08:03 AM

2 Attachment(s)
I have the same problem on OpenSuse 12.2 64bit
ati amd 12.10 driver installed, and only on the right monitor i have distorted mouse cursor.
strange thing is that when i zoom in the desktop using KDE effects - the cursor looks fine.
when i'm back in 0% zoom it's still distorted.

when i do a screenshot - the cusor on the screenshot looks fine.

look at my attachments - one screenshot and another one made by a phone camera

Please change the topic - remove [solved]


All times are GMT -5. The time now is 02:50 AM.