LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Mouse buttons clicking twice in Slackware 12.1 (http://www.linuxquestions.org/questions/slackware-14/mouse-buttons-clicking-twice-in-slackware-12-1-a-641354/)

dimm0k 05-10-2008 09:57 PM

Mouse buttons clicking twice in Slackware 12.1
 
Recently upgraded from 12.0 to 12.1 following the steps outlines in UPGRADE.TXT and CHANGES_AND_HINTS.TXT and so far so good except for the USB mouse in KDE. For some odd reason whenever I click once, whether it be the left button or the right, it's treated as as though I've double clicked. I've tried removing .kde and starting KDE as new, but no change. Even the wheel, which is supposed to paste the contents of a copy/cut acts as though I've clicked twice. Does anyone know why this is happening?

I've tried blacklisting the psmouse module and allowing it to load, but that didn't help. I've also manually loaded and unloaded this particular module, but no change. HELP!

dimm0k 05-11-2008 12:52 AM

Looks like I've narrowed it down to my xorg.conf file being the culprit, but I have no clue what could be wrong since it was working fine in Slackware 12.0. Here's my conf file.

Code:

Section "Module"
    Load        "dbe"  # Double buffer extension
    SubSection  "extmod"
      Option    "omit xfree86-dga"  # don't initialise the DGA extension
    EndSubSection
    Load        "type1"
    Load        "freetype"
    #Load        "speedo"
    Load        "glx"
EndSection


Section "Files"
    RgbPath      "/usr/share/X11/rgb"
    ModulePath  "/usr/lib/xorg/modules"
    FontPath    "/usr/share/fonts/TTF"
    FontPath    "/usr/share/fonts/OTF"
    FontPath    "/usr/share/fonts/Type1"
    FontPath    "/usr/share/fonts/misc"
    FontPath    "/usr/share/fonts/75dpi/:unscaled"
EndSection


Section "ServerFlags"
EndSection


Section "InputDevice"
    Identifier  "Keyboard1"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "IntelliMouse"
    Driver      "mouse"
    Option      "Protocol" "ExplorerPS/2"
    Option      "Device" "/dev/input/mice"
    Option      "Buttons" "7"
    Option      "ZAxisMapping" "4 5"
    Option      "Emulate3Buttons"
EndSection

Section "InputDevice"
    Identifier  "Mouse1"
    Driver      "mouse"
    Option      "Protocol"    "PS/2"
    Option      "Device"      "/dev/psaux"
EndSection


Section "Modes"
    Identifier  "19x12"
    # 1920x1200 @ 60.00 Hz (GTF) hsync: 74.52 kHz; pclk: 193.16 MHz
    Modeline "1920x1200"  193.16  1920 2048 2256 2592  1200 1201 1204 1242  -HSync +Vsync
EndSection


Section "Monitor"

    Identifier  "Dell Inspiron 9300 LCD"
    ModelName  "Notebook Display Panel"
    VendorName  "Dell"
    HorizSync  31.5 - 100.0
    VertRefresh 60.0 -  60.0
    DisplaySize 506 316
    UseModes    "19x12"
EndSection

Section "Monitor"
    Identifier  "Samsung SyncMaster 900SL"
    HorizSync  30-96
    VertRefresh 50-160
EndSection


Section "Device"
    Identifier  "VESA Framebuffer"
    Driver      "vesa"
    #VideoRam    4096
EndSection

Section "Device"
    Identifier  "NVIDIA GeForce 6800 - single"
    Driver      "nvidia"
    VideoRam    262144
    Option      "RenderAccel" "yes"
    Option      "AllowGLXWithComposite" "yes"
    Option      "HWCursor" "yes"
    Option      "CursorShadow" "yes"
    Option      "NoLogo" "yes"
    BusID      "PCI:1:0:0"
    Option      "ConnectedMonitor" "CRT-0"
EndSection

Section "Screen"
    Identifier  "Screen 0"
    Device      "NVIDIA GeForce 6800 - single"
#    Monitor    "Dell Inspiron 9300 LCD"
    Monitor    "Samsung SyncMaster 900SL"
    DefaultDepth 24
    Subsection "Display"
        Depth      8
        Modes "1920x1200" "1600x1200" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth      16
        Modes "1920x1200" "1600x1200" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth      24
        Modes "1920x1200" "1600x1200" "1024x768" "800x600" "640x480"
        Option "AddARGBGLXVisuals" "yes"
    EndSubsection
    Subsection "Display"
        Depth      32
        Modes "1920x1200" "1600x1200" "1024x768" "800x600" "640x480"
    EndSubsection
EndSection

Section "Device"
    Identifier  "NVIDIA GeForce 6800 - clone"
    Driver      "nvidia"
    VideoRam    262144
    Option      "RenderAccel" "yes"
    Option      "DPMS"
    Option      "HWCursor" "yes"
    Option      "CursorShadow" "yes"
    Option      "NoLogo" "yes"
    BusID      "PCI:1:0:0"
    Option      "ConnectedMonitor" "CRT-0, DFP-0"
    Option      "FlatPanelProperties" "Scaling = aspect-scaled"
    Option      "TwinView" "yes"
    Option      "TwinViewOrientation" "Clone"
    Option      "HorizSync" "CRT-0: 30-96, DFP-0: 31.5-100"
    Option      "VertRefresh" "CRT-0: 50-160, DFP-0: 60"
    Option      "MetaModes" "CRT-0: 1600x1200, DFP-0: 1920x1200"
EndSection

Section "Screen"
    Identifier  "Screen 1"
    Device      "NVIDIA GeForce 6800 - clone"
#    Monitor    "Dell Inspiron 9300 LCD"
    Monitor    "Samsung SyncMaster 900SL"
    DefaultDepth 24
    Subsection "Display"
        Depth      8
        Modes "1920x1200" "1600x1200" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth      16
        Modes "1920x1200" "1600x1200" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth      24
        Modes "1920x1200" "1600x1200" "1024x768" "800x600" "640x480"
        Option "AddARGBGLXVisuals" "yes"
    EndSubsection
    Subsection "Display"
        Depth      32
        Modes "1920x1200" "1600x1200" "1024x768" "800x600" "640x480"
    EndSubsection
EndSection

Section "Device"
    Identifier  "NVIDIA GeForce 6800 - multihead"
    Driver      "nvidia"
    VideoRam    262144
    Option      "RenderAccel" "yes"
    Option      "HWCursor" "yes"
    Option      "CursorShadow" "yes"
    Option      "NoLogo" "yes"
    BusID      "PCI:1:0:0"
    Option      "ConnectedMonitor" "CRT-0, DFP-0"
    Option      "FlatPanelProperties" "Scaling = aspect-scaled"
    Option      "TwinView" "yes"
    Option      "TwinViewOrientation" "LeftOf"
    Option      "HorizSync" "CRT-0: 30-96, DFP-0: 31.5-100"
    Option      "VertRefresh" "CRT-0: 50-160, DFP-0: 60"
    Option      "MetaModes" "CRT-0: 1600x1200, DFP-0: 1920x1200"
EndSection

Section "Screen"
    Identifier  "Screen 2"
    Device      "NVIDIA GeForce 6800 - multihead"
#    Monitor    "Dell Inspiron 9300 LCD"
    Monitor    "Samsung SyncMaster 900SL"
    DefaultDepth 24
    Subsection "Display"
        Depth      8
        Modes "1920x1200" "1600x1200" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth      16
        Modes "1920x1200" "1600x1200" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth      24
        Modes "1920x1200" "1600x1200" "1024x768" "800x600" "640x480"
        Option "AddARGBGLXVisuals" "yes"
    EndSubsection
    Subsection "Display"
        Depth      32
        Modes "1920x1200" "1600x1200" "1024x768" "800x600" "640x480"
    EndSubsection
EndSection


Section "ServerLayout"
    Identifier  "Simple Layout"
    Screen      "Screen 0"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "IntelliMouse" "SendCoreEvents"
    InputDevice "Keyboard1" "CoreKeyboard"
EndSection


Section "Extensions"
    Option      "Composite" "Enable"
EndSection


shadowsnipes 05-11-2008 12:55 AM

I don't think you need to blacklist psmouse. Instead, you might just need to change the protocol used in /etc/modprobe.d/psmouse

Quote:

Originally Posted by CHANGES_AND_HINTS.TXT
The psmouse module is no longer blacklisted by default; instead, it is loaded
with the imps protocol per /etc/modprobe.d/psmouse -- if you need/want a
different protocol, edit that file.
Note that options declarations have
no bearing on *if* a module is loaded - they only affect *how* it is loaded.
In other words, the module should now be loaded automatically (since it's no
longer blacklisted), and the options in /etc/modprobe.d/psmouse are the ones
applied when loading it.

If this doesn't help then ask yourself this: Does this only happen in KDE? Try to click around and paste some text with GPM in the console.

Last resort, check these things:

/etc/udev
make sure there are no .new or .bak or .orig files anywhere
while you are at it, in case you forgot to remove 75-network-devices.rules and 75-optical-devices.rules you can do that now
Quote:

Originally Posted by CHANGES_AND_HINTS.TXT
udev was upgraded - don't forget to move/merge all of the associated *.new
files into place or you will have problems. We are now using as much of
the upstream udev rules as possible (and efforts are underway to further
unify us with other distributions), so you'll notice a lot more udev rules
files in that directory. Be sure to heed the warnings about not editing
the included rules files, as they will be overwritten if/when the udev
package is upgraded.
If you have more than one network card and have been using the
75-network-devices.rules file, it is now called 70-persistent-net.rules
(and is generated from 75-persistent-net-generator.rules).
Rules for optical devices are now located in 70-persistent-cd.rules (and
are generated from 75-cd-aliases-generator.rules).
You will need to remove the old rules files (75-optical-devices.rules and
75-network-devices.rules) so that they don't conflict.


As stated above, Slackware's udev implementation will automatically create
rules files for your optical devices and network interfaces on first boot.
If you add/remove/replace any of this hardware, and/or you "clone" a system
to another hard drive for deployment, you will need to either remove these
two rules files (so that udev will regenerate them to reflect the new or
changed hardware) or edit them accordingly.


shadowsnipes 05-11-2008 01:03 AM

Quote:

Originally Posted by dimm0k (Post 3149634)
Looks like I've narrowed it down to my xorg.conf file being the culprit, but I have no clue what could be wrong since it was working fine in Slackware 12.0. Here's my conf file.

Code:

Section "InputDevice"
    Identifier  "IntelliMouse"
    Driver      "mouse"
    Option      "Protocol" "ExplorerPS/2"
    Option      "Device" "/dev/input/mice"
    Option      "Buttons" "7"
    Option      "ZAxisMapping" "4 5"
    Option      "Emulate3Buttons"
EndSection

Section "InputDevice"
    Identifier  "Mouse1"
    Driver      "mouse"
    Option      "Protocol"    "PS/2"
    Option      "Device"      "/dev/psaux"
EndSection


Do you use two mice?

Perhaps try
Code:

Option        "Protocol" "Auto"
Edit:
Don't forget to check how your mouse works in a console (no X!)

dimm0k 05-11-2008 01:07 AM

The thing with psmouse is I don't see it loaded at the moment when I do a lsmod | grep psmouse. If I exit KDE, modprobe it and go back into KDE there's absolutely no change...

This is not happening at the console. The weird thing is my notebook's touchpad does the same thing as my USB mouse!

I say I've narrowed it down to the xorg.conf because I loaded a very generic xorg.conf and the mouse works with no problems. Attempts at duplicating only the mouse section does not fix this...

As for my udev directory everything in there looks ok.

dimm0k 05-11-2008 01:12 AM

Quote:

Originally Posted by shadowsnipes (Post 3149642)
Do you use two mice?

Perhaps try
Code:

Option        "Protocol" "Auto"
Edit:
Don't forget to check how your mouse works in a console (no X!)

I don't really use two mice. One is a touchpad and the other is a USB mouse and while I rarely use the touchpad, it's an option I like to have handy.

What do you mean by how my mouse works in a console?

shadowsnipes 05-11-2008 01:51 AM

Quote:

Originally Posted by dimm0k (Post 3149647)
I don't really use two mice. One is a touchpad and the other is a USB mouse and while I rarely use the touchpad, it's an option I like to have handy.

I figured as much

Quote:

Originally Posted by dimm0k (Post 3149647)
What do you mean by how my mouse works in a console?

I mean kill X and just check it on a TTY (runlevel 3 style). Of course you could just go to TTY6 (CTRL+ALT+F6) and test there. You might want to login again and then open a text file to test with.

You said when you click on something it double clicks. In the console with GPM activated this would cause you to highlight a word (one click is a character highlight). A middle click would paste what is highlighted once, where a double middle click would paste twice. I think you get it now...

If there is no problem without X, then it is probably your xorg.conf.
If that is the case, try the auto option I mentioned for one of your mice (your touchpad). Also, try only having one of them in there. I just checked my laptop and I only have one InputDevice listed for mice. I use auto for my protocol and I can easily use my touchpad or USB mouse without problems.

T3slider 05-11-2008 01:58 AM

I don't know that this will affect your specific problem (the double mouse click), but if `lsmod | grep psmouse` returns nothing, you've set something up improperly. I notice you upgraded from 12.0 to 12.1. In 12.0, the psmouse module was blacklisted by default and then later loaded using /etc/rc.d/rc.modules*. In 12.1, it is no longer blacklisted by default, and instead the options for loading the psmouse module are specified in /etc/modprobe.d/psmouse. Therefore, the line loading psmouse in /etc/rc.modules-2.6.24.5-smp is COMMENTED OUT, as it should be.

You should make sure that you are using the generic-smp-2.6.24.5-smp kernel, that rc.modules-2.6.24.5-smp is being loaded at boot time (it won't appear in `dmesg` or in any other logs -- you'll have to watch as your computer boots up. It should say something like "Running rc.modules-2.6.24.5-smp"), and that you only have one blacklist file in /etc/modprobe.d (and it should be the one from 12.1). If your psmouse module is not being loaded by default, it's likely that you have two blacklist files in /etc/modprobe.d. You should have overwritten the old (/etc/modprobe.d/blacklist) file with the new (/etc/modprobe.d/blacklist.new) file. Make sure that you do NOT have a backup of the 12.0 blacklist file in that directory, or else BOTH will be checked and since psmouse is blacklisted in 12.0's blacklist file, it will not be loaded. You should also make sure that /etc/modprobe.d/psmouse exists.
Quote:

Originally Posted by CHANGES_AND_HINTS.TXT
The psmouse module is no longer blacklisted by default; instead, it is loaded
with the imps protocol per /etc/modprobe.d/psmouse -- if you need/want a
different protocol, edit that file. Note that options declarations have
no bearing on *if* a module is loaded - they only affect *how* it is loaded.
In other words, the module should now be loaded automatically (since it's no
longer blacklisted), and the options in /etc/modprobe.d/psmouse are the ones
applied when loading it.

The /etc/modprobe.d/blacklist file has been changed significantly; be sure to
move/merge the /etc/modprobe.d/blacklist.new file in its place. Also, you
must NOT leave a backup of the old blacklist file (such as blacklist.orig)
in /etc/modprobe.d/ -- ALL files in that directory are checked, so if a
module is blacklisted in *any* of them, it won't be loaded.

See this post for more details (you can safely ignore the bit about HP Device Manager): http://www.linuxquestions.org/questi...3/#post3149474

I am not sure if that will affect your problem or not, but it seems something is awry anyway and should be fixed regardless.

dimm0k 05-11-2008 09:27 PM

Thanks guys for your suggestions and help. It looks like I've narrowed down my issue to the following two arguments:

Option "SendCoreEvents" "true"
"CorePointer"

Apparently giving IntelliMouse the "CorePointer" option and the touchpad the other fixes the issue.


All times are GMT -5. The time now is 07:55 PM.