LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-15-2003, 01:35 AM   #1
Berhanie
Senior Member
 
Registered: Dec 2003
Location: phnom penh
Distribution: Fedora
Posts: 1,625

Rep: Reputation: 165Reputation: 165
mounting usb floppy


in order to mount my usb floppy drive,
I added the following line to my /etc/fstab:

/dev/sda /mnt/floppy auto noauto,user 0 0

when i tried to mount my floppy using "mount /dev/sda",
everything worked fine, but when I tried "mount /mnt/floppy",
the computer hung until I killed the process, at which point it
returned an error message regarding /dev/fd0 (I don't have an
internal floppy drive, by the way).

Now, when I changed the entry in fstab to

/dev/sda /mnt/usbfd auto noauto,user 0 0

I had no problem with "mount" whether specifying /dev/sda or
/mnt/usbfd



What's the reason for this? Why does it care whether
I mount it on /mnt/floppy or /mnt/usbfd?

On a related note, what is the /mnt/hd? It was created
by default.

Thanks.

Last edited by Berhanie; 12-15-2003 at 03:38 AM.
 
Old 12-15-2003, 12:29 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,966
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
It doesn't... my educated guess would be
that you didn't unmount the device before
mounting the mount-point :)


Cheers,
Tink
 
Old 12-15-2003, 12:37 PM   #3
CoryS
LQ Newbie
 
Registered: Oct 2003
Location: Illinois
Distribution: Slackware 10.1
Posts: 4

Rep: Reputation: 0
This may sound like a dumb question...

... but did you make sure that there's not another /mnt/floppy entry in the fstab that points to /dev/fd0? Sounds like it tried to mount the nonexistent /dev/fd0 over top of the already mounted /dev/sda.
 
Old 12-15-2003, 12:57 PM   #4
Berhanie
Senior Member
 
Registered: Dec 2003
Location: phnom penh
Distribution: Fedora
Posts: 1,625

Original Poster
Rep: Reputation: 165Reputation: 165
Thank you very much, Tinkster and CoryS.
It turned out there was another entry for /mnt/floppy
that I missed.
 
Old 12-15-2003, 04:44 PM   #5
Berhanie
Senior Member
 
Registered: Dec 2003
Location: phnom penh
Distribution: Fedora
Posts: 1,625

Original Poster
Rep: Reputation: 165Reputation: 165
ok, so now i can mount my floppy with "mount /mnt/floppy" and
with "mount /dev/sda".
the problem is that when i try to modify an existing file on the floppy
and try to save the modified file, i get a message saying "file exists" (even though i'm root) and it won't let me save. however i can create new files on the floppy without problem.

how can i fix that?

thank you.
 
Old 12-15-2003, 05:01 PM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,966
Blog Entries: 11

Rep: Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865Reputation: 865
Which tool/editor are you using to modify
the files? What happens if you let's say
create a file on the floppy using touch,
and then echo into it?

touch /mnt/floppy/test
echo "Just testing" > /mnt/floppy/test
echo "Still testing" >> /mnt/floppy/test

What are the permissions on the files?



Cheers,
TInk
 
Old 12-15-2003, 10:18 PM   #7
Berhanie
Senior Member
 
Registered: Dec 2003
Location: phnom penh
Distribution: Fedora
Posts: 1,625

Original Poster
Rep: Reputation: 165Reputation: 165
Hello again, Tinkster. Thank you for your help.
I use vi to modify the files. I still can't do it. I can
only create. But the opposite is true when I echo
into it. Here's my script file:

root@hp:/mnt# ls -l|grep floppy
drwxr-xr-x 2 root root 4096 Dec 14 22:24 floppy
root@hp:/mnt# mount /mnt/floppy
root@hp:/mnt# ls -l|grep floppy
drwxr--r-- 2 root root 7168 Dec 31 1969 floppy
root@hp:/mnt# cd floppy
root@hp:/mnt/floppy# ls -l
total 0
root@hp:/mnt/floppy# touch test
touch: setting times of `test': No such file or directory
root@hp:/mnt/floppy# ls -l
total 0
-rwxr--r-- 1 root root 0 Dec 15 20:00 test
root@hp:/mnt/floppy# echo "testing" >test
bash: test: No such file or directory
root@hp:/mnt/floppy# ls -l
total 0
-rwxr--r-- 1 root root 0 Dec 15 20:00 test
root@hp:/mnt/floppy# echo "testing" >>test
root@hp:/mnt/floppy# ls -l
total 1
-rwxr--r-- 1 root root 8 Dec 15 20:00 test
root@hp:/mnt/floppy# echo "the end" >test
bash: test: No such file or directory
root@hp:/mnt/floppy# ls -l
total 1
-rwxr--r-- 1 root root 8 Dec 15 20:00 test
root@hp:/mnt/floppy#
Script done on Mon Dec 15 20:01:33 2003
 
Old 12-18-2003, 11:59 AM   #8
AceTech747
Member
 
Registered: Nov 2003
Distribution: RH 9.0
Posts: 144

Rep: Reputation: 15
When you are in the VI did you press the I key to edit the text that you have?
 
Old 12-18-2003, 12:31 PM   #9
Berhanie
Senior Member
 
Registered: Dec 2003
Location: phnom penh
Distribution: Fedora
Posts: 1,625

Original Poster
Rep: Reputation: 165Reputation: 165
yes, i entered new text, but when i tried to
save the file again, it said something like
"file exists". it didn't help when i used w! to
write the file.
check out that funny timestamp on the /mnt/floppy
directory after i mounted it.
 
Old 12-23-2003, 02:24 PM   #10
Berhanie
Senior Member
 
Registered: Dec 2003
Location: phnom penh
Distribution: Fedora
Posts: 1,625

Original Poster
Rep: Reputation: 165Reputation: 165
Problem Solved!

It turned out that since I let the system autodetect the filesystem
type, it mount the floppy as umsdos instead of vfat. I'll have to
adjust my fstab or create an /etc/filesystems as described in the
mount man page.

Thank you for all the contributions.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting USB Floppy in Mandrake 10 ltd602 Linux - Hardware 3 10-16-2004 02:08 PM
OpenBSD: problems mounting usb floppy Berhanie *BSD 2 09-19-2004 09:53 PM
Mounting USB floppy in Red Hat 9? LDZ420 Linux - Newbie 2 04-26-2004 11:32 AM
Internal floppy to USB Floppy kbvaldez Linux - Newbie 0 08-21-2003 11:11 AM
mounting a usb floppy transfix Linux - Newbie 1 12-30-2001 08:24 PM


All times are GMT -5. The time now is 03:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration