LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-09-2007, 08:27 AM   #1
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,406

Rep: Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829
Mounting CIFS file systems at boot with Slackware 12.0


I have been converting the mounts on my Samba servers from smbfs file systems to cifs file systems as the smbfs file system is now deprecated. The smbfs file systems could be automatically mounted at boot time, but after conversion to cifs they are not automatically mounted at boot. After boot a simple "mount -a" fixes things.

To get the cifs file systems to be automatically recognised at boot, I have found that I need to add this code to /etc/rc.d/rc.inet2 after the code to mount remote SMB filesystems.

Code:
# Mount remote (CIFS) filesystems:
if cat /etc/fstab | grep -v '^#' | grep -w cifs 1> /dev/null 2> /dev/null ; then
  echo "Mounting remote (CIFS) file systems:  /sbin/mount -a -t cifs"
  /sbin/mount -a -t cifs
  # Show the mounted volumes:
  /sbin/mount -v -t cifs
fi
 
Old 10-09-2007, 08:30 AM   #2
indienick
Senior Member
 
Registered: Dec 2005
Location: London, ON, Canada
Distribution: Arch, Ubuntu, Slackware, OpenBSD, FreeBSD
Posts: 1,853

Rep: Reputation: 65
Did you have a particular question about SMB/CIFS shares, or were you just sharing your solution with us?
 
Old 10-09-2007, 08:31 AM   #3
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
I'm guessing there is no question here, just a comment about CIFS not being automatically mounted by default in Slackware.
 
Old 10-09-2007, 08:34 AM   #4
indienick
Senior Member
 
Registered: Dec 2005
Location: London, ON, Canada
Distribution: Arch, Ubuntu, Slackware, OpenBSD, FreeBSD
Posts: 1,853

Rep: Reputation: 65
Fair enough.
Is this a problem with other distributions, by any chance? I can't test it out right now (as I'm at work), but also the fact that my SMBFS shares at home have never given me any issues, so why mess with stability (aside from the obvious entertainment that could ensue)?

I didn't know smbfs was deprecated, though.
 
Old 10-09-2007, 08:57 AM   #5
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,406

Original Poster
Rep: Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829
Sorry,
I should have it made it clear that this was just a comment.
 
Old 10-09-2007, 09:25 AM   #6
indienick
Senior Member
 
Registered: Dec 2005
Location: London, ON, Canada
Distribution: Arch, Ubuntu, Slackware, OpenBSD, FreeBSD
Posts: 1,853

Rep: Reputation: 65
It's all good.
Perhaps you should submit this to the Linux Answers section?
 
Old 10-09-2007, 03:32 PM   #7
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,223

Rep: Reputation: Disabled
Quote:
Originally Posted by allend View Post
I have been converting the mounts on my Samba servers from smbfs file systems to cifs file systems as the smbfs file system is now deprecated. The smbfs file systems could be automatically mounted at boot time, but after conversion to cifs they are not automatically mounted at boot. After boot a simple "mount -a" fixes things.

To get the cifs file systems to be automatically recognised at boot, I have found that I need to add this code to /etc/rc.d/rc.inet2 after the code to mount remote SMB filesystems.

Code:
# Mount remote (CIFS) filesystems:
if cat /etc/fstab | grep -v '^#' | grep -w cifs 1> /dev/null 2> /dev/null ; then
  echo "Mounting remote (CIFS) file systems:  /sbin/mount -a -t cifs"
  /sbin/mount -a -t cifs
  # Show the mounted volumes:
  /sbin/mount -v -t cifs
fi
This has been fixed in slackware-current which is still not publicly available (no idea when it will though, and don't ask).

Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting windows share via cifs (fstab entry) - error 13 opening credentials file O(V)eGA_l2el) Linux - Networking 2 12-05-2006 11:22 AM
stuck after mounting file systems ashlesha Linux - Kernel 0 10-28-2006 07:16 PM
Mounting 2 file systems to one directory leupi Linux - Networking 7 01-21-2006 10:29 PM
Mounting to file systems n e r d Linux - Hardware 3 07-22-2004 07:53 AM
mounting file systems philfighter Linux - General 5 08-20-2001 08:20 PM


All times are GMT -5. The time now is 03:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration