LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-30-2003, 10:21 AM   #1
bynaar
Member
 
Registered: Jul 2002
Posts: 141

Rep: Reputation: 15
Mounted partitions in slack 9.0 ?!


Hello !

This is probably easy to fix, I have installed the slackware 9.0 experience now.
I was installing from the cd-rom , and I just installed it over yhe old 8.1.
When prompted if I wanted to formating my / partition , I choosed NO .

Everything seems to work ok , exept from one thing:

this is the problem:
When logging in as an ordinary user, I can't access my mounted FAT32 partitions, I can howewer access them as root.

I did not have any problems accessing partitions, with the 8.1 release.

Happy for help !
 
Old 03-30-2003, 01:40 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,985
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Use the search, Luke!

Cheers,
Tink
 
Old 03-30-2003, 02:04 PM   #3
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
I discovered yesterday that Slack 9.0 does not use the default umask setting from /etc/profile the way it should and the way it has been in the past. You need to mount the vfat partitions using a mount option to set the umask to 022 or 000. It is now mounting the partitions with a umask of 033 unless it is instructed otherwise. If you use the /etc/fstab to mount the partition at boot, then add it to the options as umask=000. If you mount manually or through rc.local then use "-o umask=000" in the mount command. Perhaps it will help with your problem.
 
Old 03-30-2003, 04:41 PM   #4
bynaar
Member
 
Registered: Jul 2002
Posts: 141

Original Poster
Rep: Reputation: 15
Ok . I added the umask=000 on two partitions, this was my 8.1 setting.
Added umask=000 in order to write to those partitions as a 'user'

So the new thing is that one have to use the umask, just to read partitions

here's my fstab:

/dev/hda7 /mnt/hda7 vfat defaults,iocharset=iso8859-1,umask=000 1 0
/dev/hda8 /mnt/hda8 vfat defaults,iocharset=iso8859-1 1 0
/dev/hda9 /mnt/hda9 vfat defaults,iocharset=iso8859-1 1 0

/dev/hdb5 /mnt/hdb5 vfat defaults,iocharset=iso8859-1 1 0
/dev/hdb7 /mnt/hdb7 vfat defaults,iocharset=iso8859-1 1 0
/dev/hdb8 /mnt/hdb8 vfat defaults,iocharset=iso8859-1 1 0
/dev/hdb9 /mnt/hdb9 vfat defaults,iocharset=iso8859-1 1 0
/dev/hdb10 /mnt/hdb10 vfat defaults,iocharset=iso8859-1 1 0
/dev/hdb11 /mnt/hdb11 vfat defaults,iocharset=iso8859-1,umask=000 1 0
/dev/hdb12 /mnt/hdb12 vfat defaults,iocharset=iso8859-1 1 0
 
Old 03-30-2003, 07:38 PM   #5
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
In my tests the umask setting was 033 instead of the set default umask. Now, 033 should produce rwxr--r-- permissions that should allow read for all users. However, if some programs have problems with it then add the umask setting of 022 and that would be using the Slack default (rwxr-xr-x). Also, there are two new settings available, fmask and dmask. You can review the man page (man mount) for more info regarding the use.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Acessing mounted partitions stevesk Linux - Newbie 11 12-15-2004 03:40 AM
How many NFS partitions can be mounted? ksingh Linux - Software 1 09-10-2004 03:29 AM
partitions not mounted at boot jackren Debian 1 03-20-2004 07:59 PM
can i have a few partitions mounted in one directory ? baronlynx Linux - Newbie 1 02-27-2004 03:46 AM
Slack 9: mounted FAT32 partitions cannot be accessed by normal user Obi-Wan_Kenobi Slackware 6 07-12-2003 11:15 PM


All times are GMT -5. The time now is 07:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration