LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Mounted partitions in slack 9.0 ?! (http://www.linuxquestions.org/questions/slackware-14/mounted-partitions-in-slack-9-0-a-52498/)

bynaar 03-30-2003 11:21 AM

Mounted partitions in slack 9.0 ?!
 
Hello !

This is probably easy to fix, I have installed the slackware 9.0 experience now.
I was installing from the cd-rom , and I just installed it over yhe old 8.1.
When prompted if I wanted to formating my / partition , I choosed NO .

Everything seems to work ok , exept from one thing:

this is the problem:
When logging in as an ordinary user, I can't access my mounted FAT32 partitions, I can howewer access them as root.

I did not have any problems accessing partitions, with the 8.1 release.

Happy for help !

Tinkster 03-30-2003 02:40 PM

Use the search, Luke!

Cheers,
Tink

Excalibur 03-30-2003 03:04 PM

I discovered yesterday that Slack 9.0 does not use the default umask setting from /etc/profile the way it should and the way it has been in the past. You need to mount the vfat partitions using a mount option to set the umask to 022 or 000. It is now mounting the partitions with a umask of 033 unless it is instructed otherwise. If you use the /etc/fstab to mount the partition at boot, then add it to the options as umask=000. If you mount manually or through rc.local then use "-o umask=000" in the mount command. Perhaps it will help with your problem.

bynaar 03-30-2003 05:41 PM

Ok . I added the umask=000 on two partitions, this was my 8.1 setting.
Added umask=000 in order to write to those partitions as a 'user'

So the new thing is that one have to use the umask, just to read partitions

here's my fstab:

/dev/hda7 /mnt/hda7 vfat defaults,iocharset=iso8859-1,umask=000 1 0
/dev/hda8 /mnt/hda8 vfat defaults,iocharset=iso8859-1 1 0
/dev/hda9 /mnt/hda9 vfat defaults,iocharset=iso8859-1 1 0

/dev/hdb5 /mnt/hdb5 vfat defaults,iocharset=iso8859-1 1 0
/dev/hdb7 /mnt/hdb7 vfat defaults,iocharset=iso8859-1 1 0
/dev/hdb8 /mnt/hdb8 vfat defaults,iocharset=iso8859-1 1 0
/dev/hdb9 /mnt/hdb9 vfat defaults,iocharset=iso8859-1 1 0
/dev/hdb10 /mnt/hdb10 vfat defaults,iocharset=iso8859-1 1 0
/dev/hdb11 /mnt/hdb11 vfat defaults,iocharset=iso8859-1,umask=000 1 0
/dev/hdb12 /mnt/hdb12 vfat defaults,iocharset=iso8859-1 1 0

Excalibur 03-30-2003 08:38 PM

In my tests the umask setting was 033 instead of the set default umask. Now, 033 should produce rwxr--r-- permissions that should allow read for all users. However, if some programs have problems with it then add the umask setting of 022 and that would be using the Slack default (rwxr-xr-x). Also, there are two new settings available, fmask and dmask. You can review the man page (man mount) for more info regarding the use.


All times are GMT -5. The time now is 10:10 PM.