LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-27-2004, 07:35 PM   #1
ernesto_lelo
Member
 
Registered: Oct 2003
Posts: 49

Rep: Reputation: 15
Question mount DVD Rom & CD-R/RW


Hello everybody.
I just move to Slackware 10 and I've been trying to set my system, but I'm having a bad time with my DVD Rom and my CD-R/RW (both liteon).
First I had the idea that Slackware was detecting more device. I got this Idea after checking my dmesg...

Here is a copy of my dmesg file:

hda: ST340823A, ATA DISK drive
hdb: LITE-ON LTR-52246S, ATAPI CD/DVD-ROM drive
blk: queue c03b3360, I/O limit 4095Mb (mask 0xffffffff)
hdc: WDC WD400EB-00CPF0, ATA DISK drive
hdd: JLMS DVD-ROM LTD-166S, ATAPI CD/DVD-ROM drive
blk: queue c03b37b4, I/O limit 4095Mb (mask 0xffffffff)
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 78165360 sectors (40021 MB) w/512KiB Cache, CHS=4865/255/63, UDMA(100)
hdc: attached ide-disk driver.
hdc: host protected area => 1
hdc: 78165360 sectors (40021 MB) w/2048KiB Cache, CHS=77545/16/63, UDMA(33)
hdb: attached ide-cdrom driver.
hdb: ATAPI 52X CD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.12
hdd: attached ide-cdrom driver.
hdd: ATAPI 48X DVD-ROM drive, 512kB Cache, UDMA(33)



Now I read on a different thread that by editing my fstab file it should work. (assuming that my DVD is on hdd and my CD-R/RW is on hdb). So I changed it. Here is a copy of my fstab...

/dev/hdc2 swap swap defaults 0 0
/dev/hdc1 / reiserfs defaults 1 1
/dev/hda1 /WindowsXP ntfs ro 1 0
/dev/hdd /mnt/dvd auto noauto,users,ro 0 0
/dev/hdb /mnt/cdrw auto noauto,users,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0



But still is giving me problems. Now when I try to mount any of them (using the following command:
Code:
mount /mnt/dvd
) it gives me the following error...

/dev/hdd: Input/output error
mount: you must specify the filesystem type


any suggestion????

Although I posted my problem on a different thread I was advice to create a new one, so I'm doing it....
 
Old 09-27-2004, 07:47 PM   #2
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Rep: Reputation: 49
You've got:
Quote:
/dev/hdd /mnt/dvd auto noauto,users,ro 0 0
/dev/hdb /mnt/cdrw auto noauto,users,ro 0 0
You should try:
Code:
/dev/hdd  /mnt/dvd   iso9660   noauto,users,ro  0   0
/dev/hdb  /mnt/cdrw  iso9660   noauto,users,ro  0   0
Additionally, I add nosuid to both of mine, but that is just me.
 
Old 09-27-2004, 07:49 PM   #3
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Change your entries for the CD-RW and DVD-ROM like this:

Code:
/dev/hdb         /mnt/cdrw        iso9660     noauto,users,ro   0   0
/dev/hdd         /mnt/dvd         iso9660     noauto,users,ro   0   0

Last edited by Bruce Hill; 09-27-2004 at 07:52 PM.
 
Old 09-27-2004, 08:42 PM   #4
ernesto_lelo
Member
 
Registered: Oct 2003
Posts: 49

Original Poster
Rep: Reputation: 15
Thanks for the quick response.
I tried your suggestion (both of you suggested the same thing) and I actually got to see the data on a data CD using both devices but when trying to use a music CD now the error message changed to this...

mount: wrong fs type, bad option, bad superblock on /dev/hdd,
or too many mounted file systems

any idea ???
 
Old 09-27-2004, 08:47 PM   #5
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Quote:
Originally posted by ernesto_lelo
when trying to use a music CD now the error message changed to this...

mount: wrong fs type, bad option, bad superblock on /dev/hdd,
or too many mounted file systems

any idea ???
You can't mount music CDs in Linux - that I know of - at
least not the .cda files. You can play them, however,
and for this I install the xmms-cdread-0.11d.tar.gz plugin
and then just stick them in the drive without trying to
mount them and play with XMMS.
 
Old 10-28-2004, 09:38 PM   #6
lukeh
LQ Newbie
 
Registered: Aug 2004
Posts: 5

Rep: Reputation: 0
this reply might be a bit late but I had a similar problem. If you are using the 'hdc=ide-scsi' flag with your kernel then to mount a dvdrom I needned to mount it like 'mount /dev/sr0 /mnt/dvd'

hope this helps
Luke H.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount cd/dvd -rom,change permission darkangel29 Linux - Newbie 10 04-16-2005 02:24 AM
can't mount a dvd on a cd burner/dvd rom drive dr_zayus69 Linux - Hardware 7 12-09-2004 09:56 AM
can't mount dvd rom or hard disc... gbdavidx Slackware 3 11-12-2004 04:34 AM
cd-rom and dvd-rom drives won't mount... :-( Ausar Linux - Newbie 12 09-01-2004 03:51 PM
cannot mount cd/dvd rom xone Linux - Hardware 2 04-05-2004 06:09 PM


All times are GMT -5. The time now is 11:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration