LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-10-2004, 12:59 PM   #1
derfaust
Member
 
Registered: Feb 2004
Location: TX, USA
Distribution: slack 9.1, 10, and 10.2
Posts: 144

Rep: Reputation: 15
mount cdrom as non-root user


how do you mount a cd-rom in slack 9.1 as a regular user?....i know how to do it as root, but that gets quite annoying....having to su over all the time.....

thanks for your time....and i know the answer is something simple....lol...

rock!

Last edited by derfaust; 03-10-2004 at 01:01 PM.
 
Old 03-10-2004, 01:05 PM   #2
superbondbond
Member
 
Registered: Nov 2002
Posts: 668

Rep: Reputation: 30
you need to edit your /etc/fstab. look for the line for your cdrom, and change where it says "owner" to read "users"

Code:
/dev/sr0         /mnt/cdrom       iso9660     noauto,users,ro   0   0
 
Old 03-10-2004, 01:31 PM   #3
derfaust
Member
 
Registered: Feb 2004
Location: TX, USA
Distribution: slack 9.1, 10, and 10.2
Posts: 144

Original Poster
Rep: Reputation: 15
i tried that, it didnt seem work....i even rebooted....lol....how do you restart that service when you change fstab?...

here id my fstab....just so you one could see it...and on the sam topic...how do i automount a windows network share?...i tried in the last line...but no love...

thanks for the quick reply!!

-derfaust

/dev/hdb3 swap swap defaults 0 0
/dev/hdb2 / reiserfs defaults 1 1
/dev/hdb1 /boot ext2 defaults 1 2
/dev/hdb4 /home reiserfs defaults 1 2
/dev/hda2 /mnt/data ntfs auto,owner,umask=022 0 0
/dev/hda1 /mnt/windows ntfs auto,owner,umask=022 0 0
/dev/hda5 /mnt/programs ntfs auto,owner,umask=022 0 0
/dev/hdc1 /mnt/storage ntfs auto,owner,umask=022 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,users,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
//10.0.0.3/e /mnt/tv_e smbfs auto,users,umask=022,guest 0 0
 
Old 03-10-2004, 01:44 PM   #4
superbondbond
Member
 
Registered: Nov 2002
Posts: 668

Rep: Reputation: 30
You shouldn't need to restart any services to take affect.
Try "user" instead of "users" and see what it does.
 
Old 03-10-2004, 01:52 PM   #5
derfaust
Member
 
Registered: Feb 2004
Location: TX, USA
Distribution: slack 9.1, 10, and 10.2
Posts: 144

Original Poster
Rep: Reputation: 15
tried but it still gripes that i, "must be superuser to mount"....i tried to change the permissions to /bin/mount...

no love....

keep the ideas a flowin....

Last edited by derfaust; 03-10-2004 at 01:53 PM.
 
Old 03-10-2004, 06:08 PM   #6
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 535

Rep: Reputation: 30
try first checking where your /dev/cdrom actually points to by
ls -l /dev/cdrom
then edit your /etc/fstab according to that device to see it it works.
After that as root
rm /dev/cdrom and
ln -s /dev/xxx /dev/cdrom
this should re-extabilish a right link if missing
Hope this helps
Ciao
 
Old 03-10-2004, 07:52 PM   #7
derfaust
Member
 
Registered: Feb 2004
Location: TX, USA
Distribution: slack 9.1, 10, and 10.2
Posts: 144

Original Poster
Rep: Reputation: 15
well...i just tried that as well.....still no love...

hmmmm???

i figured it would be easier than this.....lol

like my sig says.....
 
Old 03-10-2004, 08:06 PM   #8
newinlinux
Member
 
Registered: Dec 2003
Location: Next to Equator
Distribution: GNU/Linux 2.6.14
Posts: 382

Rep: Reputation: 30
not sure if adding umask=000 after ro will help you, mine has it and it works, sorry, this is just blind copying without understanding on my part.
 
Old 03-10-2004, 11:05 PM   #9
nutronix
Member
 
Registered: Jan 2003
Location: montreal
Distribution: Slackware and XUbuntu
Posts: 110
Blog Entries: 1

Rep: Reputation: 17
i had that problem with slack-8.1 and here is the solution i also applied in 9.0 ;

like mentioned above , find your cdrom link;
ls -l /dev/cdrom
as root ; cdrecord -scanbus tells you about your cdrom device;
mine is 0,0,0 therefore /dev/sr0 (on account of scsi emulation i think);
so i did ln -sf /dev/sr0 /dev/cdrom do not forget the space after -sf
check your link again

i also changed permissions with chmod a+rw /dev/cdrom
let us know , good luck

p.s.=my fstab entry =/dev/cdrom /mnt/cdrom iso9660 noauto,user,ro 0 0

Last edited by nutronix; 03-10-2004 at 11:06 PM.
 
Old 03-11-2004, 01:17 AM   #10
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
What's the mount command you are issuing? With the correct fstab (looked right above) and if the symlinks are correct, a simple 'mount /mnt/cdrom' should do it.
 
Old 03-11-2004, 05:25 PM   #11
derfaust
Member
 
Registered: Feb 2004
Location: TX, USA
Distribution: slack 9.1, 10, and 10.2
Posts: 144

Original Poster
Rep: Reputation: 15
hrm...that did not do it either.....this should be an easy thing to do, yes??

is thier any more information i could give that would help??

here id my fstab again...


/dev/hdb3 swap swap defaults 0 0
/dev/hdb2 / reiserfs defaults 1 1
/dev/hdb1 /boot ext2 defaults 1 2
/dev/hdb4 /home reiserfs defaults 1 2
/dev/hda2 /mnt/data ntfs auto,owner,umask=022 0 0
/dev/hda1 /mnt/windows ntfs auto,owner,umask=022 0 0
/dev/hda5 /mnt/programs ntfs auto,owner,umask=022 0 0
/dev/hdc1 /mnt/storage ntfs auto,owner,umask=022 0 0
/dev/hdd /mnt/cdrom iso9660 noauto,user,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
//10.0.0.3/e /mnt/tv_e smbfs auto,user,umask=022,guest 0 0
//10.0.0.3/c /mnt/tv_c smbfs auto,user,umask=022,guest 0 0
//10.0.0.3/f /mnt/tv_f smbfs auto,user,umask=022,guest 0 0


thanks....
 
Old 03-11-2004, 06:15 PM   #12
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Rep: Reputation: 137Reputation: 137
Is the cd drive a cd/rw or dvd combo drive, if it is perhaps appending "hdd=ide-scsi" in lilo will help. I then created a cdrom icon in kde and I just click to mount. Though you still have to umount or eject.

Also changing noauto to auto should automatically mount the cd drive, though I don't know if this will be a problem without a cd in the drive.
 
Old 03-11-2004, 08:53 PM   #13
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
skimming the post, excuse me if i repeat anything

first, make sure you are mounting the correct device; check output of dmesg for the device name

now, make sure that device has proper permissions; do chmod 777 /dev/hdx

what kernel version are you running? if you are using a 2.4.x kernel, add the line append hdx=ide-scsi to your lilo.conf file (somewhere near the top); if you are using 2.6.x, use append hdx=ide-cd

if you use ide-scsi, your cd drive is going to be /dev/sr0; do chmod 777 /dev/sr0; now make a symlink like so: ln -s /dev/sr0 /dev/cdrom; if using ide-cd, do ln -s /dev/hdx /dev/cdrom

do chmod 777 /dev/cdrom

do chmod 777 /mnt/cdrom

now edit your fstab and add this line
/dev/cdrom /mnt/cdrom iso9660 noauto,user 0 0

now you should be able to say mount /mnt/cdrom and mount as a user
 
Old 03-12-2004, 02:05 PM   #14
derfaust
Member
 
Registered: Feb 2004
Location: TX, USA
Distribution: slack 9.1, 10, and 10.2
Posts: 144

Original Poster
Rep: Reputation: 15
nope....none of that has worked so far....

i could stand on my head and sing, "the sound of music"....would that help?...

this is irritating....i have spent days on what should have taken about 15 minutes(if even that, regardless of the operating system)....it still does not work right....hrmmmm....hrmmmm....hrmmmm.....

please does anybody "know"?.... no guesses please!!!!!

thanks for your time...

dig
 
Old 03-12-2004, 02:31 PM   #15
TheOneAndOnlySM
Member
 
Registered: Jul 2003
Location: Dallas, TX
Distribution: Ubuntu 10.04 LTS
Posts: 987

Rep: Reputation: 30
the only thing i didn't mention in my previous post was to do chmod 777 /dev/sr0 if you have ide-scsi emulation enabled

while i was definitely not making any guess in my last post, i know it was a lot of information, so i could have missed some specific command

okay, so i will need information (and will probably include lots of copying and pasting to this forum)

what kernel are you using? do uname -r to find out
do you have ide-scsi emulation enabled? check lilo.conf, and also post the dmesg lines that regard to the detection of the harddrives, cddrives, etc.
post output of file /dev/cdrom
post output of ls -l /dev/cdrom, ls -l /dev/sr0, ls -l /dev/hdx (where hdx is your cd device)
finally, post your fstab (if you have changed it from your previous fstab posting)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to give not-root user ability to mount devices to any mount point??? jdupre Linux - General 8 02-04-2012 11:03 AM
Non-root cdrom mount kleptophobiac Slackware 9 02-15-2005 06:59 PM
Why can't a non-root user mount a cdrom? dokterneo Slackware 8 12-21-2003 08:01 PM
Cannot mount cdrom as user or root in Mandrake 8.2 TlitJ Linux - General 11 09-09-2003 04:51 PM
Unresolved : Cannot access cdrom mount from any user except root??? acadcworks Linux - General 5 10-18-2002 12:08 PM


All times are GMT -5. The time now is 11:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration