LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-25-2003, 01:14 AM   #1
lt1derful
Member
 
Registered: Jul 2003
Distribution: Slackware 9.1; Gentoo
Posts: 68

Rep: Reputation: 15
More Mplayer CRAP! Won't run...


After ./configure; make; and make install all ran ERROR FREE...Mplayer won't load!!!

I get this when I run Mplayer:

Quote:
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/local/share/locale


MPlayer 0.90rc5-3.2.2 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Intel Pentium 4 Willamette (Family: 8, Stepping: 10)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /root/.mplayer/config
Reading /root/.mplayer/codecs.conf: can't open '/root/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: 50 audio & 136 video codecs
Usage: mplayer [options] [url|path/]filename
That is followed by a list of Basic Options and Basic Keys.

A couple things I notice: /usr/local/etc/mplayer does not have a mplayer.conf file...why? It does however have a condecs.conf file. I don't have a /root/.mplayer directory...again, why? Shouldn't this stuff be there after having configured and installed Mplayer?

Man, this program is KILLING me!!!!

Did I do something wrong? Is there more that needs to be tweaked? Any help, greatly appreciated...and yes, I've used search and cannot locate answers that have resolved anything.
 
Old 07-25-2003, 02:15 AM   #2
Riley
Member
 
Registered: Feb 2003
Location: SC, USA
Distribution: Mandrake 10.0 Powerpack
Posts: 178

Rep: Reputation: 30
Did you specify a media file to play? Cause unless you're using the gui it won't stay running unless you do. That's what looks like is happening since it gives the usage thing.

The directories and files should be there unless you installed as a user. I've never had problems with compiling and installing it so I don't really know what to tell you beyond that.
 
Old 07-25-2003, 03:07 AM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
Code:
Usage: mplayer [options] [url|path/]filename
i'd strongly suggest you actually *read* the messages there.... see the man page and documentation for more information.

Last edited by acid_kewpie; 07-25-2003 at 03:08 AM.
 
Old 07-25-2003, 05:56 AM   #4
Rodrin
Member
 
Registered: May 2003
Location: Upstate NY, U.S.
Distribution: Slackware
Posts: 247

Rep: Reputation: 31
I don't see anything wrong here. Those are all normal messages unless you set up special configurations for MPlayer to use. The problem here is that you are trying to start MPlayer from the command line like you could Xine without a file to play. By default, MPlayer's user interface works in command line only mode, which means that if you don't give it a file, it has nothing to put up on the screen. If you do give it a file, then it displays the video of your file, but it does not display a gui. If you want to use a gui, you need to start it with gmplayer. Be warned, though, that you need more things installed and configured for the gui to work than you do for the command line interface. If you don't have a skin and fonts configured correctly for it, it won't work.
 
Old 07-25-2003, 03:07 PM   #5
lt1derful
Member
 
Registered: Jul 2003
Distribution: Slackware 9.1; Gentoo
Posts: 68

Original Poster
Rep: Reputation: 15
OK...so now. I've reconfigured and installed Mplayer with --enable-gui

So, when I try to launch gmplayer...it can't find <default skin>...I've downloaded skins, and from what I've gathered I need to edit gui.conf in order to tell it which skin to load.

Here's my only problem. THE ONLY .CONF file I can find is codecs.conf!! No mplayer.conf and no gui.conf!!!!

I am so starting to hate this friggin' thing so bad.

Any help?
 
Old 07-25-2003, 04:04 PM   #6
Riley
Member
 
Registered: Feb 2003
Location: SC, USA
Distribution: Mandrake 10.0 Powerpack
Posts: 178

Rep: Reputation: 30
try putting the skins in ~/.mplayer/Skin

gui.conf should be in ~/.mplayer/
when you try to run gmplayer it'll tell you if it's there or not. Create it if it's not there and set
gui_skin = "SkinName"

Last edited by Riley; 07-25-2003 at 04:19 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to run MPlayer GUI ? thandermax Linux - Newbie 2 07-04-2005 07:08 PM
Can't run Mplayer dolphans1 Mandriva 14 06-03-2005 09:03 AM
How to run Mplayer with GUI ? xelt Linux - Software 2 04-28-2005 05:27 PM
Linspire = Crap, Netzero also = Crap rm6990 General 16 09-20-2004 03:35 AM
How do I run mplayer Fear58 Linux - Software 8 06-13-2004 09:57 AM


All times are GMT -5. The time now is 11:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration