LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-07-2006, 12:16 PM   #1
phunkymunky
Member
 
Registered: Aug 2003
Location: Glasgow, Scotland
Distribution: Slackware 14.0, Debian 7.0
Posts: 60

Rep: Reputation: 22
Mono - problem with glib


Hope you Slackers can help..i'm not a noob but can't seem to fix this. I need to install mono/monodevelop etc for an upcoming job (need to learn c#). I have installed using the binary installer from the mono site and it installed OK (to a point).
I can write programs, compile and run them from command line(using mcs and mono) but I want to use the IDE (monodevelop). When I run monodevelop from the command line it says it can't find System.xxxx.xxx.libgnomeui.xxx so I download libgnomeui try to install it and get error saying can't find libgnome so download that, install gets the error that it can't find gnome-vfs so download that and get the error that glib is wrong version (2.8.6 need >=2.9.3) so this is where i get the problem.

First problem is to do with glib, some links for glib-2.9.3 point to glib2.0-2.9.3, are glib and glib2.0 the same, I have both installed.

I downloaded and installed glib-2.9.3 and some other glib2.0 stuff just to make sure.

pkg-config is OK, PATH is OK but configure for gnome-vfs just cannot find the correct glib version.

Any ideas on the steps to either uninstall/reinstall/configure glib and/or any other steps needed to get this to work.

I have already spent 3 days trying to get this to work so any help would be great.

Thanks

phunkymunky
 
Old 06-08-2006, 04:54 AM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,555

Rep: Reputation: 424Reputation: 424Reputation: 424Reputation: 424Reputation: 424
since my base system was 10.1, i have GNOME installed on my system and then, i just have to upgrade glib and gtk or other packages and it worked well on my system (slackware-current).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help!! Mono on Fedora core 5 - problem RaymondC Linux - Software 2 08-09-2006 11:08 AM
Help Mono Installed But Mono Develop Won't Load TheGreatGonzo Slackware 8 05-18-2006 06:42 AM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 09:12 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM
Problem when I install mono ICO Linux - Software 1 08-11-2003 06:18 AM


All times are GMT -5. The time now is 03:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration