LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Monittor can't display correct resolution (http://www.linuxquestions.org/questions/slackware-14/monittor-cant-display-correct-resolution-528579/)

satimis 02-13-2007 03:00 AM

Monittor can't display correct resolution
 
Hi folks,

slamd64-11.0
graphic card:
Asus GeForce 7300 GS (PCI-E 16, 256MB 64bit)
NVIDIA GeForce 7300 GS
Philips 200WP7 LCD display
1680x1050 resolution


Can't display the correct resolution on screen;

$ cat /etc/X11/xorg.conf
Code:

....
# **********************************************************************
# Monitor section
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"

    Identifier  "My Monitor"

# HorizSync is in kHz unless units are specified.
# HorizSync may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.

    HorizSync        30 - 98

# VertRefresh is in Hz unless units are specified.
# VertRefresh may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.

    VertRefresh 56-76

EndSection


# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

Section "Device"
    Identifier  "VESA Framebuffer"
    Driver      "vesa"
    #VideoRam    4096
    # Insert Clocks lines here if appropriate
EndSection

# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present.  Each describes
# the configuration of a single screen.  A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
    Identifier  "Screen 1"
    Device      "VESA Framebuffer"
    Monitor    "My Monitor"

# If your card can handle it, a higher default color depth (like 24 or 32)
# is highly recommended.

    DefaultDepth 24
#  DefaultDepth 32

# "1024x768" is also a conservative usable default resolution.  If you
# have a better monitor, feel free to try resolutions such as
# "1152x864", "1280x1024", "1600x1200", and "1800x1400" (or whatever your
# card/monitor can produce)

    Subsection "Display"
        Depth      8
        Modes "1680x1050" "1024x768"
    EndSubsection
    Subsection "Display"
        Depth      16
        Modes "1680x1050" "1024x768"
    EndSubsection
    Subsection "Display"
        Depth      24
        Modes "1680x1050" "1024x768"
    EndSubsection
    Subsection "Display"
        Depth      32
        Modes "1680x1050" "1024x768"
    EndSubsection

EndSection
....

Pls advise where can I download the correct driver and how to fix the problem. TIA


B.R.
satimis

juanbobo 02-13-2007 03:15 AM

Are you sure that's the right resolution. Even if the monitor supports it, it doesn't mean the video card does.

nass 02-13-2007 03:25 AM

well first of look at the nvidia site for the latest linux driver.
if im not mistaken i saw you own and amd64? then this should be the link
http://www.nvidia.com/object/linux_d..._1.0-9746.html
still i suggest you go to the nvidia site and choose whats best from the drivers download page.
even though i don't have an nvidia on my slackbox, i read there that they have added a utility to help you config your X config file.that should be neat - grab that too.

anyhow once installed the graphics card, i suggest you input your monitor characteristics in the xorg conf file too.

mine looks like (just the monitor section)
Code:

        DisplaySize      320  240    # mm
        Identifier  "Monitor0"
        VendorName  "EIZO"
        ModelName    "F553-M"
        HorizSync    27-69
        VertRefresh  55-120
        Option      "DPMS" "true"

don't ask me abt the DPMS option...

perhpas in your monitor's vendor site you can get some additional info about how to set up your monitor in linux.
you should be fine there after
nass

Daedra 02-13-2007 05:11 AM

hi, first thing I want to ask is what did you use to setup your xorg.conf file? Did you use xorgconfig or xorgsetup, because certain lines in your config file are wrong in my opinion, especially the video decive section, if you have a nividia card you should use the "nv" driver and then install the nvidia drivers from nvidia's website and switch to the "nvidia" driver. If you have still have trouble let us know, I remember when I got my widescreen monitor it took me about 2 hours to get it at 1440x900 but now I can do it in about 2 minutes.

Sorry if you don't understand all this, im just taking it one step at a time.

satimis 02-13-2007 05:56 AM

Hi Daedra,

I'm now answering your posting on another PC, FC6. Because slamd64-11.0 can't connect Internet 10 minutes ago. It has been working for at least 4~5 hours without problem. In order to check the problem not coming from ISP I run FC6.

Quote:

hi, first thing I want to ask is what did you use to setup your xorg.conf file? Did you use xorgconfig or xorgsetup, because certain lines in your config file are wrong in my opinion, especially the video decive section, if you have a nividia card you should use the "nv" driver and then install the nvidia drivers from nvidia's website and switch to the "nvidia" driver.
I haven't fixed the resolution problem yet. I ran the installer to install slamd64-11.0. xorg.conf was created automatically. I did not edit it at all. Previously slamd64-11.0 worked on a 15" NEC LCD display without problem because the max resolution of the latter was 1024x768. I Changed the Philips 200WP7 LCD display about 2 hours ago. Then the problem surfaced. That is the complete story. Vesa is the default driver of slamd64-11.0.

Quote:

If you have still have trouble let us know, I remember when I got my widescreen monitor it took me about 2 hours to get it at 1440x900 but now I can do it in about 2 minutes.
Your advice would be appreciated. TIA

B.R.
satimis

Daedra 02-13-2007 08:37 PM

of first thing you should do is make a new xorg.conf file, first back up your old one like this

cd /etc/X11/
mv xorg.conf xorg.conf.backup

once the file is backed up, run as root

xorgsetup

this will generate a new xorg.conf file, once you do this startx and if everything is fine, post the contents of the xorg.conf file

satimis 02-14-2007 11:27 PM

Hi Daedra,

Tks for your advice.

Quote:

once the file is backed up, run as root

xorgsetup
# cd /ete/X11
# ls
Code:

WindowMaker/  fvwm2/      rstart/  xdm/    xorg.conf-fbdev    xorg.conf.original  xsm/
app-defaults/  lbxproxy/  twm/    xinit/  xorg.conf-vesa     
fs/            proxymngr/  xdg/    xkb/    xorg.conf  xserver/

# mv /etc/X11/xorg.conf /etc/X11/xorg.conf.20070215
# xorgsetup
Started "CONFIGURE X SERVER?" window. On clicking [Yes] it closed and prompted:
Code:


Please consult the The X.Org Foundation support
        at http://wiki.X.Org
 for help.


B.R.
satimis

Daedra 02-15-2007 04:21 PM

did you run it will you were in x windows? Because you have to log out of the X server and run it from the command prompt

satimis 02-15-2007 08:47 PM

Hi Daedra,

Quote:

did you run it will you were in x windows? Because you have to log out of the X server and run it from the command prompt
First I tried w/o exit X server. It prompted a warning requesting to close X windown. Then I exited X to runlevel 3. It was still the same:
Code:

Please consult the The X.Org Foundation support
        at http://wiki.X.Org
 for help.

Now I have my problem solved after download/install a driver for amd64 on nVidia.com. During installation a new xorg.conf was created. Then I adjusted and added some other items on the file. Resoultion:1680x1050 (factory design) can be run. Tks.

Now the remaining problem is to increase the font size on the top toolbar of Mozilla. I'm still searching a solution.

Anyway tks again for your advice.


B.R.
satimis

ciotog 02-17-2007 01:17 PM

To fix mozilla, go to Edit -> Preferences -> "Content" tab - > "Advanced" button under the "Fonts & Colors" section and change "Display resolution" to be "System setting" (or whatever you like).

satimis 02-17-2007 07:15 PM

Hi ciotog,

Tks for your advice.

Quote:

To fix mozilla, go to Edit -> Preferences -> "Content" tab - > "Advanced" button under the "Fonts & Colors" section and change "Display resolution" to be "System setting" (or whatever you like).
Sorry, it did not work here.

I have my problem solved with following steps as advised by folks in another thread;

$ touch ~/.gtkrc-2.0
$ nano ~/.gtkrc-2.0
copied "gtk-font-name = "Lucida Sans 14" on it.

Restarted X and evoked Firefox. Font size increased.

Repeated the same steps as root.

Tks.


B.r.
satimis

ciotog 02-17-2007 08:31 PM

Trust me, it would have worked. You have to have restarted Firefox / Mozilla and you would have seen the change.
Actually with Mozilla it's slightly different:
"Edit -> Preferences -> Appearance -> Font" and there change the "Display resolution" preference.

satimis 02-18-2007 01:20 AM

Hi ciotog,

Quote:

Actually with Mozilla it's slightly different:
"Edit -> Preferences -> Appearance -> Font" and there change the "Display resolution" preference.
Strangely there is something different here;
Mozilla Firefox
Edit --> Preferences --> (Appearance does not exits here) instead --> Content --> (under Fonts & Color) Advanced --> Fonts (here I increased the font size --> OK --> Close
exiting "Preferences"

Restarted "Mozilla Firefox" - Font size still the same (small)

Restarted X and then Mozilla Firefox - No improvement.


B.R.
satimis

Old_Fogie 02-18-2007 01:19 PM

in your mozilla, what's the value for "browser.display.screen_resolution" in "about:config"

ciotog 02-18-2007 01:40 PM

Which version of firefox do you have? 2.0 might have moved stuff around, or maybe you have an older version than 1.5. There should be a "display resolution" option, changing the default font for page text won't change the menu bar as you found out.


All times are GMT -5. The time now is 09:38 PM.