LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-27-2006, 12:58 PM   #1
mrxtheking
LQ Newbie
 
Registered: Oct 2003
Distribution: Slackware =)
Posts: 10

Rep: Reputation: 0
Monitor turn off


Hi guys, I don't write very often here, but this one I just cant find it on forums or I'm just using the wrong keyboard, but I just cant find it. I'm on slack 10.2 with kernel 2.6.15.6. I'm trying to make my monitor to shutdown after being idle for a period of time, like 10 minutes. I tried using default KDe control center Power Control, but it didn't shutdown my monitor, it just made it black ? The power was still on, but the monitor image just turned to black? I tried every option also, but none of which did help. Then I tried addingi n xorg DMPS option and ServerLayout to 10 minutes, it worked only 1 time though. After I did that, it did turn off my monitor after 10 minutes and after i resumed it with mouse and tried leaving it idle again, it never did shutoff again...What am I missing out on? Sorry if this been covered already, but I just couldnt find it no where...I usually post as my last option...Thanx in advance!
 
Old 03-27-2006, 02:08 PM   #2
stormtracknole
Member
 
Registered: Aug 2005
Location: The Big Easy
Distribution: Slackware, RHEL
Posts: 817

Rep: Reputation: 104Reputation: 104
It's actually DPMS. It should look something like this:

Option "DPMS"

Hope this works.
 
Old 03-27-2006, 02:23 PM   #3
MannyNix
Member
 
Registered: Dec 2005
Location: ~
Distribution: Slackware -current, OpenBSD
Posts: 449

Rep: Reputation: 41
yup, this works for me on viewsonic vx900, Nvidia Fx5200
Code:
    Identifier     "My Monitor"
    HorizSync       30.0 - 60.0
    VertRefresh     50.0 - 75.0
    Option         "DPMS"
EndSection
 
Old 03-28-2006, 08:53 AM   #4
mrxtheking
LQ Newbie
 
Registered: Oct 2003
Distribution: Slackware =)
Posts: 10

Original Poster
Rep: Reputation: 0
It doesn't work and this is I how I got it setup....

Code:
Section "Monitor"

# HorizSync is in kHz unless units are specified.
# HorizSync may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.
#    HorizSync	30-64         # multisync
#    HorizSync	31.5, 35.2    # multiple fixed sync frequencies
#    HorizSync	15-25, 30-50  # multiple ranges of sync frequencies
# VertRefresh is in Hz unless units are specified.
# VertRefresh may be a comma separated list of discrete values, or a
# comma separated list of ranges of values.
# NOTE: THE VALUES HERE ARE EXAMPLES ONLY.  REFER TO YOUR MONITOR'S
# USER MANUAL FOR THE CORRECT NUMBERS.
    Identifier     "My Monitor"
    HorizSync       30.0 - 60.0
    VertRefresh     56.0 - 75.0
    Option "DPMS"
EndSection

Section "Device"

    #VideoRam    4096
    # Insert Clocks lines here if appropriate
    Identifier     "VESA Framebuffer"
    Driver         "nvidia"
EndSection

Section "Screen"

# If your card can handle it, a higher default color depth (like 24 or 32)
# is highly recommended.
#   DefaultDepth 8
#   DefaultDepth 16
#   DefaultDepth 32
# "1024x768" is also a conservative usable default resolution.  If you
# have a better monitor, feel free to try resolutions such as
# "1152x864", "1280x1024", "1600x1200", and "1800x1400" (or whatever your
# card/monitor can produce)
    Identifier     "Screen 1"
    Device         "VESA Framebuffer"
    Monitor        "My Monitor"
    DefaultDepth    24
    SubSection     "Display"
        Depth       8
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       32
        Modes      "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
   Identifier "Screen 1"
	Option "OffTime"	"3"	# Turn off DPMS monitor
EndSection
 
Old 03-28-2006, 03:01 PM   #5
MannyNix
Member
 
Registered: Dec 2005
Location: ~
Distribution: Slackware -current, OpenBSD
Posts: 449

Rep: Reputation: 41
My xorg.conf doesn't have this last lines yours has, just guessing here, maybe comment them out?
Quote:
Originally Posted by mrxtheking
Section "ServerLayout"
Identifier "Screen 1"
Option "OffTime" "3" # Turn off DPMS monitor
 
Old 03-28-2006, 06:36 PM   #6
mrxtheking
LQ Newbie
 
Registered: Oct 2003
Distribution: Slackware =)
Posts: 10

Original Poster
Rep: Reputation: 0
doesnt work without them either, but if you dont have the lines, where do you specify the times for the monitor to turn off?
 
Old 03-28-2006, 09:30 PM   #7
MannyNix
Member
 
Registered: Dec 2005
Location: ~
Distribution: Slackware -current, OpenBSD
Posts: 449

Rep: Reputation: 41
i specify the times for the monitor to turn off like this:
kde ->right click on desktop ->configure desktop ->display ->power control ->enable dislay power management ->standby after ->10 min

Last edited by MannyNix; 03-28-2006 at 09:50 PM.
 
Old 03-29-2006, 01:05 PM   #8
mrxtheking
LQ Newbie
 
Registered: Oct 2003
Distribution: Slackware =)
Posts: 10

Original Poster
Rep: Reputation: 0
LOL it actually got it fixed that way! Thanks so much! I took out the serverlayout option and left DPMS option, then went to configure power management and set up stand by time and it worked, thank you!
 
Old 03-29-2006, 05:26 PM   #9
MannyNix
Member
 
Registered: Dec 2005
Location: ~
Distribution: Slackware -current, OpenBSD
Posts: 449

Rep: Reputation: 41
lol, good to hear it worked!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn off monitor? Zeno McDohl Slackware 14 01-26-2006 06:20 PM
Fn-F3 to turn off Laptop Monitor. StevenO Linux - Laptop and Netbook 1 01-25-2006 05:25 AM
Software to turn off monitor? GoogleMe Linux - Software 8 12-27-2005 07:43 PM
monitor turn off jkmartha Linux - Newbie 1 05-03-2005 01:16 AM
Utility that can turn monitor off 3saul Linux - General 2 08-25-2004 02:09 AM


All times are GMT -5. The time now is 05:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration