LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-27-2012, 05:36 PM   #1
Cara25
Member
 
Registered: Mar 2006
Location: Nashville, Tennessee
Distribution: Salix 13.37 with KDE
Posts: 257

Rep: Reputation: 36
Monitor resolution other than default


Fine tuning my first install of Salix/Slackware 13.37/KDE, 32 bit. Great and easy install ! I can't get the system to accept and hold a different screen resolution than the max of 1280x1024. I need to use 1024x768 because I'm old. I change the settings in the KDE System Settings app but the system will not keep the 1024x768 settings when I shut down and restart. Any simple fixes ? While researching this glitch, I've read horror stories about how to fix, but I don't need a new career.
Thanks in advance
 
Old 08-27-2012, 08:11 PM   #2
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 519

Rep: Reputation: 137Reputation: 137
You will need to create an xorg.conf under /etc/X11/xorg.conf.d to specify your defaults and override autodetection. You don't need a full balls to the wall definitions, just, say, the bits you need to override.

Thats the easiest way...but then I am old school. Bah, Kids these days - can't even whip up a proper X config file...

You'll need to know some specifics about you GPU and monitor. For example, something like a "/etc/X11/xorg.conf.d/monitors.conf" (modify as required, this is for one of my boxes):
Code:
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Dell"
    ModelName      "DELL P780"
    DisplaySize     312    234
    HorizSync       30.0 - 85.0
    VertRefresh     48.0 - 120.0
    Option         "DPI" "96 x 96"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 430"
    Option         "Coolbits" "5"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
       Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
       Depth       24
    EndSubSection
EndSection
As root, you can run
Code:
# X -configure
to get a autodetected template for your system: /root/xorg.conf.new

Adjust as needed.

See also:
http://humanreadable.nfshost.com/sdeg/index.htm#toc
https://wiki.archlinux.org/index.php/Xorg
 
Old 08-27-2012, 11:04 PM   #3
mrascii
Member
 
Registered: Jun 2012
Location: on the Net
Distribution: Slackware
Posts: 100

Rep: Reputation: Disabled
xrandr will list the resolutions that your monitor is capable of and mark the preferred resolution with a plus sign. If your goal is to have larger fonts you may find a better solution might be to change the size of the system fonts or the default font in the web browser.

DNA
AKA mrascii
 
Old 08-29-2012, 04:56 PM   #4
Cara25
Member
 
Registered: Mar 2006
Location: Nashville, Tennessee
Distribution: Salix 13.37 with KDE
Posts: 257

Original Poster
Rep: Reputation: 36
Thanks kingbeowulf, I understand, I think, on what you're doing. I've found all the files. 2 questions, then I'll try it.
1. The monitors.conf file you use did you copy this info from another file ?
2. If I remove the 1280 x 1024 from my monitors.conf file will the 1280 x 1024 be available in the Systems Settings app ?
I'm 57 years old and had a stroke 5 years ago that left my right arm/hand very difficult to use. In my better days, I've probably written 1000s of lines of DOS script using primarily D.R. DOS. I've written 100s of lines of C to connect Windows PCs to UNIX boxes worldwide. I just don't want to buy a "plug and play" PC with a buggy full of shrink wrapped "Donkey Kong" software at Walmart.
 
Old 08-30-2012, 01:21 PM   #5
ottavio
Member
 
Registered: Nov 2007
Posts: 312

Rep: Reputation: 46
Quote:
Originally Posted by mrascii View Post
xrandr will list the resolutions that your monitor is capable of and mark the preferred resolution with a plus sign.
I would have gone with xrandr too. In my case though xrandr fixed the resolution but messed up with my fonts. Any suggestions?
 
Old 08-30-2012, 04:16 PM   #6
turtleli
Member
 
Registered: Aug 2012
Location: UK
Distribution: Slackware 14.1
Posts: 135

Rep: Reputation: Disabled
@Cara25

I have two different methods you can try.

1. Modify monitors.conf

I'll use kingbeowulf's monitors.conf as the example. In the display subsection:
Code:
       Modes      "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
If you want 1024x768 to be default you move that to the front.
Code:
       Modes      "1024x768" "1600x1200" "1280x1024" "800x600" "640x480"
See if that works. This method has problems with the nvidia driver (I don't know whether the same problems exist on other drivers), which leads me to the second method (it may also be simpler).

2. Add a xrandr line into the appropriate startup script.

If you login at the console you change xinitrc.
If you login via the KDE login manager I think you change /etc/kde4/kdm/Xsetup (I don't use KDE, so I may be wrong)

Add the following line into the appropriate file:
Code:
xrandr --output output_name --mode 1024x768
Replace output_name for whatever it is called on your system, if you don't know what it's called run xrandr. One of the lines it outputs in my system is
Code:
DVI-I-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 598mm x 336mm
In my case, output_name is DVI-I-1.

This worked for me using the nvidia driver and should also work fine with other drivers as well, so I would probably recommend this method first.

Last edited by turtleli; 08-30-2012 at 04:23 PM. Reason: Typos
 
Old 08-30-2012, 05:18 PM   #7
mrascii
Member
 
Registered: Jun 2012
Location: on the Net
Distribution: Slackware
Posts: 100

Rep: Reputation: Disabled
If the real issue here is making fonts bigger and easier to read in all applications than changing from the default monitor resolution may not be what you want to do. I've had LCD monitors what were harder to read since the resolution was lower -- 800x600 simple has fewer pixels to display that 1280x900. Leaving the resolution at the default swetting and then adjusting the font sizes in the KDE System Settings/Application Appearance might work better for you. The default font settings are 8 and 9 points. Changing to 11 or 12 might make all the difference for you. You can also define the minimum font size that Firefox uses under the Firefox menu Edit/Preferences/Content/Fonts & Colors. Be sure to check the options under the Advanced button "Allow pages to choose their own fonts."

DNA
AKA mrascii
 
Old 08-30-2012, 05:41 PM   #8
turtleli
Member
 
Registered: Aug 2012
Location: UK
Distribution: Slackware 14.1
Posts: 135

Rep: Reputation: Disabled
Cara25 has dexterity problems and has not mentioned vision problems. Maybe the lower resolution is helpful for some reason. The only other thing I can suggest is to look at the KDE accessibility options to see whether anything would be useful, such as mouseless operation.
 
Old 08-30-2012, 09:28 PM   #9
Cara25
Member
 
Registered: Mar 2006
Location: Nashville, Tennessee
Distribution: Salix 13.37 with KDE
Posts: 257

Original Poster
Rep: Reputation: 36
Everyone, Thanks for all the help. I'm trying option number 1 suggested by turtleli and earlier by kingbeowulf. I'll modify a monitors.conf file and insert it. Let everyone know tomorrow. BTW, I don't have a vision problem, just limited use of my right hand. Makes a lot of typing slow just using 1 hand. Then again, I might be lazy.
 
Old 08-30-2012, 09:37 PM   #10
cascade9
Senior Member
 
Registered: Mar 2011
Location: Brisneyland
Distribution: Debian, aptosid
Posts: 3,718

Rep: Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903Reputation: 903
Quote:
Originally Posted by mrascii View Post
If the real issue here is making fonts bigger and easier to read in all applications than changing from the default monitor resolution may not be what you want to do. I've had LCD monitors what were harder to read since the resolution was lower -- 800x600 simple has fewer pixels to display that 1280x900.
I agree (though its not just due to number of pixels, for example using a 4:3 setting on modern 16:9, 16:10 etc. monitor causes display skewing). If Cara25 was using a LCD/LED monitor it would be a much better idea to play with font sizes/DPI setting. But the DELL P780 being used is a CRT.

*Edit- I feel like an idiot, the P780 was kingbeowulf.

Last edited by cascade9; 08-31-2012 at 03:16 AM.
 
Old 08-30-2012, 11:29 PM   #11
mrascii
Member
 
Registered: Jun 2012
Location: on the Net
Distribution: Slackware
Posts: 100

Rep: Reputation: Disabled
@cascade9: Thanks for the clarification.

DNA
AKA mrascii
 
Old 08-31-2012, 03:03 AM   #12
kingbeowulf
Member
 
Registered: Oct 2003
Location: WA
Distribution: Slackware64 14.1, Slackware 14.1
Posts: 519

Rep: Reputation: 137Reputation: 137
@Cara25: You got about 5 years on me, and I'm glad you are a happy linux user.

Just make sure you don't forget to set the HorizSync, VertRefresh frequencies correctly for your monitor. The DisplaySize is to correct aspect ratio since X guesses wrong sometimes (as does xrandr). In the example I gave, the monitor is Dell's version of a 17" Sony Trinitron.

The only reason I didn't mention xrandr is...just not used to it: always tweaked single and multimonitor setups with Slackware via X configuration files. xrandr is handy since it is somewhat driver agnostic.

BTW, to test a config file, at the CLI (not the GUI login), you can
Code:
X -config /path/to/config/your.conf
to test to make sure it works. back out with <Ctrl>-<Alt>-<Backspace> (if this is not disabled in your distro).
 
  


Reply

Tags
kde, screen resolution


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual monitor setup; one monitor has terrible resolution chris24300 Linux - Newbie 7 10-27-2011 09:50 AM
New Better Monitor Changing Default Resolution Slackware 13.0 frankbell Slackware 6 09-18-2010 06:13 AM
default screen resolution smaller than max. resolution ?? Thoddy Linux - General 2 11-10-2005 01:33 AM
X: using larger resolution for games than default desktop resolution Jamo Linux - Games 2 04-10-2005 03:16 AM
Monitor problems -- changing resolution back w/o monitor Jiawen Linux - Hardware 5 03-17-2004 10:06 PM


All times are GMT -5. The time now is 03:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration