LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 05-08-2011, 12:58 PM   #1
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Rep: Reputation: 62
Monitor resolution - Intel driver


Something that has been bugging me in my new netbook:

The graphics card is an Intel GMA3150 and the max resolution I get in Linux is 1024x600. On Windows 7, I could get higher resolutions - I guess one of them was 1024x780, but I can't say for sure because I wiped it off after I learned I couldn't even change the wallpaper. Can I change that switching to the Intel driver in /testing? Or should I set the resolution manually in a .conf file? If so, how can I do that?
 
Old 05-08-2011, 02:18 PM   #2
Lirey
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 35

Rep: Reputation: 6
I don't have any systems currently running Linux with the Intel GMA3150 graphics, but I've installed Slackware(-current, between 13.1 and 13.37) on a number of Atom/NM10/GMA3150 systems. As far as I can recall, I had no problems getting 1600x1200 resolution. I did not need to use the driver in /testing, just the default driver that was installed.

(Off topic, Slackware recognized all the hardware in these systems without any additional drivers and ran flawlessly. When I installed Windows 7 on the same hardware, Windows failed to recognize the video, sound, and network until third party drivers were installed for each.)

I suspect that X11 is not properly recognizing the capabilities of your monitor. Have you tried running 'xorgsetup'? This should create an X11 configuration file: /etc/X11/xorg.conf If you've run xorgsetup and still are not seeing the resolutions that you want as an option, you can try manually editing the file.

Look in the configuration file for a section called "Screen" and a subsection called "Display". There should be a line that lists the modes that the monitor can display. By default it looks like:

Modes "1024x768" "800x600" "640x480"

You can edit this line to add any other resolutions that your monitor can handle. For instance, the line in my xorg.conf looks like:

Modes "1920x1200" "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"

Once the configuration file has been updated, you should have these resolutions available the next time you start the GUI. I think KDE will automatically start in whatever resolution it was using last, but the option to switch to the new resolutions should be available in the KDE system settings.

Lirey
 
Old 05-08-2011, 04:14 PM   #3
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Original Poster
Rep: Reputation: 62
Thank you Lirey for you repply. Based on your suggestion, I ran xorgsetup and added the modes line to the display subsection. I added a line like this to all the display subsections:
Code:
Modes "1152x864" "1024x768" "1024x600" "800x600" "640x480"
But I still couldn't change the resolution to anything higher than 1024x600. I then ran xrandr and got this output:
Code:
Screen 0: minimum 320 x 200, current 1024 x 600, maximum 4096 x 4096
LVDS1 connected 1024x600+0+0 (normal left inverted right x axis y axis) 223mm x 125mm
   1024x600     60.2*+
   800x600      60.3     56.2
   640x480      59.9
VGA1 disconnected (normal left inverted right x axis y axis)
Based on what it said in maximum, I tried to set it to 1152x864:
Code:
xrandr --output LVDS1 --mode 1152x864
and got
Code:
xrandr: cannot find mode 1152x864
What can I do to make xorg aware of those modes?
 
Old 05-08-2011, 04:27 PM   #4
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
You can created a modeline with cvt or gtf and add it to the Monitor section of your xorg.conf file.

Adam
 
Old 05-08-2011, 04:37 PM   #5
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Original Poster
Rep: Reputation: 62
Quote:
Originally Posted by adamk75 View Post
You can created a modeline with cvt or gtf and add it to the Monitor section of your xorg.conf file.

Adam
Hi. I tried both methods, but none of them got assigned to LVDS1, but to VGA1. What am I doing wrong? I did this:
Code:
gtf 1152  864 60.4
xrandr --newmode "1152x768" 82.17 1152 1216 1336 1520 864 865 868 895 -Hsync +Vsync
 
Old 05-08-2011, 05:22 PM   #6
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Then use xrandr with --addmode to add it to a particular output device. You can add the modeline to a monitor section, but the Identifier for the monitor section will need to be the output device name given by xrandr.

Adam
 
Old 05-08-2011, 05:37 PM   #7
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Original Poster
Rep: Reputation: 62
I'll paste everything that I'm doing and also the output I get from the computer.

:~# xrandr
Code:
Screen 0: minimum 320 x 200, current 1024 x 600, maximum 4096 x 4096
LVDS1 connected 1024x600+0+0 (normal left inverted right x axis y axis) 223mm x 125mm
   1024x600     60.2*+
   800x600      60.3     56.2
   640x480      59.9
VGA1 disconnected (normal left inverted right x axis y axis)
:~# gtf 1152 864 60.2

Code:
  # 1152x864 @ 60.20 Hz (GTF) hsync: 53.88 kHz; pclk: 81.90 MHz
  Modeline "1152x864_60.20"  81.90  1152 1216 1336 1520  864 865 868 895  -HSync +Vsync
:~# xrandr --newmode "1152x864_60.20" 81.90 1152 1216 1336 1520 864 865 868 895 -HSync +Vsync

:~# xrandr --addmode LVDS1 1152x864_60.20

Code:
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  149 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  25
  Current serial number in output stream:  26
:~# xrandr --output LVDS1 --mode 1152x864_60.20
Code:
xrandr: cannot find mode 1152x864_60.20
I really don't know where my mistake is.

Last edited by bonixavier; 05-08-2011 at 05:51 PM. Reason: Added code tags for each individual output. Makes it easier to read
 
Old 05-08-2011, 06:16 PM   #8
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
I really don't know if it matters in this situation, but you really shouldn't be running these commands as root. Does --addmode work if you put the mode name in quotes:

Code:
xrandr --addmode LVDS1 "1152x864_60.20"
 
Old 05-08-2011, 06:22 PM   #9
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Original Poster
Rep: Reputation: 62
No. Same error message. This is frustrating.
 
Old 05-08-2011, 06:35 PM   #10
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Sorry, no idea then. I've done that plenty of times with the radeon driver but not with intel.
 
Old 05-08-2011, 06:41 PM   #11
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Original Poster
Rep: Reputation: 62
Quote:
Originally Posted by adamk75 View Post
Sorry, no idea then. I've done that plenty of times with the radeon driver but not with intel.
Thank you for helping me. Turns out that the higher resolution it can get in Windows is actually not native and is not achievable in Linux. I found this online:
Quote:
At last night's meeting, I mentioned that my Samsung N150 was capable of 1024 x 768 resolution in Windows 7 Starter Edition, but would only give me 1024 x 600 resolution in Ubuntu, and I was trying to figure out how to get the higher resolution in Ubuntu. Unfortunately, I learned today that the supposed 1024 x 768 mode in Windows is achieved by having the driver discard 168 scan lines of info, presumably spaced out across the screen, so the real resolution is only 1024 x 600. I have run into a couple of programs on Ubuntu, notably the Pan Usenet program, that open dialog boxes that are a full 768 pixels high, and have command buttons off-screen when used on a 1024 x 600 display.
That sucks because XFCE's terminal settings dialog doesn't fit my screen, for example. >-( Suppose I should have gotten another model.
 
Old 05-08-2011, 06:46 PM   #12
bonixavier
Member
 
Registered: Sep 2010
Distribution: Slackware
Posts: 320

Original Poster
Rep: Reputation: 62
But why the heck does xrandr report 4096x4096 as the max resolution? Is it the one the video card is capable of, but the monitor isn't?
 
Old 05-08-2011, 06:50 PM   #13
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
It's telling you that the driver allocated enough video RAM to support that high of a resolution across all possible output devices.

Adam
 
1 members found this post helpful.
Old 05-08-2011, 07:53 PM   #14
Lirey
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 35

Rep: Reputation: 6
I'm not very familiar with xrandr, but if it is reporting 4096x4096 as the maximum resolution it must be reporting the capabilities of the video card/video hardware, not the monitor/display itself. In a nettop type system with an external monitor, the GMA3150 graphics can handle a relatively high resolution - although 4096x4096 seems a bit absurd for integrated graphics.

Do you know what is the hardware resolution of your display? The Samsung N150 mentioned above seems to have some conflicting specifications, but most indicate that it has a 1024x600 (WSVGA) display.

Does XFCE allow a virtual desktop that is larger than the display resolution? I'm not sure if current versions of the desktop environments still support this feature, but it used to be quite useful when configuring systems connected to small (12 or 13 inch CRT with VGA max resolution) displays.
 
Old 01-15-2012, 10:03 AM   #15
igordcard
LQ Newbie
 
Registered: Jan 2009
Posts: 3

Rep: Reputation: 0
So, the question is: Is there a known way to force a resolution by discarding some exceeding lines along the way, in Linux? Also, my netbook can do 1152x864 in Windows (the panel is 1024x600 native, the max resolution in GNU/Linux). In this case, not only additional height is being added, but width too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get high resolution with vesa xorg driver (Intel 82845) wmb Debian 6 02-21-2011 06:01 PM
[SOLVED] another graphics resolution question intel driver. okos Slackware 6 03-06-2010 12:36 PM
How I upgraded Intel/PRO 2200 Wireless Driver on Suse 10.1 to have Monitor Mode parsek77 Suse/Novell 0 07-21-2006 12:13 PM
: Intel® 865G Chipset with Intel® Extreme Graphics 2 -driver for linux7.0 ker 2.4.1 schandak Red Hat 1 10-28-2004 01:43 AM
Monitor problems -- changing resolution back w/o monitor Jiawen Linux - Hardware 5 03-17-2004 11:06 PM


All times are GMT -5. The time now is 01:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration