LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-12-2006, 09:23 PM   #1
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 292Reputation: 292Reputation: 292
monitor powering off


I'm trying to change the monitor blanking time. For a while now it's blanked at 10 mins, and I'm trying to set it for 30, but I can't find any way of affecting it.

Things I've tried so far:

Option "OffTime" "30" and
Option "DPMS" in xorg.conf

Then tried turning DPMS off altogether:
Took out all dpms options in xorg.conf
xset -dpms

Killed acpid daemon
/bin/setterm -blank 30 -powersave powerdown -powerdown 60

The last option I know shouldn't affect X but I tried it just in case.

Are there any other ways of controlling monitor blanking?
 
Old 04-12-2006, 11:13 PM   #2
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 66
Have you tried disabling the screensaver?
 
Old 04-12-2006, 11:14 PM   #3
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Original Poster
Rep: Reputation: 292Reputation: 292Reputation: 292
Yes xscreensaver is disabled, and I also checked kde's because I sometimes run kde progs
 
Old 04-12-2006, 11:52 PM   #4
drumz
Member
 
Registered: Apr 2005
Location: Scottsdale, AZ, USA
Distribution: Slackware
Posts: 188

Rep: Reputation: 33
In a run dialog try

Code:
xset dpms <standby time in minutes> <suspend time in minutes> <off time in minutes>
xset dpms 0 0 0 should turn powersavings off. Then again, xset -dpms should have, as well.
 
Old 04-13-2006, 12:05 AM   #5
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Original Poster
Rep: Reputation: 292Reputation: 292Reputation: 292
Strange. I just booted up xscreensaver and set to blank after 30, and also checked power management and turned that on too. I was thinking/hoping that xscreensaver might override whatever was blanking the screen.

It didn't help, but when I redisabled xscreensaver and killed the daemon the monitor stayed on.

Hopefully this is solved. I've also just tried xset dpms 30 60 120 to see if that is working again as it should.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
powering down usb drive? argh Linux - Hardware 2 01-23-2006 11:47 AM
Powering off when powering off, how hard can it be? Ian_Hawdon Slackware 14 01-19-2006 03:19 PM
Powering up Interface TMH Linux - Networking 3 02-26-2005 06:07 PM
Powering off... daihard Linux - Software 1 12-22-2004 04:20 PM
Laptop powering down during install OldRod Fedora - Installation 1 10-06-2004 03:45 AM


All times are GMT -5. The time now is 12:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration