LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-25-2004, 05:52 PM   #1
LadFromWales85
Member
 
Registered: Apr 2003
Location: Wales, UK
Distribution: Slackware 10
Posts: 30

Rep: Reputation: 15
Modules: errors in logs


Just been looking through my system logs, and find lots of errors loading certain modules.

Code:
Jul 25 03:06:43 shaunsputer insmod: /lib/modules/2.4.26/kernel/drivers/cdrom/sbpcd.o.gz: insmod block-major-25 failed
Jul 25 03:06:43 shaunsputer insmod: /lib/modules/2.4.26/kernel/drivers/cdrom/cdu31a.o.gz: init_module: Input/output error
Jul 25 03:06:43 shaunsputer insmod: /lib/modules/2.4.26/kernel/drivers/cdrom/cdu31a.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.       You may find more information in syslog or the output from dmesg
Jul 25 03:06:43 shaunsputer insmod: /lib/modules/2.4.26/kernel/drivers/cdrom/cdu31a.o.gz: insmod block-major-15 failed
Jul 25 03:06:49 shaunsputer insmod: /lib/modules/2.4.26/kernel/drivers/cdrom/mcd.o.gz: init_module: Input/output error
Jul 25 03:06:49 shaunsputer insmod: /lib/modules/2.4.26/kernel/drivers/cdrom/mcd.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.       You may find more information in syslog or the output from dmesg
Jul 25 03:06:49 shaunsputer insmod: /lib/modules/2.4.26/kernel/drivers/cdrom/mcd.o.gz: insmod block-major-23 failed
Jul 25 03:07:00 shaunsputer kernel: Trying to free nonexistent resource <00000340-00000343>
Jul 25 03:07:00 shaunsputer insmod: /lib/modules/2.4.26/kernel/drivers/cdrom/sjcd.o.gz: init_module: Input/output error
Jul 25 03:07:00 shaunsputer insmod: /lib/modules/2.4.26/kernel/drivers/cdrom/sjcd.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.       You may find more information in syslog or the output from dmesg
Jul 25 03:07:00 shaunsputer insmod: /lib/modules/2.4.26/kernel/drivers/cdrom/sjcd.o.gz: insmod block-major-18 failed
Jul 25 03:07:00 shaunsputer insmod: /lib/modules/2.4.26/kernel/drivers/cdrom/cm206.o.gz: init_module: Input/output error
Jul 25 03:07:00 shaunsputer insmod: /lib/modules/2.4.26/kernel/drivers/cdrom/cm206.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.       You may find more information in syslog or the output from dmesg
Jul 25 03:07:00 shaunsputer insmod: /lib/modules/2.4.26/kernel/drivers/cdrom/cm206.o.gz: insmod block-major-32 failed
It also seems to list other cd rom modules, which is weird :s I haven't been doing anything with CD rom's at all

Code:
Jul 25 02:17:26 shaunsputer modprobe: modprobe: Can't locate module sound-slot-1
Jul 25 02:17:26 shaunsputer modprobe: modprobe: Can't locate module sound-service-1-0
Jul 25 02:17:26 shaunsputer modprobe: modprobe: Can't locate module sound-slot-1
Jul 25 02:17:26 shaunsputer modprobe: modprobe: Can't locate module sound-service-1-0
Jul 25 02:17:52 shaunsputer modprobe: modprobe: Can't locate module sound-slot-1
Jul 25 02:17:52 shaunsputer modprobe: modprobe: Can't locate module sound-service-1-0
Jul 25 02:17:52 shaunsputer modprobe: modprobe: Can't locate module sound-slot-1
Jul 25 02:17:52 shaunsputer modprobe: modprobe: Can't locate module sound-service-1-0
Jul 25 02:20:04 shaunsputer modprobe: modprobe: Can't locate module sound-slot-1
Jul 25 02:20:04 shaunsputer modprobe: modprobe: Can't locate module sound-service-1-0
Jul 25 02:20:04 shaunsputer modprobe: modprobe: Can't locate module sound-slot-1
Jul 25 02:20:04 shaunsputer modprobe: modprobe: Can't locate module sound-service-1-0
I have no idea how to fix any of this, all confusing to me I've tried searching in modules.conf and in the rc.d files, cant find anything

Any help appreciated
 
Old 07-26-2004, 04:35 PM   #2
LadFromWales85
Member
 
Registered: Apr 2003
Location: Wales, UK
Distribution: Slackware 10
Posts: 30

Original Poster
Rep: Reputation: 15
Can anyone be of any help to me?
 
Old 07-26-2004, 08:19 PM   #3
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,614

Rep: Reputation: 136Reputation: 136
Maybe something wrong with your /etc/modules.conf

Try as root :

depmod -a
 
Old 07-27-2004, 04:02 PM   #4
LadFromWales85
Member
 
Registered: Apr 2003
Location: Wales, UK
Distribution: Slackware 10
Posts: 30

Original Poster
Rep: Reputation: 15
Tried that, didnt solve the problem

I've discovered that when it spams the information about loading modules for cd rom's, my pc locks up for 5-10 seconds, which is very annoying, and I cant find out whats triggering it
 
Old 07-28-2004, 05:10 AM   #5
Cedrik
Senior Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 2,140

Rep: Reputation: 242Reputation: 242Reputation: 242
Did you try to disable hotplug (chmod -x /etc/rc.d/rc.hotplug) or if you keep it enabled, did you try to put the concerning modules in /etc/hotplug/blacklist ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sendmail errors - in logs mac_casey Linux - Newbie 0 01-31-2005 08:20 AM
Boot errors; can't find them in logs itzfritz Linux - General 1 11-15-2004 03:04 PM
make modules errors out zmanea Linux - Newbie 2 02-26-2004 08:54 AM
Module Errors with no modules used? mikeyt_333 Linux - General 4 02-02-2002 10:31 PM
booting - modules errors elist Linux - General 3 02-01-2002 04:54 AM


All times are GMT -5. The time now is 06:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration