LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-27-2004, 12:21 PM   #1
netindustries
LQ Newbie
 
Registered: Mar 2004
Location: Indianapolis
Distribution: Slackware 9.1
Posts: 25

Rep: Reputation: 15
modprobe hp100 "device not found"


I am trying different distributions on an old AT machine. My hp100 card was successfully found on Red Hat 6.0 with autoprobing:
# modprobe hp100 hp100_port=0

In Slackware 9.1 this is the result:
/lib/modules/2.4.22/kernel/drivers/net/hp100.o.gz: init_module: no such device
/lib/... : Hint: insmod errors... blah blah blah
... hp100.o.gz: insmod hp100 failed

I tried specifying hp100_port=0x330. I think this is where Red Hat said it was found. Netconfig's card probe said it found a card using sk98lin.o, but lsmod said it is unused. I edited /etc/modules.conf with:
alias eth0 hp100
options eth0 hp100_port=0
and rebooted, with the same result as previous in the bootup message.

Sorry if this sounds dumb, but I thought the modules I modprobed in other distros were .o files. Do I need to gunzip the hp100.o.gz file first, or is this automatic in Slackware?

Ideas?
Thanks.

PS - I edited the alias line in this message. I missed hp100 but it is in my modules.conf.

Last edited by netindustries; 03-27-2004 at 02:05 PM.
 
Old 03-27-2004, 02:33 PM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Redhat most likely comes default with this module enabled. Slackware doesn't. You will either need to compile the module or recompile the kernel to add the support.
 
Old 03-27-2004, 03:21 PM   #3
netindustries
LQ Newbie
 
Registered: Mar 2004
Location: Indianapolis
Distribution: Slackware 9.1
Posts: 25

Original Poster
Rep: Reputation: 15
Slackware came with the hp100.o.gz module. I really need to recompile the kernel?
 
Old 03-27-2004, 04:15 PM   #4
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Quote:
Originally posted by netindustries
Slackware came with the hp100.o.gz module. I really need to recompile the kernel?
Where are you finding that module? If its not in /lib/modules/path/to/module then it wasn't compiled with the current kernel.
Well its not Slackware but support from the kernel like mentioned. Most likely by default or using the default kernel with Slackware it didn't compile support. Like I mentioned before, compile the module or recompile the kernel to add the support.

Last edited by trickykid; 03-27-2004 at 04:16 PM.
 
Old 03-27-2004, 05:42 PM   #5
netindustries
LQ Newbie
 
Registered: Mar 2004
Location: Indianapolis
Distribution: Slackware 9.1
Posts: 25

Original Poster
Rep: Reputation: 15
Recompiling the kernel right now with built-in support for HP 10/100, we'll see...
Then what, I need to load the module?
 
Old 05-20-2004, 12:26 AM   #6
snocked
Member
 
Registered: Dec 2002
Location: St. Louis, MO
Distribution: Slackware 9.1
Posts: 482

Rep: Reputation: 30
Recompiling the kernel still doesn't work because the module already is in the stock kernel config. Still no one seems to know how to fix "eth0: unknown interface: No such device" error and get eth0 recognized regardless of module.
 
Old 05-20-2004, 12:32 AM   #7
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware-current
Posts: 1,244

Rep: Reputation: 47
is hotplug already loading some other module for it. I have seen that message before when I had hotplug enabled after an update. hotplug always wants to load tulip for me. But i need dmfe.... i get that same message you got only about dmfe, because at that point tulip is already claiming that device.
 
Old 05-20-2004, 12:45 AM   #8
subgenius
Member
 
Registered: Mar 2004
Distribution: Slackware 9.1
Posts: 41

Rep: Reputation: 15
Did you try just 'modprobe hp100' without the port parameter?

Generally, if the module is included with the kernel-modules package, which
matches the kernel-ide package, it should work.

And no, you do not have to worry about the .gz. It is uncompressed
when accessed.
 
Old 09-05-2004, 06:00 PM   #9
netindustries
LQ Newbie
 
Registered: Mar 2004
Location: Indianapolis
Distribution: Slackware 9.1
Posts: 25

Original Poster
Rep: Reputation: 15
Thanks for the help.
If anyone still cares, I recompiled the kernel with support for it and it worked.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Successful install" results in "Boot device not found" slackr007 Fedora 2 06-21-2005 05:05 PM
"Successful install" results in "Boot device not found" slackr007 Linux - Newbie 2 05-31-2005 09:02 PM
alsaconf detects device that is un"modprobe"able fazaman Linux - Hardware 1 02-06-2005 02:32 PM
cupsd, many "modprobe: can't locate device /dev/usb.." at boot bit7 Linux - Software 1 01-16-2004 09:42 PM
cupsd, many "modprobe: can't locale device /dev/usbxx" at boot.. bit7 Linux - Software 0 01-16-2004 02:40 AM


All times are GMT -5. The time now is 09:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration