LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-23-2007, 09:57 AM   #1
rshepard
Member
 
Registered: Oct 2007
Location: Troutdale, Oregon
Distribution: Slackware
Posts: 130

Rep: Reputation: 15
modprobe.conf in Slackware-12.0


If /etc/modprobe.d/modprobe.conf is deprecated in -12.0, why does the boot process keep looking for it and reporting that it's not found?

Just curious,

Rich
 
Old 10-23-2007, 06:46 PM   #2
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
I've never seen this - what exactly is looking for it (and more importantly, why?)
 
Old 10-24-2007, 08:34 AM   #3
rshepard
Member
 
Registered: Oct 2007
Location: Troutdale, Oregon
Distribution: Slackware
Posts: 130

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by rworkman View Post
I've never seen this - what exactly is looking for it (and more importantly, why?)
Ah, grasshopper! That's the question of the day. :-) Here's where it appears in /var/log/messages:

Oct 24 06:16:15 lemna logger: /etc/rc.d/rc.inet1: /sbin/ifconfig eth0 192.168.55.3 broadcast 192.168.55.63 netmask 255.255.255.192
Oct 24 06:16:15 lemna logger: /etc/rc.d/rc.inet1: /sbin/route add default gw 192.168.55.4 metric 1
Oct 24 06:16:15 lemna logger: /etc/rc.d/rc.inet1: /sbin/ifconfig lo 127.0.0.1Oct 24 06:16:16 lemna logger: /etc/rc.d/rc.inet1: /sbin/route add -net 127.0.0.0 netmask 255.0.0.0 lo
Oct 24 06:16:19 lemna modprobe: WARNING: Failed to open config file /etc/modprobe.d/modprobe.conf: No such file or directory

While the system is booting, I see multiple copies of the message scroll by. In the log, this is the sequence for the past three days.

Whether the warning is related to bringing up the network interfaces is not certain.

It is a warning, not a fatal error, but it should not be there anyway.

Any ideas, Robby?

Rich
 
Old 10-24-2007, 08:55 AM   #4
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
Show this output:
Code:
ls -l /etc/modprobe.d /etc/modprobe.conf
 
Old 10-24-2007, 11:59 AM   #5
rshepard
Member
 
Registered: Oct 2007
Location: Troutdale, Oregon
Distribution: Slackware
Posts: 130

Original Poster
Rep: Reputation: 15
There is no /etc/modprobe.conf. /etc/modprobe.d/modprobe.conf is a broken link to the no-longer-existing /etc/modprobe.conf

Rich
 
Old 10-24-2007, 12:34 PM   #6
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
Either remove the broken symlink or put /etc/modprobe.conf back - the stock installation includes it, so you must have removed it.
 
Old 10-24-2007, 02:25 PM   #7
rshepard
Member
 
Registered: Oct 2007
Location: Troutdale, Oregon
Distribution: Slackware
Posts: 130

Original Poster
Rep: Reputation: 15
This is interesting, Robby. You're correct that I probably removed it because it says that it's deprecated and all module information should be placed in /etc/modprobe.d/.

I re-installed module-init-tools*.tgz and it put that short version of /etc/modprobe.conf back, along with a working link in /etc/modprobe.d/. I am sure that now the warning will not appear when I next reboot the notebook.

However, why is a non-functional /etc/modprobe.conf included if it has been deprecated with the 2.6.x kernels and no longer used?

Thanks,

Rich
 
Old 10-24-2007, 02:39 PM   #8
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
Rather than retype it, I'm going to post a message that I wrote in response to a similar question on a mailing list:
Quote:
> Havinge recently upgraded to slackware 12, I notice there is no
> modules.conf file, please forgive me if this has been discussed before,
> but I'm curous as to why? I realise that it was empty on a stock
> slackware install but it was a good place to edit some of the kernel
> options such as disabling net protocols with entries such as:
>
> alias net-pf-4 off # IPX
>
> is this still acceptable practice and if not what is the correct
> procedure? Thanks in advance.


/etc/modules.conf was the file to place module load parameters when
using the old modutils (for 2.4.x kernels). For 2.6.x kernels,
module loading is handled by the module-init-tools package, which
looks at the contents of /etc/modprobe.conf and then each file in
the /etc/modprobe.d/ directory.

*HOWEVER* -- *READ* *THIS* :-)

The usage of /etc/modprobe.conf is indeed deprecated and will be
phased out at some point in the future - I personally have confirmed
this with Jon Masters, the module-init-tools maintainer. As such,
Slackware's module-init-tools package includes a two line patch to
modprobe.c which reverses the checking order to look at the contents
of /etc/modprobe.d/ before /etc/modprobe.conf - this is to help ease
everyone into the transition. To further ease the process, you'll
notice that /etc/modprobe.d/modprobe.conf is a symlink to the actual
/etc/modprobe.conf file, so anyone still using the "old" location will
not notice any problems :-)

With all that said, you can put module load options into a custom file
(or files) in /etc/modprobe.d/ -- there are very few restrictions on
the filenames that are looked at, and I don't happen to recall them
at the moment, but you might look at how -current is doing it right
now: there's 'blacklist' for blacklisting modules (preventing them
from being automatically loaded) [1], there's 'isapnp' to define some
common isapnp aliases, there's 'psmouse' to make the psmouse module
load with the imps protocol by default, and so on. You could follow
this convention and use a file called 'aliases' or 'net-pf' or pretty
much whatever you want.

[1] There were quite a few problems with 12.0 during its development
with the pcspkr module being loaded even though it was commented
out in rc.modules and blacklisted in /etc/modprobe.d/blacklist -
it turns out that it was due to the isapnp alias for it; the
blacklist was being ignored for module aliases. This was one of
many fixes that went into the new module-init-tools 3.4 that's in
-current now.

Hope that helps,
-RW
 
Old 10-24-2007, 02:42 PM   #9
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
By the way, if you don't want the /etc/modprobe.conf file there (as it's not needed), that's okay -- you just have to remove the (now-broken) symlink to it in /etc/modprobe.d/
Otherwise, module-init-tools will look at the symlink, but the file it points to doesn't exist, so you get that warning message.
 
Old 10-24-2007, 02:59 PM   #10
rshepard
Member
 
Registered: Oct 2007
Location: Troutdale, Oregon
Distribution: Slackware
Posts: 130

Original Poster
Rep: Reputation: 15
Robby,

Thank you very much for the mail list reprint. It makes everything clear. Doesn't matter to me if the deprecated file and symlink remain until the next upgrade; it's harmless.

Much appreciated,

Rich
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
modprobe doesn't work; why is modprobe.conf deprecated in slack 12? aquilolumen Slackware 13 08-26-2007 02:05 AM
modprobe.conf : is this ok? Hitboxx Linux - Newbie 4 12-30-2006 06:29 AM
Questions re - /etc/modprobe.d/modprobe.conf The_Outlander Slackware 9 12-12-2006 08:28 PM
modprobe.conf from modules.conf Vaxon Linux - Hardware 1 09-22-2004 05:22 AM
[FC2] How to write a modprobe.conf from a module.conf??? Coume Fedora 0 05-31-2004 03:40 AM


All times are GMT -5. The time now is 01:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration