LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-15-2003, 01:08 PM   #1
skeetnah
LQ Newbie
 
Registered: Nov 2003
Posts: 27

Rep: Reputation: 15
modprobe: Can't find module eth1


I get "modprobe: Can't find module eth1" at boot and when I run "modprobe eth1"... I suppose I need the eth1 module to get any type of wireless anything to run and I need my pci wireless adapter to be working to connect to the internet. I am constantly rebooting to run windowsxp to access the internet to find anything linux related because I cannot get my wireless adapter to work!

So can anyone suggest why eth1 is not being found?
 
Old 12-15-2003, 01:17 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Because there is no module by that name?

You need to make an ALIAS in /etc/modules.conf


alias eth1 <physcial device's driver>



Cheers,
Tink
 
Old 12-15-2003, 01:20 PM   #3
skeetnah
LQ Newbie
 
Registered: Nov 2003
Posts: 27

Original Poster
Rep: Reputation: 15
I actually have that in /etc/modules.conf... I can't remember what the line was, I got it from ndiswrapper's README. I'll see if I can find it without having to boot back to slack then back to here to post it.
 
Old 12-15-2003, 01:24 PM   #4
skeetnah
LQ Newbie
 
Registered: Nov 2003
Posts: 27

Original Poster
Rep: Reputation: 15
Hah, the line is "alias eth1 ndiswrapper". That is what I have added to /etc/modules.conf. Also, the README said to add:

post-install ethX /path/to/loaddriver x y /path/to/driver.sys /path/to/driver.inf

I have both of the lines added...
 
Old 12-16-2003, 02:07 AM   #5
malo_umoran
Member
 
Registered: Dec 2003
Distribution: Desktop: Slackware 13.1 &13.37 | Server: Debian 6.0
Posts: 270

Rep: Reputation: 32
did you enable wireless support in kernel???

if recognized, you should have /proc/(something)/wireless or /proc/wireless.

M.
 
Old 12-16-2003, 06:01 AM   #6
skeetnah
LQ Newbie
 
Registered: Nov 2003
Posts: 27

Original Poster
Rep: Reputation: 15
I'm not sure if I have wireless enabled. But, if I don't, how do I enable it? I'll check if I have /proc/wireless or /proc/(something)/wireless now...
 
Old 12-16-2003, 06:09 AM   #7
malo_umoran
Member
 
Registered: Dec 2003
Distribution: Desktop: Slackware 13.1 &13.37 | Server: Debian 6.0
Posts: 270

Rep: Reputation: 32
somewhere in kernel, I think under "networking devices" is wireless also.

if your driver is on the list, install it like a module, and if not google for it. after you install drivers, you'll get a module in /lib/modules/linux..../misc or /lib/modules/linux.../kernel/net/ and you can load it with:

"modprobe name_of_the_module"

"iwconfig -a" will show you all wireless devices if recognized.


"man iwconfig" to see all options.

M.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
device eth0 entered prominous mode & modprobe:pppt0 Module can't find out !! AZIMBD03 Linux - Hardware 0 06-01-2004 02:08 AM
wireless_tools and modprobe: Can't find module eth1 dibblethewrecke Linux - Software 5 02-06-2004 02:06 PM
Kernel 2.4.22 finds eth0 and eth1 but 2.6.0 does not find eth1 coollink Linux - Networking 3 01-13-2004 07:32 PM
modprobe: Can't find module mickeyboy Red Hat 1 09-13-2003 10:46 PM
modprobe: modprobe can't locate module ppp0 in redhat 7.1 while shutting down. cyberdude3k Linux - Networking 1 09-08-2003 12:01 PM


All times are GMT -5. The time now is 04:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration