LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-30-2004, 09:15 PM   #1
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
modprobe: Can't locate module char-major-4


I don't really even know how to ask this question, but I looked in /var/log/syslog just because it takes my Slack system about
one minute to boot, and that seems very slow for my hardware. When I ran Debian it booted in about 20 seconds. I noticed this
line and can't determine why it's doing this. I've Googled and searched LQ and read lots, but nothing seems to apply.

Code:
Jan 31 07:37:18 paul modprobe: modprobe: Can't locate module char-major-4
Jan 31 07:37:18 paul last message repeated 31 times
This is all that's in modules config file
Code:
mingdao@paul:Sat Jan 31 09:19:00~$ cat /etc/modules.conf
alias char-major-195 nvidia
Can someone even point me in the right direction to get somewhere with this?
 
Old 01-30-2004, 09:33 PM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
i think thats something to do with a generic serial port, and if its not in your modules.conf, did you try looking in /etc/rc.d/rc.modules ?

or i think by adding :
char-major-4 off
to your modules.conf file should stop it also ..
 
Old 01-30-2004, 09:40 PM   #3
DaHammer
Member
 
Registered: Oct 2003
Location: Planet Earth
Distribution: Slackware, LFS
Posts: 561

Rep: Reputation: 30
Don't recall what that is, but you can turn it off by adding this to your modules.conf

alias char-major-4 off
 
Old 01-30-2004, 10:33 PM   #4
LinFreak!
Member
 
Registered: Jul 2003
Location: England
Distribution: slack9.1
Posts: 209

Rep: Reputation: 30
another place to disable it from is /etc/hotplug/blacklist - just add it to the list.

edit: ignore this, it stops modules loading.

Last edited by LinFreak!; 01-31-2004 at 03:20 PM.
 
Old 01-30-2004, 11:45 PM   #5
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Original Poster
Rep: Reputation: 124Reputation: 124
Quote:
Originally posted by DrOzz
i think thats something to do with a generic serial port, and if its not in your modules.conf, did you try looking
in /etc/rc.d/rc.modules ?
No serial port built-in or modules - nothing in /etc/rc.d/rc.modules.
Quote:
or i think by adding :
char-major-4 off
to your modules.conf file should stop it also ..
When I added it without the word alias...
Code:
mingdao@paul:Sat Jan 31 11:29:02~$ cat /etc/modules.conf
alias char-major-195 nvidia
char-major-4 off
mingdao@paul:Sat Jan 31 11:29:15~$
Code:
mingdao@paul:Sat Jan 31 11:21:39~$ startx


XFree86 Version 4.3.0
Release Date: 27 February 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.22 i686 [ELF]
Build Date: 16 September 2003
        Before reporting problems, check http://www.XFree86.Org/
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sat Jan 31 11:21:40 2004
(==) Using config file: "/etc/X11/XF86Config"
NV: could not open control device /dev/nvidiactl (No such device)
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0):  *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.

XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.
X wouldn't start. You need to have the word alias in the line ->
alias char-major-4 off
which did stop that message.

It still boots just as slow. When booting, it gets to this point in 15 seconds
Code:
PCI: Sharing IRQ 11 with 00:1d.7
tg3: eth0: Link is up at 100 Mbps, full duplex.
tg3: eth0: Flow control is on for TX and on for RX.
and spends about 16 seconds there bringing up the NIC. Then
it finishes the rest in another 15 seconds, still taking 53 secs. to boot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
modprobe: Can'l locate module char-major-108 Guvvy Linux - Newbie 5 02-03-2005 10:57 PM
modprobe: modprobe: Couldn't locate module nvnet.o/nvaudio.o xiojqwnko Linux - Newbie 2 12-08-2003 06:41 PM
"modprobe: can't locate module char-major-188"mesage eye Red Hat 4 10-23-2003 08:09 PM
modprobe: modprobe can't locate module ppp0 in redhat 7.1 while shutting down. cyberdude3k Linux - Networking 1 09-08-2003 01:01 PM
No modem after kernel upgrade: Modprobe can't locate module char-major-4 Rimmer Linux - General 2 05-09-2001 03:40 AM


All times are GMT -5. The time now is 03:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration