LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-08-2003, 04:25 AM   #1
kc00l
Member
 
Registered: Oct 2003
Location: France/Italy
Distribution: Slackware Current
Posts: 83

Rep: Reputation: 15
modinst error when "make modules_install", kernel 2.4.22


I'm using Slackware 9.1 kernel 2.4.22 already recompiled for my Omnibook xe3 GF.
I had successfully recompiled my kernel several times in the past, and even used some branches of the 2.6.0 test kernel. Never had a problem which I couldn't solve by reading READMEs, HOWTOs or searching the web.

So, I decided to add PPP kernel support to use my home ADSL connection.
[Yes, I know I didn't need to recompile the entire kernel sources for that, but didn't think about that before starting the compile process.]
Anyway, I started making the correct symbolic link for the source:
Code:
cd /usr/src/
ln -s linux-2.4.22 linux
then the usual cleaning:
Code:
cd linux
make clean
make mrproper
and following the usual 2.4.XX procedure:
Code:
cp ../kernelconfigs/config-2.4.22 .config
make menuconfig
I enabled PPP as a module then:
Code:
make dep
make bzImage; make modules
all this procedure without errors. So I went on and did:
Code:
make modules_install
and then I got the following error:
Code:
ln: when making multiple links, last argument must be a directory
make: *** [_modinst_] Error 1
I then searched the Makefile for the lines referring to the "make modules_install" procedure, and found the following:
Code:
_modinst_:
        @rm -rf $(MODLIB)/kernel
        @rm -f $(MODLIB)/build
        @mkdir -p $(MODLIB)/kernel
        @ln -s $(TOPDIR) $(MODLIB)/build
This fails me... is this procedure interpreted as if I were making multiple links?
Could be due to the fact I've made some modifications to my
/etc/profile
/etc/bashrc
/etc/inputrc
?
Thanks for your attention and I'm sorry for the lenght of the post.
 
Old 12-08-2003, 06:52 AM   #2
Misel
Member
 
Registered: Mar 2003
Location: Berlin
Distribution: Slackware current
Posts: 310

Rep: Reputation: 30
hmmm, I don't know what the error means but usually it helps when you do a "make mrproper" and recompile again.

Don't forget to backup your kernel config
 
Old 12-09-2003, 01:30 AM   #3
kc00l
Member
 
Registered: Oct 2003
Location: France/Italy
Distribution: Slackware Current
Posts: 83

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Misel
hmmm, I don't know what the error means but usually it helps when you do a "make mrproper" and recompile again.

Don't forget to backup your kernel config
I've done both, as usual, but still no cigar...
Thanks for your reply, anyway.
 
Old 12-09-2003, 06:06 AM   #4
kc00l
Member
 
Registered: Oct 2003
Location: France/Italy
Distribution: Slackware Current
Posts: 83

Original Poster
Rep: Reputation: 15
Well I didn't attach my
/etc/profile
/etc/bashrc
/etc/inputrc

to the original post so maybe I could do that now, instead of just *bumping* the post...
Code:
# Begin /etc/profile
# Written for Beyond Linux From Scratch
# by James Robertson <jameswrobertson@earthlink.net>

# System wide environment variables and startup programs.

# System wide aliases and functions should go in /etc/bashrc.  Personal
# environment variables and startup programs should go into
# ~/.bash_profile.  Personal aliases and functions should go into
# ~/.bashrc.

# Function to help us manage paths
pathman () {
        if ! echo $PATH | /bin/egrep -q "(^|:)$1($|:)" ; then
                if [ "$2" = "last" ] ; then
                        PATH=$PATH:$1
                else
                        PATH=$1:$PATH
                fi
        fi
}

# Add to the standard path.
if [ $(id -u) = 0 ] ; then
        if [ -d "/usr/local/sbin" ] ; then
                pathman /usr/local/sbin last
        fi
fi

if [ $(id -u) != 0 ] ; then
        if [ -d "/usr/local/bin" ] ; then
                pathman /usr/local/bin last
        fi
fi

if [ -d "/usr/X11R6/bin" ] ; then
        pathman /usr/X11R6/bin last
fi

# Setup some environment variables.
HISTSIZE=1000
HISTIGNORE="&:[bf]g:exit"
PS1="[\u@\h \w]\\$ "

# Setup the INPUTRC environment variable.
if [ -z "$INPUTRC" -a ! -f "$HOME/.inputrc" ] ; then
        INPUTRC=/etc/inputrc
fi

# Setup for /bin/ls to support color, the alias is in /etc/bashrc.
if [ -f "/etc/DIR_COLORS" ] ; then
        eval $(dircolors -b /etc/DIR_COLORS)

        if [ -f "$HOME/.dir_colors" ] ; then
                eval $(dircolors -b $HOME/.dir_colors)
        fi
fi


PATH="$PATH:/usr/X11R6/bin:/usr/games:$HOME/bin:/usr/local/mozilla:/usr/local/bin:/usr/share/texmf:/usr/local/Acrobat5/bin:."

export PATH HISTSIZE HISTIGNORE PS1 LS_COLORS INPUTRC

# End /etc/profile# /etc/inputrc
# This file configures keyboard input for programs using readline.
# See "man 3 readline" for more examples.

# Configure the system bell.  Options are none, visible, and audible.
#set bell-style none

# Enable 8 bit input.
set meta-flag On
set input-meta On
set convert-meta Off
set output-meta On

# Set various nice escape sequences:
"\eOd": backward-word
"\eOc": forward-word

# for linux console
"\e[1~": beginning-of-line
"\e[4~": end-of-line
"\e[5~": beginning-of-history
"\e[6~": end-of-history
"\e[3~": delete-char
"\e[2~": quoted-insert

# for xterm
"\eOH": beginning-of-line
"\eOF": end-of-line

# for freebsd console
"\e[H": beginning-of-line
"\e[F": end-of-line
# Begin /etc/bashrc
# Written for Beyond Linux From Scratch
# by James Robertson <jameswrobertson@earthlink.net>

# System wide aliases and functions.

# System wide environment variables and startup programs should go into
# /etc/profile.  Personal environment variables and startup programs
# should go into ~/.bash_profile.  Personal aliases and functions should
# go into ~/.bashrc

# By default we want the umask to get set.
# Even for non-interactive and non-login shells.
if [ "$(id -gn)" = "$(id -un)" -a $(id -u) -gt 99 ] ; then
        umask 002
else
        umask 022
fi

# Provides a colored /bin/ls command.  Used in conjunction with code in
# /etc/profile.
alias ls='ls --color=auto'

# Provides prompt for non-interactive shells, specifically shells started
# in the xfree environment. [Review archive thread titled PS1
# Environment Variable for a great case study behind this script
# addendum.]
export PS1="[\u@\h \w]\\$ "

# End /etc/bashrc
Again, sorry for the long post.

Last edited by kc00l; 12-09-2003 at 07:13 AM.
 
Old 12-09-2003, 08:34 AM   #5
cimmer
LQ Newbie
 
Registered: Dec 2003
Posts: 17

Rep: Reputation: 0
post a few lines preceeding the error
 
Old 12-09-2003, 09:33 AM   #6
kc00l
Member
 
Registered: Oct 2003
Location: France/Italy
Distribution: Slackware Current
Posts: 83

Original Poster
Rep: Reputation: 15
Unfortunately there are no preceding lines...
"make modules_install" just tries to create the modules directory for the custom kernel (I've modified the Makefile extraversion) and then stops cause it doesn't interpret correctly this part:

Code:
@ln -s $(TOPDIR) $(MODLIB)/build
Actually it's some part of $MODLIB which I think it's not recognized as a directory...
Code:
TOPDIR	:= $(shell /bin/pwd)
MODLIB	:= $(INSTALL_MOD_PATH)/lib/modules/$(KERNELRELEASE)
KERNELRELEASE=$(VERSION).$(PATCHLEVEL).$(SUBLEVEL)$(EXTRAVERSION)
Maybe I could just manually install modules by making what "make modules_install" does but this won't solve the problem and won't help me understand where's the problem.
 
Old 12-10-2003, 09:12 AM   #7
kc00l
Member
 
Registered: Oct 2003
Location: France/Italy
Distribution: Slackware Current
Posts: 83

Original Poster
Rep: Reputation: 15
So, after a little bit more googling (I searched for the complete error msg I get) I found I'm not the only one (are we ever the only ones to experience problems?) to get this error message when recompiling the kernel.
From what I found it seems the point is the syntax of the EXTRAVERSION in the top Makefile. My EXTRAVERSION is:
Code:
EXTRAVERSION = -myker.091203
Looking at the other kernels images I have in my /boot directory it seems they don't have a
"." in their name...

Anyway I'm recompiling now without that dot in the extraversion. I feel that's the error.

I hope this little kernel experience may help others which have/have had/will have the same error message.

EDIT:
I found the error:

"make dep" before editing the EXTRAVERSION of the top Makefile
ie, I made sure to have an empty EXTRAVERSION Makefile before doing "make dep" and only after "make dep" has finished change the EXTRAVERSION.

Last edited by kc00l; 12-10-2003 at 12:54 PM.
 
Old 01-23-2004, 02:28 PM   #8
maykon
LQ Newbie
 
Registered: Jan 2004
Posts: 1

Rep: Reputation: 0
Smile

Normally this occurs when you leave a blank space in the field EXTRAVERSION=

For example: edit the Makefile, locate the EXTRAVERSION line end verify if you have the blank space "EXTRAVERSION= -1.mcs ". Erase the blank space "EXTRAVERSION= -1.mcs" end re-compile the kernel.

Bye.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel compilation error : in "make modules_install" b0nd Linux - Newbie 5 06-11-2013 07:15 AM
WARNING message when "make modules_install" wakjoko Linux - Hardware 3 01-29-2005 07:39 AM
2.6 test6 "make modules_install" problem yocompia Slackware 2 10-06-2003 03:56 AM
LFS 4.1: Stalled at Perl, "missing seperator" error from "make" SparceMatrix Linux From Scratch 1 06-07-2003 03:31 PM
Why do I always get errors in "make modules_install" ? JoeLinux Linux - General 6 04-12-2002 01:41 PM


All times are GMT -5. The time now is 08:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration