LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 09-11-2008, 02:08 PM   #1
glore2002
Member
 
Registered: Mar 2007
Location: Buenos Aires, Argentina.
Distribution: Debian Lenny AMD64
Posts: 506

Rep: Reputation: 32
Modifying xorg.conf to set up monitor to 1280x1024 60hz refresh rate.


Hi Back,

Now if I right click on my desktop and choose Configure Desktop->Display, I see my monitor is displaying 1280x1024 at 50hz refresh rate. If I try to change the refresh rate, available options are: 50 or 54.

My monitor (Samsung 732nplus) has a recommended refresh rate of 60hz and a recommeded resolution of 1280x1024. So, resolution is ok but refresh rate should be changed to 60.

What parameter/s should I change to set refresh rate to 60?

I've tried to change this to nVidia X server settings but then I wasn't able to boot my system again into X (as I've mentioned in a previous post).

This is my xorg.conf file (screen related sections):

Code:
Section "Monitor"
    Identifier  "My Monitor"
    HorizSync   31 - 81
    VertRefresh 56-75
EndSection

Section "Device"
    Identifier  "VESA Framebuffer"
    Driver      "nvidia"
EndSection

Section "Screen"
    Identifier  "Screen 1"
    Device      "VESA Framebuffer"
    Monitor     "My Monitor"
    DefaultDepth 24
    Subsection "Display"
        Depth       8
        Modes "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       16
        Modes "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       24
        Modes "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
    Subsection "Display"
        Depth       32
        Modes "1280x1024" "1024x768" "800x600" "640x480"
    EndSubsection
EndSection
Thanks,
Glore2002.-
 
Old 09-11-2008, 02:20 PM   #2
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728
I don't pretend to totally understand how this works. Things I have used successfully:

1. Set the monitor vert. refresh to 59.9-60.1

2. Use a modeline (generate using gtf)
 
Old 09-11-2008, 02:24 PM   #3
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,282

Rep: Reputation: 66
Could you set it with the nvidia-settings program ?
 
Old 09-11-2008, 02:28 PM   #4
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728
I am running a 1920x1200 LCD on an Nvidia card (nvidia driver). The vert refresh was set to 50-70, and xrandr said it was actually running at 50. Curiously, it gives other modes available as follows:
Code:
1920x1200      50.0* 
   1680x1050      51.0     52.0  
   1600x1200      53.0  
   1600x1024      54.0  
   1440x900       55.0  
   1400x1050      56.0     57.0     58.0  
   1280x1024      59.0     60.0  
   1280x960       61.0 
<snipped>
Out of curiousity, I changed the vert refresh to 58-62, and nothing changed. I assume this means it is working off of the data it gets directly from the monitor.

The screen does not flicker and looks great, so I don't care to find out what's going on---at least for now....
 
Old 09-11-2008, 02:31 PM   #5
glore2002
Member
 
Registered: Mar 2007
Location: Buenos Aires, Argentina.
Distribution: Debian Lenny AMD64
Posts: 506

Original Poster
Rep: Reputation: 32
Quote:
Originally Posted by keefaz View Post
Could you set it with the nvidia-settings program ?
The nVidia setup program gave me the possibility to change refresh to 60 but it generates a new xorg.conf. With this new xorg.conf my computer couldn't boot up.

Glore2002.-
 
Old 09-11-2008, 02:39 PM   #6
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,282

Rep: Reputation: 66
Just use show preview after you click "Save to X file...", click cancel after that
Then note the options in "Screen" section, and add Screen option in xorg.conf
In the hope that is not the option that makes X un-startable though
 
Old 09-11-2008, 02:39 PM   #7
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728Reputation: 728
I used nvidia-settings and changed the refresh rate from "auto" to 60. xrandr then said that i now had 2 options for the 1920x1200 mode: 50 and 100. The refresh rate for the other modes was the same as before.

I have NO CLUE what is going on.....
 
Old 09-11-2008, 02:44 PM   #8
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,282

Rep: Reputation: 66
Be carefull, I just noticed the xorg.conf generated by nvidia-settings does not use the same Identifier names as the original xorg.conf in sections!!!

No wonder X will not start if you just copy one section for example, the identifier names must match between sections
 
Old 09-11-2008, 02:55 PM   #9
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,253

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
Quote:
What parameter/s should I change to set refresh rate to 60?
This sounds much like the problem I experienced and shared:

https://www.linuxquestions.org/quest...701/page2.html

I use a Samsung 712N monitor with the same basic display specs. I use the proprietary nvidia drivers. The solution I discovered solved the incorrect reporting of the display settings.

I hope this helps.
 
Old 09-11-2008, 03:23 PM   #10
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,282

Rep: Reputation: 66
Thanks Woodsman for the tip about DynamicTwinView, much appreciated
 
Old 09-11-2008, 05:40 PM   #11
glore2002
Member
 
Registered: Mar 2007
Location: Buenos Aires, Argentina.
Distribution: Debian Lenny AMD64
Posts: 506

Original Poster
Rep: Reputation: 32
Thumbs up Great Tip and Great Slackware Team!

#1: Woodsman: Your research work deserves an "A" :-)
#2: Now I can choose between 60 and 75hz. It works OK.
#3: What I finally added was:
Code:
Option "DynamicTwinView" "false"
to the Screen section of my xorg.conf. That solved the problem.


Thanks to all of you. You're the best source of information I ever had!!!

Glore2002.-
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with setting the right refresh rate. xorg.conf Deadw Slackware 13 04-01-2008 06:47 AM
xorg.conf, refresh rate and viewsonic VX2025wm mala fide Linux - Hardware 8 10-18-2006 12:19 AM
Xorg and refresh rate of AOCd556 Monitor nexus06 Linux - Desktop 0 10-04-2006 01:04 PM
How do I force xorg.conf to accept certain refresh rate? ExCIA Debian 9 08-06-2006 08:11 PM
editing refresh rate in xorg.conf does nothing Riallin Slackware 22 02-28-2005 03:31 AM


All times are GMT -5. The time now is 02:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration