LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-27-2014, 04:00 PM   #16
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Original Poster
Rep: Reputation: 137Reputation: 137

Layout:

computer ---- Belkin F5D7230 ----- Zyxel P-660R-T1 ----- ISP via telephone line
..................Wireless Access Point

samac

Last edited by samac; 04-27-2014 at 04:10 PM.
 
Old 04-27-2014, 04:14 PM   #17
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Original Poster
Rep: Reputation: 137Reputation: 137
The Belkin has a version number A000de and it is not possible to install dd-wrt. Is what you are suggesting still possible?

samac
 
Old 04-27-2014, 08:56 PM   #18
ReaperX7
Senior Member
 
Registered: Jul 2011
Distribution: LFS-SVN, Slackware-14.1, PCBSD-10.0
Posts: 2,881
Blog Entries: 15

Rep: Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743Reputation: 743
Get a Buffalo Networks router.
 
Old 04-28-2014, 09:44 PM   #19
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,437

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
Quote:
Originally Posted by samac View Post
My router is supplied by the ISP and it only wants to connect using dhcp, so a atatic IP doesn't seem to be the solutions, unless anyone knows a way around this.
Really? There's no admin interface (normally web based) that allows you to set a couple of static IP addresses?
 
Old 04-28-2014, 09:53 PM   #20
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,422
Blog Entries: 2

Rep: Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995
Quote:
Originally Posted by Richard Cranium View Post
Really? There's no admin interface (normally web based) that allows you to set a couple of static IP addresses?
Usually you don't need to do something like that. At least on my network I never did, I just used netconfig (or editing /etc/conf.d/net on Gentoo) and it worked without a problem. But that is possibly dependent on the router.
 
Old 04-28-2014, 09:54 PM   #21
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,437

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
Hmm. http://cache-www.belkin.com/support/...xxx_manual.pdf and scroll to page 45.

Setup your IP pool to not include the address that you want to give your computer that you're talking about in this thread (otherwise it might be given to another machine that logs into your network).
 
1 members found this post helpful.
Old 04-28-2014, 09:55 PM   #22
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,437

Rep: Reputation: 407Reputation: 407Reputation: 407Reputation: 407Reputation: 407
Quote:
Originally Posted by TobiSGD View Post
Usually you don't need to do something like that. At least on my network I never did, I just used netconfig (or editing /etc/conf.d/net on Gentoo) and it worked without a problem. But that is possibly dependent on the router.
Normally you do have to tell the router to not hand out your static IP to someone else.
 
Old 04-28-2014, 10:46 PM   #23
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,422
Blog Entries: 2

Rep: Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995
Quote:
Originally Posted by Richard Cranium View Post
Normally you do have to tell the router to not hand out your static IP to someone else.
You are right, but in a single user network (as described by the OP) that won't happen.
 
Old 04-29-2014, 02:17 AM   #24
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Original Poster
Rep: Reputation: 137Reputation: 137
@Richard Cranium
Thanks for the link much better than the pamphlet that came with the router. I do have access to the router, but I haven't been able to set things up yet, perhaps the manual will help (I hear cries of RTFM resound widely across the internet).

@TobiSGD & Richard Cranium
Could it have something to do with the Belkin Wireless router being set up as a wireless access point that is causing the problem with it not connecting through to the internet when I set a static IP in rc.inet1.conf

samac
 
Old 04-29-2014, 05:02 AM   #25
enorbet
Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware 14 is Main OpSys on Main PC, 2ndary are OpenSuSe 13 and SolydK
Posts: 674

Rep: Reputation: 268Reputation: 268Reputation: 268
Quote:
Originally Posted by samac View Post
I have a broadband router set up a wireless access point. Could I use this? If so, how?

samac
Easy. A Wireless Access Point behaves as if it were a NIC so only requires DHCP setup to talk to your ISPs modem and static addy to talk with your wired NIC.

Back in the day when wireless drivers were rare (and troublesome) on Linux and nearly non-existent on OS/2 and BeOS I circumvented the problem by using a wired NIC supported sweetly in each, and connected wirelessly through a cheap little portable WAP. Worked great for years until I just decided wired was better in too many ways.
 
Old 04-29-2014, 07:13 AM   #26
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,422
Blog Entries: 2

Rep: Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995Reputation: 3995
Quote:
Originally Posted by samac View Post
@TobiSGD & Richard Cranium
Could it have something to do with the Belkin Wireless router being set up as a wireless access point that is causing the problem with it not connecting through to the internet when I set a static IP in rc.inet1.conf

samac
It shouldn't matter if you connect through WLAN or Ethernet.
 
Old 05-03-2014, 12:40 PM   #27
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Original Poster
Rep: Reputation: 137Reputation: 137
Marking this as solved.

I had to change the usage of the Belkin from a wireless access point back to a router, then I had reset it and set it back up. Then after running netconfig and restarting the network. I have internet and also a machine that boots in about 19-20 seconds after the lilo prompt.

samac
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to boot faster? george-lappies Slackware 2 05-23-2011 02:55 AM
LXer: Linux 2.6.30 Gets Faster Boot - but is Fedora Faster? LXer Syndicated Linux News 0 06-11-2009 04:40 AM
How to boot into safe mode in XP when i run dual boot XP/suse? suse91pro General 5 11-02-2006 03:28 AM
how to boot faster? chandan Linux - General 6 07-03-2003 06:36 PM
How to boot Mandrake Linux faster (skip boot option) lava Linux - General 7 02-28-2003 02:39 PM


All times are GMT -5. The time now is 08:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration