Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 04-17-2006, 02:08 PM   #1
Registered: Aug 2003
Location: Terneuzen Netherlands
Distribution: Slack current
Posts: 135

Rep: Reputation: 16
mixer settings lost

Installed kernel and alsa-driver-1.0.11rc3_2.6.15.6-i486-1.
Everything works fine except for sound.

Googling brought no clue, so I'm here to ask.

I login at init3 and mixer settings are ok.
In KDE (after startx) the mixer settings are different.
I have to adjust every time I startX.
Settings are lost although I do # alsactl store.

Any ideas?
Old 04-17-2006, 04:03 PM   #2
Senior Member
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86_64; Gentoo PPC; FreeBSD; OS X 10.9.4
Posts: 3,760
Blog Entries: 4

Rep: Reputation: 78
# alsactl restore
Old 04-17-2006, 04:40 PM   #3
Registered: Jul 2004
Location: [jax][fl][usa]
Distribution: Slackware64-current
Posts: 796

Rep: Reputation: 31
sounds like kmixer or such is interfering
and resetting your mixer to it's predefined

is arts disabled?
Old 04-17-2006, 04:53 PM   #4
Senior Member
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
the only way i know :
-start kde
-set your mixer
-logout of kde ( use the kde menu option)

after that , your mixer will be set as chosen earlier when starting kde.

btw.:there should be a kde menu option to do this,
but it isn't there or i didn't find it.


Old 04-17-2006, 04:57 PM   #5
Registered: Aug 2003
Posts: 66

Rep: Reputation: 16
if kmix is running, unset Restore Volumes on Login in preference
Old 04-18-2006, 05:52 AM   #6
Registered: Aug 2003
Location: Terneuzen Netherlands
Distribution: Slack current
Posts: 135

Original Poster
Rep: Reputation: 16
Tnx for all reactions.
Well arts is running (I guess):
mike 5755 1.3 1.5 65072 13960 ? S 11:38 0:02 artsd -F 10 -S 4096 -d -s 60 -m artsmessage -c drkonqi -l 3 -f

Unsetting restore volumes solved the problem of changing the settings.
I don't get the KDE-sound at start of desktop.
Pressing Test Sound in Control Center gives sound and the rest of the sound apps work OK


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I save mixer settings? melinda_sayang Linux - General 10 04-09-2004 02:26 AM
Mixer settings lost Boffy Mandriva 4 03-31-2004 04:02 PM
Save mixer settings ar1 Linux - General 1 03-02-2004 11:17 AM
Mixer settings? Allen614 Slackware 5 04-20-2003 09:52 PM
Mixer Settings RefriedBean Linux - Software 2 08-06-2002 10:38 PM

All times are GMT -5. The time now is 12:28 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration