LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-13-2012, 10:17 AM   #1
sanjioh
Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 48

Rep: Reputation: Disabled
Missing vga_switcheroo userspace interface


Hi everybody,

I'm trying to turn off the Radeon 7730m in my notebook (Dell Inspiron 15R SE or model 7520), without much success.
I know it has a mux-less kind of switchable graphics, so the point here at the moment is just managing to turn off the discrete board and use only the integrated one (hd4000).
AFAIK, the way to go is vga_switcheroo. So this is what i did (Slackware 14, huge kernel 3.2.29):

- blacklist radeon module (/etc/modprobe.d/blacklist.conf with the line: blacklist radeon)
- fstab with the line:
none /sys/kernel/debug debugfs defaults 0 0
to mount debugfs at boot
- modprobe radeon after boot (I can read in /var/log/messages something similar to:
Jul 4 12:44:00 darkstar kernel: [ 8.609135] VGA switcheroo: detected switching method \_SB_.PCI0.GFX0.ATPX handle)

At this point, I should be able to:

cat /sys/kernel/debug/vgaswitcheroo/switch

Instead, /sys/kernel/debug doesn't contain any vgaswitcheroo directory (the mount is working because I can see other directories inside).

What am I missing? I can provide any kind of log if that could help.

Thanks a lot!
 
Old 11-14-2012, 05:53 AM   #2
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 248

Rep: Reputation: Disabled
Quote:
Originally Posted by sanjioh View Post
Hi everybody,

I'm trying to turn off the Radeon 7730m in my notebook (Dell Inspiron 15R SE or model 7520), without much success.
I know it has a mux-less kind of switchable graphics, so the point here at the moment is just managing to turn off the discrete board and use only the integrated one (hd4000).
AFAIK, the way to go is vga_switcheroo. So this is what i did (Slackware 14, huge kernel 3.2.29):

- blacklist radeon module (/etc/modprobe.d/blacklist.conf with the line: blacklist radeon)
- fstab with the line:
none /sys/kernel/debug debugfs defaults 0 0
to mount debugfs at boot
- modprobe radeon after boot (I can read in /var/log/messages something similar to:
Jul 4 12:44:00 darkstar kernel: [ 8.609135] VGA switcheroo: detected switching method \_SB_.PCI0.GFX0.ATPX handle)

At this point, I should be able to:

cat /sys/kernel/debug/vgaswitcheroo/switch

Instead, /sys/kernel/debug doesn't contain any vgaswitcheroo directory (the mount is working because I can see other directories inside).

What am I missing? I can provide any kind of log if that could help.

Thanks a lot!

Look this http://en.gentoo-wiki.com/wiki/Vga_switcheroo
 
Old 11-14-2012, 06:55 AM   #3
sanjioh
Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 48

Original Poster
Rep: Reputation: Disabled
hi, thanks for your answer.
unfortunately I've already read that guide (among others) again and again, but with no success.
I'm following every step (see list in my previous post), but no /sys/kernel/debug/vgaswitcheroo directory appears.

may the huge kernel be the reason?

thanks again!
 
Old 11-14-2012, 08:07 AM   #4
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 248

Rep: Reputation: Disabled
Why are you modprobing radeon module?
If i understand you corectly you wont to disable ati am i right?
Create this file in /etc/modprobe.d/radeon.conf or in lilo nomodeset
or in /etc/modprobe.d/radeon.conf add these lines options radeon modeset=0
 
Old 11-14-2012, 09:25 AM   #5
sanjioh
Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 48

Original Poster
Rep: Reputation: Disabled
Apparently, vga_switcheroo interface appears upon loading of the radeon module, and only if both boards (intel and amd) have modesetting enabled.
The blacklisting prevents the radeon module to be loaded at boot, causing a blank screen.
So, to my understanding, the procedure is:

- boot with radeon blacklisted
- modprobe radeon -> vga_switcheroo interface enables
- turn off ati board witch echo OFF > /sys/kernel/debug/vga_switcheroo/switch

I'm stuck at point 2.


EDIT: source: https://wiki.archlinux.org/index.php/Hybrid_graphics

Last edited by sanjioh; 11-14-2012 at 09:26 AM.
 
Old 11-14-2012, 09:25 AM   #6
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,344

Rep: Reputation: 184Reputation: 184
What does lsmod show. Do not set use nomodeset/modeset=0 and do not blacklist radeon. For vgaswitcheroo to work need the radeon drive to be there during boot up.
 
Old 11-14-2012, 09:28 AM   #7
sanjioh
Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 48

Original Poster
Rep: Reputation: Disabled
hi colorpurple21859,
thanks for your reply.
I'll post the result of lsmod as soon as I go home from work.
Are you sure that radeon module shouldn't be blacklisted?
 
Old 11-14-2012, 09:32 AM   #8
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,344

Rep: Reputation: 184Reputation: 184
Yes I have a HP laptop with hd6770m ati graphics and I use the radeon driver.
 
Old 11-14-2012, 09:34 AM   #9
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida
Distribution: slackware64-current, puppy, ubuntu
Posts: 1,344

Rep: Reputation: 184Reputation: 184
I put the
Code:
echo OFF > /sys/kernel/debug/vga_switcheroo/switch
in the /etc/rc.d/rc.local to turn off the discrete card during bootup.
 
Old 11-14-2012, 09:35 AM   #10
sanjioh
Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 48

Original Poster
Rep: Reputation: Disabled
Yes, that was my idea too.
I'll try and let you know
 
Old 11-15-2012, 10:17 AM   #11
sanjioh
Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 48

Original Poster
Rep: Reputation: Disabled
Mhh, maybe the solution is simpler than I thought:
http://kernelnewbies.org/Linux_3.4#h...7c6f87702c3d9a

I'll jump directly to Kernel 3.6.6 (using Pat's config for 3.6-rc4 as a base) and see how it goes.

 
Old 11-15-2012, 04:44 PM   #12
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,159

Rep: Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013
Not sure it can help but I just posted an how-to. Just to be sure I would type as root:
Code:
grep switcheroo /var/log/messages
and see what I come up with.

Last edited by Didier Spaier; 11-18-2012 at 02:18 AM.
 
Old 11-17-2012, 07:00 PM   #13
sanjioh
Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 48

Original Poster
Rep: Reputation: Disabled
hi, fortunately my guess was right, and I was dumb enough not to read about which kernel version supported my board. kernel 3.6.6 works fine and I have /sys/kernel/debug/vgaswitcheroo/switch interface, so I can turn the discrete chip off.

does anybody know if some special action is required upon suspend/resume/reboot/shutdown? i'd like to avoid blank screens or worst

thanks!
 
Old 07-30-2013, 09:41 PM   #14
GmeSalazar
LQ Newbie
 
Registered: Jul 2013
Posts: 1

Rep: Reputation: Disabled
I came across the same issue today. For documentation purposes, I think it's worth posting a possible solution. Check [1] out (edit).

---------- Post added 07-30-13 at 09:42 PM ----------

[1] http://blog.desdelinux.net/vgaswitch...das-en-debian/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Network interface missing kwill Linux - Networking 12 06-05-2012 08:09 AM
[HP Pavilion] ATI Radeon HD 5650 and vga_switcheroo Insomnium Linux - Laptop and Netbook 2 06-21-2011 10:39 AM
missing interface icons in firefox dodgefan Debian 4 05-29-2010 01:32 PM
WLAN interface missing khaan Linux - Wireless Networking 2 09-19-2007 07:27 AM
network interface missing nu-B Linux - Networking 2 05-20-2002 06:54 PM


All times are GMT -5. The time now is 03:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration