LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Missing KDE icons after upgrade from 4.2.4 to 4.3.4 (http://www.linuxquestions.org/questions/slackware-14/missing-kde-icons-after-upgrade-from-4-2-4-to-4-3-4-a-784789/)

ebros 01-26-2010 04:50 AM

Missing KDE icons after upgrade from 4.2.4 to 4.3.4
 
I am using slackware-current 32bit version.
After upgrading from kde 4.2.4 to 4.3.4 (using slackpkg), all my K-menu icons were missing.
There are also no icons in task managers for all kde-based applications like konsole,dolphin etc..
But for non-kde application like firefox, wicd and xmms, the icons show up in task manager.
I have tried reinstalling kdebase, kdebase-runtime and kde-userspace with no luck.
I have been searching for a week on how to fix this issue. I really hope somebody here could help me. Thanks.

~sHyLoCk~ 01-26-2010 05:13 AM

Move/rename/delete ~/.kde

gegechris99 01-26-2010 05:50 AM

Hello,

Did you also run

Code:

slackpkg install-new
to install new packages?

Here's an extract of the -current changelog that might be of interest to you:

Quote:

+--------------------------+
Thu Oct 22 22:09:40 UTC 2009
New KDE and other updates. Thanks to Vincent Batts, Robby Workman, Piter Punk,
and Eric Hameleers for the help!
......
kde/oxygen-icons-4.3.2-i486-1.txz: Added.
.....

zakonnik 01-26-2010 08:50 AM

Install "oxygen-icons" package, in 4.2.4 icons were in kdebase, now they are in kdesupport.

ebros 01-27-2010 02:31 AM

Thanks a lot gegechris99 and zakonnik!
You were both right. I run slackpkg install-new to install the oxygen-icons-4.3.4-i486-1 and it has fixed the problem.
Thanks so much guys for your help.

ngc457 01-29-2010 03:02 PM

Quote:

Originally Posted by ebros (Post 3840725)
I am using slackware-current 32bit version.
After upgrading from kde 4.2.4 to 4.3.4 (using slackpkg), all my K-menu icons were missing.
There are also no icons in task managers for all kde-based applications like konsole,dolphin etc..
But for non-kde application like firefox, wicd and xmms, the icons show up in task manager.
I have tried reinstalling kdebase, kdebase-runtime and kde-userspace with no luck.
I have been searching for a week on how to fix this issue. I really hope somebody here could help me. Thanks.

Just installed Slackware 13 myself and have been having freezing in KDE 4.2.4, and am wondering if upgrading to 4.3.X would help. Worth a shot. Anyway, could you explain how you upgraded KDE?

Thanks


All times are GMT -5. The time now is 06:07 PM.