LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-20-2003, 09:13 PM   #1
k4ution
Member
 
Registered: Nov 2003
Posts: 46

Rep: Reputation: 15
Missing Device File


Just installed 2.6.0 kernel and come to find out that the ethernet device file was not included(eth0). I used my config file from 2.4.22 kernel (upgraded it a bit but didn't mess with the networking section that much). Does anyone know what I need to do?
 
Old 12-21-2003, 04:17 AM   #2
miaviator278
Member
 
Registered: Dec 2003
Location: Al-Diwania, Iraq (deployed)
Distribution: Slackware ONLY
Posts: 237

Rep: Reputation: 30
ok, specifics..
you upgraded from 2.4.22 to 2.6.0
your using ? ethernet card
your runninx ? distro.
you have tried ?

do you mean /dev/eth0 is missing,
or that it won't initialize properly?
have you tried looking for info from these commands
lspci
pnpdump
lsmod
dmesg

each with a manual page...
 
Old 12-21-2003, 11:26 AM   #3
k4ution
Member
 
Registered: Nov 2003
Posts: 46

Original Poster
Rep: Reputation: 15
2.4.22 to 2.6.0
SOHOware Fast 10/100 PCI card
Slackware 9.1
Haven't tried anything

There is no /dev/eth*
 
Old 12-21-2003, 04:08 PM   #4
miaviator278
Member
 
Registered: Dec 2003
Location: Al-Diwania, Iraq (deployed)
Distribution: Slackware ONLY
Posts: 237

Rep: Reputation: 30
check the output of
lspci
lsmod
dmesg
pnpdump
and post any information relating to your card that show up.

and what happens if you do
ifconfig eth0 up
? i'd assume nothing, but never know..
 
Old 12-21-2003, 07:01 PM   #5
k4ution
Member
 
Registered: Nov 2003
Posts: 46

Original Poster
Rep: Reputation: 15
lspci:
00:0d.0 Ethernet Controller: Macronix, Inc [MX1C]MX987x5 (rev 25)
lsmod:
IPv6 over IPv4 tunneling driver
dmesg:
eth16: /lib/modules/2.6.0/kernel/drivers/net/ethertap.ko
pnpdump:
No boards found
 
Old 12-22-2003, 07:50 PM   #6
miaviator278
Member
 
Registered: Dec 2003
Location: Al-Diwania, Iraq (deployed)
Distribution: Slackware ONLY
Posts: 237

Rep: Reputation: 30
what about

ifconfig
ifconfig eth0 up
?

you need to find out what module your network card uses
try modprobe ethertap

also try netconfig
slackwares network setup utill..

and keep posting
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Assign one USB-storage device to one device file Misel Linux - Hardware 1 08-28-2004 03:52 AM
Missing /var device sasklinuxuser Linux - General 2 05-14-2004 10:42 AM
Linux, Netowrk Device missing sk8ercool2001 Linux - Networking 1 04-06-2004 09:54 PM
missing device modules n_logo Linux - General 2 12-05-2003 03:57 PM
Missing device? Tdh-Anon Linux - Hardware 1 11-25-2002 01:41 PM


All times are GMT -5. The time now is 08:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration