LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Missing /dev/sda etc when booting custom kernels (http://www.linuxquestions.org/questions/slackware-14/missing-dev-sda-etc-when-booting-custom-kernels-793583/)

drmozes 03-06-2010 04:16 AM

Missing /dev/sda etc when booting custom kernels
 
Hi

A few people including me have had udev-151 only sparsely populate /dev -- crucial block devices such as /dev/sda were missing.

If you hit this problem, read /usr/doc/udev-151/README

In particular ensure your kernel meets the requirements:
- Version 2.6.27 of the Linux kernel with sysfs, procfs, signalfd, inotify,
unix domain sockets, networking and hotplug enabled:
CONFIG_HOTPLUG=y
CONFIG_UEVENT_HELPER_PATH=""
CONFIG_NET=y
CONFIG_UNIX=y
CONFIG_SYSFS=y
CONFIG_SYSFS_DEPRECATED*=n
CONFIG_PROC_FS=y
CONFIG_TMPFS=y
CONFIG_INOTIFY_USER=y
CONFIG_SIGNALFD=y
CONFIG_TMPFS_POSIX_ACL=y (user ACLs for device nodes)
CONFIG_BLK_DEV_BSG=y (SCSI devices)

- Udev will not work with the CONFIG_SYSFS_DEPRECATED* option.

- Unix domain sockets (CONFIG_UNIX) as a loadable kernel module may work,
but it is not supported.


You should find that once your kernel meets these requirements, udev-151 works.

ponce 03-06-2010 06:04 AM

i discovered it helps a lot also if you switch from the deprecated (since 2.6.33) ide layer for sata to the new one (in device configuration): a common situation when upgrading configs from older kernel versions and booting without an initrd.

edit: sorry, read better your post, thought you were speaking about current.
btw, thanx for the hint.

zhoun 03-06-2010 10:09 PM

thanks drmozes.
Solved my probleam!

alperenc 06-08-2010 03:47 PM

thank you!! i updated my gentoo but udev got broken. solved my problem.

metageek 06-13-2010 02:23 PM

thanks, this solved my problem, I was running out of ideas!

dracolich 07-04-2010 05:56 PM

Just want to say that this solved my problem, too, and I can now boot my custom 2.6.34. Thanks!


All times are GMT -5. The time now is 01:56 AM.