LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-02-2013, 12:56 PM   #1
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 389

Rep: Reputation: 23
minidlna and Slackware 14


Recently stumbled upon DLNA and wanted to set it up as easily as possible and it looks like minidlna would serve this purpose nicely. I have minidlna running as a user rather than root and can see localhost:8200 with some media in the database, however I can't see the server at all from another device. I have 8200/tcp and 1900/udp opened, but still no go. Any suggestions?
 
Old 02-02-2013, 08:46 PM   #2
D1ver
Member
 
Registered: Jan 2010
Distribution: Slackware 13.37
Posts: 527
Blog Entries: 3

Rep: Reputation: 126Reputation: 126
Can you see anything if you run minidlna as root?

I've got minidlna setup on a stock 14.0 system and it's running fine.
This is my minidlna.conf which was about as simple as I could make it.


Code:
# port for HTTP (descriptions, SOAP, media transfer) traffic
port=8200

# network interfaces to serve, comma delimited
#network_interface=eth0

# set this to the directory you want scanned.
# * if have multiple directories, you can have multiple media_dir= lines
# * if you want to restrict a media_dir to a specific content type, you
#   can prepend the type, followed by a comma, to the directory:
#   + "A" for audio  (eg. media_dir=A,/home/jmaggard/Music)
#   + "V" for video  (eg. media_dir=V,/home/jmaggard/Videos)
#   + "P" for images (eg. media_dir=P,/home/jmaggard/Pictures)
media_dir=A,/srv/media/music
media_dir=V,/srv/media/videos
media_dir=P,/srv/media/photos

# set this if you want to customize the name that shows up on your clients
friendly_name=Darkstar

# set this if you would like to specify the directory where you want MiniDLNA to store its database and album art cache
db_dir=/var/cache/minidlna

# set this if you would like to specify the directory where you want MiniDLNA to store its log file
log_dir=/var/log

# set this to change the verbosity of the information that is logged
# each section can use a different level: off, fatal, error, warn, info, or debug
#log_level=general,artwork,database,inotify,scanner,metadata,http,ssdp,tivo=warn

# this should be a list of file names to check for when searching for album art
# note: names should be delimited with a forward slash ("/")
album_art_names=Cover.jpg/cover.jpg/AlbumArtSmall.jpg/albumartsmall.jpg/AlbumArt.jpg/albumart.jpg/Album.jpg/album.jpg/Folder.jpg/folder.jpg/Thumb.jpg/thumb.jpg

# set this to no to disable inotify monitoring to automatically discover new files
# note: the default is yes
inotify=yes

# set this to yes to enable support for streaming .jpg and .mp3 files to a TiVo supporting HMO
enable_tivo=no

# set this to strictly adhere to DLNA standards.
# * This will allow server-side downscaling of very large JPEG images,
#   which may hurt JPEG serving performance on (at least) Sony DLNA products.
strict_dlna=no

# default presentation url is http address on port 80
#presentation_url=http://www.mylan/index.php

# notify interval in seconds. default is 895 seconds.
notify_interval=900

# serial and model number the daemon will report to clients
# in its XML description
serial=1234
model_number=1

# specify the path to the MiniSSDPd socket
#minissdpdsocket=/var/run/minissdpd.sock

# use different container as root of the tree
# possible values:
#   + "." - use standard container (this is the default)
#   + "B" - "Browse Directory"
#   + "M" - "Music"
#   + "V" - "Video"
#   + "P" - "Pictures"
# if you specify "B" and client device is audio-only then "Music/Folders" will be used as root
#root_container=.
 
Old 02-03-2013, 01:57 AM   #3
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 389

Original Poster
Rep: Reputation: 23
made an attempt as root... still nothing visible on the clients!chattr -i lilo.conf
 
Old 02-03-2013, 06:20 AM   #4
Celyr
Member
 
Registered: Mar 2012
Location: Italy
Distribution: Slackware+Debian
Posts: 314

Rep: Reputation: 77
Minidlna is working here as well, can you post your minidlna.conf and your logfile ? and maybe netstat -nalp | grep minidlna
You may also try a rescan
 
Old 02-03-2013, 12:13 PM   #5
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 389

Original Poster
Rep: Reputation: 23
Everything looks fine... but in case I missed anything, here's the requested info

minidnla.log

Code:
# port for HTTP (descriptions, SOAP, media transfer) traffic
port=8200

# network interfaces to serve, comma delimited
#network_interface=eth0
network_interface=bond0

# set this to the directory you want scanned.
# * if have multiple directories, you can have multiple media_dir= lines
# * if you want to restrict a media_dir to a specific content type, you
#   can prepend the type, followed by a comma, to the directory:
#   + "A" for audio  (eg. media_dir=A,/home/jmaggard/Music)
#   + "V" for video  (eg. media_dir=V,/home/jmaggard/Videos)
#   + "P" for images (eg. media_dir=P,/home/jmaggard/Pictures)
media_dir=/opt
media_dir=/home/jig/iTunes Music

# set this if you want to customize the name that shows up on your clients
#friendly_name=My DLNA Server
friendly_name=enterprise-e

# set this if you would like to specify the directory where you want MiniDLNA to store its database and album art cache
#db_dir=/var/cache/minidlna
db_dir=/home/jig/.minidlna/cache

# set this if you would like to specify the directory where you want MiniDLNA to store its log file
#log_dir=/var/log
log_dir=/home/jig/.minidlna

# set this to change the verbosity of the information that is logged
# each section can use a different level: off, fatal, error, warn, info, or debug
#log_level=general,artwork,database,inotify,scanner,metadata,http,ssdp,tivo=warn

# this should be a list of file names to check for when searching for album art
# note: names should be delimited with a forward slash ("/")
album_art_names=Cover.jpg/cover.jpg/AlbumArtSmall.jpg/albumartsmall.jpg/AlbumArt.jpg/albumart.jpg/Album.jpg/album.jpg/Folder.jpg/folder.jpg/Thumb.jpg/thumb.jpg

# set this to no to disable inotify monitoring to automatically discover new files
# note: the default is yes
inotify=yes

# set this to yes to enable support for streaming .jpg and .mp3 files to a TiVo supporting HMO
enable_tivo=no

# set this to strictly adhere to DLNA standards.
# * This will allow server-side downscaling of very large JPEG images,
#   which may hurt JPEG serving performance on (at least) Sony DLNA products.
strict_dlna=no

# default presentation url is http address on port 80
#presentation_url=http://www.mylan/index.php

# notify interval in seconds. default is 895 seconds.
notify_interval=900

# serial and model number the daemon will report to clients
# in its XML description
serial=12345678
model_number=1

# specify the path to the MiniSSDPd socket
#minissdpdsocket=/var/run/minissdpd.sock

# use different container as root of the tree
# possible values:
#   + "." - use standard container (this is the default)
#   + "B" - "Browse Directory"
#   + "M" - "Music"
#   + "V" - "Video"
#   + "P" - "Pictures"
# if you specify "B" and client device is audio-only then "Music/Folders" will be used as root
#root_container=.
output from netstat -nalp | grep minidlna
Code:
tcp        0      0 0.0.0.0:8200            0.0.0.0:*               LISTEN      24467/minidlna
udp        0      0 0.0.0.0:1900            0.0.0.0:*                           24467/minidlna
udp        0      0 192.168.1.44:48113      0.0.0.0:*                           24467/minidlna
minidnla.log
Code:
[2013/02/03 12:09:09] minidlna.c:884: warn: Starting MiniDLNA version 1.0.25 [SQLite 3.7.14.1].
[2013/02/03 12:09:09] minidlna.c:990: warn: HTTP listening on port 8200

Last edited by dimm0k; 02-03-2013 at 10:07 PM.
 
Old 02-03-2013, 05:01 PM   #6
Celyr
Member
 
Registered: Mar 2012
Location: Italy
Distribution: Slackware+Debian
Posts: 314

Rep: Reputation: 77
How do you start minidlna service ?
I think it's not picking up the right conf file.
Code:
/usr/sbin/minidlna -f /home/user/.minidlna/minidlna.conf -P /home/user/.minidlna/minidlna.pid
That's how I do start it.
I suggest you to try a rescan also, add the -R option.

Last edited by Celyr; 02-03-2013 at 05:03 PM.
 
Old 02-03-2013, 10:09 PM   #7
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 389

Original Poster
Rep: Reputation: 23
I am starting it with the following:

Code:
/usr/sbin/minidlna -f "/home/jig/.minidlna/minidlna.conf" -P "/home/jig/.minidlna/minidlna.pid" > $log 2>&1 &

Unfortunately I have also tried rescan with the -R option.
 
Old 02-03-2013, 10:15 PM   #8
escaflown
Member
 
Registered: May 2009
Location: Canada
Distribution: Slackware
Posts: 237

Rep: Reputation: 30
firewall? tcp wrapper?
 
Old 02-04-2013, 01:16 AM   #9
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 389

Original Poster
Rep: Reputation: 23
Quote:
Originally Posted by escaflown View Post
firewall? tcp wrapper?
I have the following for my firewall to open up the necessary ports for minidlna
Code:
iptables -A INPUT -p UDP -s 192.168.1.0/24 --dport 1900 -j ACCEPT
iptables -A INPUT -p TCP -s 192.168.1.0/24 --dport 8200 -j ACCEPT
Not sure what's needed for the tcp wrapper... I did however try having the following in my hosts.allow with no luck
Code:
minidlna: 192.168.1.

Last edited by dimm0k; 02-04-2013 at 01:18 AM.
 
Old 02-04-2013, 06:18 AM   #10
Celyr
Member
 
Registered: Mar 2012
Location: Italy
Distribution: Slackware+Debian
Posts: 314

Rep: Reputation: 77
What kind of files do you have in your media dirs ?
Try to delete the cache directory.
 
Old 02-04-2013, 11:23 AM   #11
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 389

Original Poster
Rep: Reputation: 23
Deleted the cache directory this morning, followed by a rescan, but still no go. The files in my media dir is mostly all mp3s with some iTunes crap format mixed in and some videos.
 
Old 02-05-2013, 03:35 AM   #12
Celyr
Member
 
Registered: Mar 2012
Location: Italy
Distribution: Slackware+Debian
Posts: 314

Rep: Reputation: 77
Check the permissions on your media dir. What are you using to browse your dlna server ?
Maybe you can try mediatomb as replacement (it's easy as minidlna to configure) maybe just to see if your dlna browser is working.
You can also try to have a look at your files.db file (it's in the cache directory) how big it is ? It's a bit messy (of course) but you can less it.
I've noticed that you have added two firewall lines, are you sure that there is no DROP rule above ?

Last edited by Celyr; 02-05-2013 at 03:37 AM.
 
Old 02-06-2013, 12:27 AM   #13
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 389

Original Poster
Rep: Reputation: 23
The permissions for the media dir are 700... if it were a permissions issue, wouldn't I at least be able to see the server? I'm actually using a software called Kalemsoft Media Player on my PlayBook tablet to browse for the DLNA server. I know it's capable as it's able to see my phone when I turn on media sharing there... I was afraid you'd say to give another DLNA server a try, but it looks more and more worthy now. My files.db is exactly 38227968, which looks about right in terms of what I had it scan. As for the firewall rules, I just double checked. All the DROP rules occur later on, in fact those two lines are in the same section where I open up ports for ssh and NFS.
 
Old 02-06-2013, 04:51 PM   #14
Celyr
Member
 
Registered: Mar 2012
Location: Italy
Distribution: Slackware+Debian
Posts: 314

Rep: Reputation: 77
Oh, I tought that you where seeing the server.
Try
Code:
iptables -L
can you try to
Code:
telnet server_ip 8200
from another pc ?
 
Old 02-12-2013, 09:30 AM   #15
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 389

Original Poster
Rep: Reputation: 23
Sorry for the delay in response... I actually do see the server fine from a Windows 7 PC. It looks like something might be up with my tablet's media player not seeing things. Unless you guys have any experience with the BlackBerry PlayBook, I'll mark this one as solved.

EDIT: looks like the reason why the PlayBook wasn't able to see the minidlna server was because the crappy Verizon FIOS ActionTec router was blocking it. Disabling that option rectified this issue!

Last edited by dimm0k; 02-13-2013 at 11:04 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do you install minidlna for debian squeeze scribesyd Linux - Newbie 6 07-17-2013 08:21 AM
minidlna on slackware and em7080 the_zone Slackware 1 11-07-2012 10:47 PM
[SOLVED] Mandriva firewall and minidlna Johng Linux - Security 9 11-23-2011 04:20 PM
MiniDLNA plus VLC to XBox 360 or DirecTV On-The-Fly akhill44 Linux - Software 1 04-22-2011 08:04 PM


All times are GMT -5. The time now is 03:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration