LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-16-2006, 03:35 PM   #1
jsmith6
Member
 
Registered: Feb 2006
Distribution: Slackware 13.1 / 13.37
Posts: 91

Rep: Reputation: 16
Midnight Commander requires twice the key-strokes


I am running Slackware 10.2 (with no upgraded packages from Slackware-curent), with the default Kernel 2.4.31, and MC 2.6.1.

MC acts somewhat strange.

Most of the times, when I am in dual-view and press keys (like the Function keys, F1, F2, etc, or the ESC key), I need to press them twice. Pressing them once will do nothing. The built-in viewer and editor (mcview, mcedit) always behave like this (require twice the key-stokes).

Also, sometimes, while pressing Functions keys, I will see some text at the bottom command line that looks like this: [[B and ~]]12[[123.

What is causing this and how can I stop it?
 
Old 05-16-2006, 07:33 PM   #2
elgatofilo
LQ Newbie
 
Registered: Dec 2004
Distribution: Slackware 10.2
Posts: 21

Rep: Reputation: 15
Is PAM installed?

Do you have dropline gnome or PAM installed by any chance? Their is a known problem involving dropline's gnome and an issue similar to the one you are describing.
 
Old 05-16-2006, 08:03 PM   #3
zborgerd
Member
 
Registered: Mar 2004
Distribution: Slackware / Dropline GNOME
Posts: 378

Rep: Reputation: 30
Quote:
Originally Posted by elgatofilo
Do you have dropline gnome or PAM installed by any chance? Their is a known problem involving dropline's gnome and an issue similar to the one you are describing.
There is? I'm not aware of such issues. If so, it would have ziltch to do with PAM, though some folks would like you to believe that it would (and propagate that myth as well). Please provide details if there are reports on a PAM-related issue such as what you are describing.

There was a user-session dbus issue that caused some problems when run as a root user, but that's been corrected by disallowing the /etc/profile.d/dbus.sh to run under root logins. There is also a similar issue with usb keyboards that manifests itself even on Slackware without any third-party addons (particularly when legacy USB support is enabled). Most people get these two problems mixed up. I also had the same problems with terminal lag in the default Slackware 2.4.31 kernel, upon installation of Slackware 10.2. It went away with an upgrade to a custom 2.6.x kernel.

Last edited by zborgerd; 05-16-2006 at 10:00 PM.
 
Old 05-16-2006, 09:07 PM   #4
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 65
Well, all my standard (non-dropline) 10.2 installs have MC working fine (5 systems), plus my 'current' install. The difference between my systems and yours is Dropline. So maybe there IS a dropline bug?(Heaven forbid)
 
Old 05-16-2006, 09:45 PM   #5
zborgerd
Member
 
Registered: Mar 2004
Distribution: Slackware / Dropline GNOME
Posts: 378

Rep: Reputation: 30
Quote:
Originally Posted by cwwilson721
Well, all my standard (non-dropline) 10.2 installs have MC working fine (5 systems), plus my 'current' install. The difference between my systems and yours is Dropline. So maybe there IS a dropline bug?(Heaven forbid)
I never said that it wasn't. However, I don't believe it to have anything to do with PAM though. There is no reason for your typical anti-dropline sarcasm (we've seen it from you a multitude of times now in these forums, and it does nothing to solve technical problems).

Unfortunately, I am unable to replicate it on my systems... With, or without Dropline. Only think I could potentially think of would be dbus-launch running as root.
 
Old 05-16-2006, 09:55 PM   #6
Stik
Member
 
Registered: Mar 2004
Location: Everett, WA
Distribution: Slackware / Dropline Gnome
Posts: 40

Rep: Reputation: 15
Quote:
Originally Posted by cwwilson721
Well, all my standard (non-dropline) 10.2 installs have MC working fine (5 systems), plus my 'current' install. The difference between my systems and yours is Dropline. So maybe there IS a dropline bug?(Heaven forbid)
Omfg.. who let Pat's lemmings out again!!!!!!!!!!!!!!!

Sorry cannot replicate here.. on current or 10.2... Typical slacker, mess
up their system and blame on dlg. Will this crap ever end? Sounds like the
slack user base is getting very limited in it's abilities to maintain their
own systems these days.
 
Old 05-17-2006, 04:39 AM   #7
jsmith6
Member
 
Registered: Feb 2006
Distribution: Slackware 13.1 / 13.37
Posts: 91

Original Poster
Rep: Reputation: 16
Thank you for replying.

I use a PS/2 mouse and keyboard.

I didn't not install Dropline Gnome, nor another custom version. I have only installed software from the CDs and a custom Slackware build of Cinelerra.

Quote:
Originally Posted by zborgerd
I also had the same problems with terminal lag in the default Slackware 2.4.31 kernel, upon installation of Slackware 10.2. It went away with an upgrade to a custom 2.6.x kernel.
There are two reasons I haven't upgraded to kernel 2.6.x. The first is that when I tried the pre-compiled one test26 from the kernels directory, I didn't had USB support (I think because of the incompatible modules). The second is that when I tried to compile the kernel myself, I stumbled uppon a list of hardware options that I didn't knew what they meant.

I will try again the precompiled 2.6.x from the CD and see if the same problem continues. The last time, I didn't kept it long enough due to the USB problem.
 
Old 05-17-2006, 05:15 AM   #8
wchild
Member
 
Registered: Mar 2006
Distribution: Slackware
Posts: 63

Rep: Reputation: 15
Midnight Commander has a "learn keys" feature somewhere inside its menus. Try it then see if the problem persists.
 
Old 05-17-2006, 09:14 AM   #9
jsmith6
Member
 
Registered: Feb 2006
Distribution: Slackware 13.1 / 13.37
Posts: 91

Original Poster
Rep: Reputation: 16
Using kernel 2.6.x didn't change anything.

Quote:
Midnight Commander has a "learn keys" feature somewhere inside its menus. Try it then see if the problem persists.
I tried this and I still have the problem. I saved of cource the keys, and setuo (mc.ini).
 
Old 05-17-2006, 12:56 PM   #10
zborgerd
Member
 
Registered: Mar 2004
Distribution: Slackware / Dropline GNOME
Posts: 378

Rep: Reputation: 30
Hmm. Perhaps disabling legacy USB support in the BIOS, or passing

append="nousb"

To your lilo.conf (and rerun "lilo" afterwards) might help. I found that I didn't even have to be using a USB keyboard for this problem to manifest itself.

You can also just test it on bootup as well, from the lilo prompt:

"bare.i nousb"

Substitute "bare.i" for your actual kernel name, if it is different.
 
Old 05-17-2006, 07:36 PM   #11
dugan
Senior Member
 
Registered: Nov 2003
Location: Canada
Distribution: distro hopper
Posts: 4,544

Rep: Reputation: 1385Reputation: 1385Reputation: 1385Reputation: 1385Reputation: 1385Reputation: 1385Reputation: 1385Reputation: 1385Reputation: 1385Reputation: 1385
Quote:
elgatofilo wrote:
Their is a known problem involving dropline's gnome and an issue similar to the one you are describing.
Could you post a link to a page that documents this please?
 
Old 05-18-2006, 06:43 AM   #12
jsmith6
Member
 
Registered: Feb 2006
Distribution: Slackware 13.1 / 13.37
Posts: 91

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by zborgerd
Hmm. Perhaps disabling legacy USB support in the BIOS, or passing

append="nousb"

To your lilo.conf (and rerun "lilo" afterwards) might help. I found that I didn't even have to be using a USB keyboard for this problem to manifest itself.

You can also just test it on bootup as well, from the lilo prompt:

"bare.i nousb"

Substitute "bare.i" for your actual kernel name, if it is different.
I went to BIOS and saw that "USB keyboard support" was already disabled. After that I added append="nousb" in lilo.conf. Nothing changed :-/
 
Old 05-18-2006, 08:14 AM   #13
jimX86
Member
 
Registered: Mar 2006
Distribution: Slackware64 14.1
Posts: 231
Blog Entries: 1

Rep: Reputation: 34
Try installing Dropline Gnome. But seriously...

Is your problem only happening with mc? Part of the mc FAQ deals with function key problems and termcap info. I'm not sure that's your problem, but it might be worth a shot.

As a short term fix, you could use ESC + a number key instead of the Function keys.
 
Old 05-19-2006, 03:47 PM   #14
jsmith6
Member
 
Registered: Feb 2006
Distribution: Slackware 13.1 / 13.37
Posts: 91

Original Poster
Rep: Reputation: 16
The MC FAQ explains why I need to press ESC twice, so here goes with one. I should have addressed there in the first place.

However, I haven't yet found why pressing does things like [[B and ~]]12[[123. I have no idea what "termcap" is (I also saw "terminfo" inside the FAQ)), but I will check that one too.

Thank you, all, for your replies.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Midnight Commander matombo Fedora 3 11-30-2005 12:41 PM
midnight commander archlyric Linux - Software 2 02-28-2004 02:04 AM
midnight commander enigma1 Linux - Software 6 12-10-2003 02:47 PM
Midnight Commander XPediTioN Slackware 2 07-12-2003 11:45 PM
Where's mc (Midnight Commander) Shadow Of Death Linux - Software 7 01-09-2003 07:09 PM


All times are GMT -5. The time now is 04:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration