LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   microphone doesn't record on Slackware 14.0 (http://www.linuxquestions.org/questions/slackware-14/microphone-doesnt-record-on-slackware-14-0-a-4175437726/)

Nohchi 11-18-2012 07:13 PM

microphone doesn't record on Slackware 14.0
 
Hi,
I have a problem with the microphone, i can't record anything or in skype can't hear me. Please help me.
slackware 14.0 (3.2.29) kde4.8.5
lspci:
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
Alsamixer Card: HDA Intel
Alsamixer Chip: SigmaTel CXD9872AKD

http://img820.imageshack.us/img820/8906/snapshot1lr.png

any ideas?

gmartins 11-18-2012 09:37 PM

Try recording with other application, audacity for example, just to check if it is a mic or skype issue.
If the issue is with skype go to audio options and uncheck "accept Skype automatically adjust your mixer levels". Adjust your mic mixer level manually. This is the way I just solved similar problem with my system.
I'ḿ using Slackware-64 multilib and upgraded Skype to the new 4.1.0.20 version.
I have an on board soundcard HDA ATI (ALC 892).
Hope this can help you

D1ver 11-18-2012 10:08 PM

If you don't want to build Audacity you can record/debug with arecord.

lkraemer 11-18-2012 11:08 PM

Nohchi,
Check APPLICATIONS -> MULTIMEDIA -> MIXER Click on SELECT CONTROLS and ENABLE the following: MASTER, PCM, CAPTURE, ANALOG MIC BOOST.

Make sure all the sliders are at Maximum for MASTER, PCM, & CAPTURE. Make sure the RED Record Button is "RED" = ENABLED.
Set the Analog MIC Boost to 30dB.

Open a Terminal, and use the following to test your recording and playback:
Code:

man arecord
arecord -vv -d 10 /tmp/mytest.wav

Playback your sounds with:
Code:

aplay -vv /tmp/mytest.wav
It should work fine.


Larry

slackass 11-19-2012 12:01 AM

I'm running Slack64-14.0 multilib and can confirm that all of my mics are working, headset, desk mic, & webcam mic. So I don't think it's a Slack problem. I did however have to crank up the volume higher than normal to make skype work. I'm using the SlackBuilds skype.

kite 11-19-2012 03:40 AM

I have the same mic-not-working-at-all problem with skype. The Mic is working fine with audacity in mono channel only though. arecord is also working. The problem is related to alsa and intel HDA.

lspci shows:

00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)

lsmod |grep snd:

snd_seq_dummy 1455 0
snd_seq_oss 28952 0
snd_seq_midi_event 5620 1 snd_seq_oss
snd_seq 50913 5 snd_seq_midi_event,snd_seq_oss,snd_seq_dummy
snd_seq_device 5228 3 snd_seq,snd_seq_oss,snd_seq_dummy
snd_pcm_oss 39087 0
snd_mixer_oss 15564 2 snd_pcm_oss
snd_hda_codec_hdmi 24057 1
snd_hda_codec_cirrus 16751 1
snd_hda_intel 23331 2
snd_hda_codec 82341 3 snd_hda_intel,snd_hda_codec_cirrus,snd_hda_codec_hdmi
snd_hwdep 6420 1 snd_hda_codec
snd_pcm 72704 4 snd_hda_codec,snd_hda_intel,snd_hda_codec_hdmi,snd_pcm_oss
snd_page_alloc 7081 2 snd_pcm,snd_hda_intel
snd_timer 18990 2 snd_pcm,snd_seq
snd 58276 14 snd_timer,snd_pcm,snd_hwdep,snd_hda_codec,snd_hda_intel,snd_hda_codec_cirrus,snd_hda_codec_hdmi,snd_ mixer_oss,snd_pcm_oss,snd_seq_device,snd_seq,snd_seq_oss
soundcore 5986 2 snd

allend 11-19-2012 08:16 AM

@Nohchi - Googling your audio chip and codec suggests that you have a Sony Vaio. Try 'echo "options snd-hda-intel index=0 model=vaio" > /etc/modprobe.d/snd-hda-intel.conf' and rebooting your machine.

@kite - What is the make and model of your computer? What is the output of 'cat /proc/asound/card*/codec* | grep Codec' ?

Perhaps this will provide some background http://docs.slackware.com/howtos:har..._snd-hda-intel

Nohchi 11-19-2012 01:52 PM

allend Thank You !!! U saved me, it worked !
You're right, is a laptop Sony Vaio.

Thanks to all who responded

upd:
/usr/sbin/alsactl: set_control:1328: failed to obtain info for control #1 (No such file or directory)
/usr/sbin/alsactl: set_control:1328: failed to obtain info for control #2 (No such file or directory)
/usr/sbin/alsactl: set_control:1328: failed to obtain info for control #10 (No such file or directory)
/usr/sbin/alsactl: set_control:1328: failed to obtain info for control #11 (No such file or directory)
/usr/sbin/alsactl: set_control:1328: failed to obtain info for control #12 (No such file or directory)
/usr/sbin/alsactl: set_control:1328: failed to obtain info for control #13 (No such file or directory)
/usr/sbin/alsactl: set_control:1328: failed to obtain info for control #14 (No such file or directory)

Now it get when the system boots to a black screen, but the sound and recording work.
I ignore these messages?, or can fix it?

allend 11-19-2012 06:46 PM

Quote:

I ignore these messages?, or can fix it?
'The Management' posted this. http://www.linuxquestions.org/questi...5/#post4289480

kite 11-19-2012 08:26 PM

Quote:

@kite - What is the make and model of your computer? What is the output of 'cat /proc/asound/card*/codec* | grep Codec' ?

Perhaps this will provide some background http://docs.slackware.com/howtos:har..._snd-hda-intel
It is a early 2011 model Macbook Pro 8,1
Here it is:

cat /proc/asound/card*/codec* | grep Codec
Codec: Cirrus Logic CS4206
Codec: Intel CougarPoint HDMI

I tried "echo "options snd-hda-intel model=auto" > /etc/modprobe.d/snd-hda-intel.conf", but this method mutes all the sound of my computer.

allend 11-19-2012 10:33 PM

@kite - Based on this https://help.ubuntu.com/community/MacBookPro8-1/Natty you could try 'echo "options snd-hda-intel model=mbp55" > /etc/modprobe.d/snd-hda-intel.conf' and rebooting.

kite 11-19-2012 10:50 PM

Quote:

Originally Posted by allend (Post 4832973)
@kite - Based on this https://help.ubuntu.com/community/MacBookPro8-1/Natty you could try 'echo "options snd-hda-intel model=mbp55" > /etc/modprobe.d/snd-hda-intel.conf' and rebooting.

It does not help. It seems to be a bug with alsa. Actually the mic is working for one channel, the other channel is not working properly, it sends static background noise instead. And Skype only uses this channel with static noise.

allend 11-20-2012 08:06 AM

@kite - I have been looking some more and this issue of Skype and the Macbook Pro is apparently not new. The most informative thread I have come across is this. http://lists.opensuse.org/opensuse-b.../msg01165.html (Please note the input from Takashi Iwai,; he is the expert).

kite 11-20-2012 10:08 AM

@allend - I submitted a bug report on kernel.org. They suggest to try kernel 3.7-rc6, which is supposed to fix the specific bug I have. Please reference: https://bugzilla.kernel.org/show_bug.cgi?id=50781

I will test the new kernel and report back.

kite 11-23-2012 11:25 AM

Macbook pro 8,1 internal mic problem solved
 
My specific bug was solved following 3 patches found here:
https://bugzilla.kernel.org/show_bug.cgi?id=50781


All times are GMT -5. The time now is 07:37 PM.