LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   microdia makes green screen (http://www.linuxquestions.org/questions/slackware-14/microdia-makes-green-screen-4175448480/)

waddles 02-03-2013 12:52 PM

microdia makes green screen
 
Have been trying to get a microdia web cam to function with mplayer.
All I get is a green screen (static?) with video1 and ioctl errors with video0.
Here is what I use:
mplayer tv:// -tv driver=v4l2:width=640:height=480:device=/dev/video1 -fps 15
I have also used -fps 30 with the same result.
INFO:
dmesg | egrep -i video
[ 4.749297] Linux video capture interface: v2.00
[ 5.204899] usb 4-1: V4L2 device registered as video0
[ 6.375530] bttv0: registered device video1
bash-4.1# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 0c45:60fc Microdia PC Camera with Mic (SN9C105)
The actual driver is sn9c102 which contains the info in ...105.
Note that video0 is registered to usb 4-1 which I suppose is bus-device but the camera is on 4-2. Also note bttv is on video1 so I should not be using video1 for the camera, yet aside from the green screen I see the numbers turning over behind the screen in the terminal.
Am I confused or else how do I correct my system, 13.37, to accept video0?

H_TeXMeX_H 02-13-2013 11:33 AM

It looks like you need the gspca drivers:
http://mxhaard.free.fr/spca5xx

Post the output of 'lsmod' as you may already have them installed.

waddles 02-14-2013 03:01 AM

microdia makes green screen
 
I tried that route. Get pretty much the same result. I will be experimenting with applying enable_mtrr_cleanup mtrr_space_reg_nr=1 in lilo as soon as I have time to research it as this I found may clear it up. Hope springs eternal.

waddles 02-17-2013 02:27 AM

microdia makes green screen
 
Appending enable_mtrr_cleanup to lilo and w/ nr=1 had no effect on cleaning up the green screen.


All times are GMT -5. The time now is 05:21 AM.