LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-08-2008, 02:35 PM   #1
n0p.cracker
Member
 
Registered: May 2008
Location: Croatia
Distribution: slackware 12.1
Posts: 39

Rep: Reputation: 15
mice doesn't work on sw 12.1


first off all, I'm from croatia, and my english is not good ..
well, i have updated sw12.0 to sw12.1.. after that update i had to install nvidia drivers again, and then i have started X... when i started x, my mice didn't work... this is my xorg.conf

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Thu Feb 14 18:20:37 PST 2008

# File generated by xf86config.
#
# Copyright (c) 1999 by The XFree86 Project, Inc.
#
# Permission is hereby granted, free of charge, to any person obtaining a
# copy of this software and associated documentation files (the "Software"),
# to deal in the Software without restriction, including without limitation
# the rights to use, copy, modify, merge, publish, distribute, sublicense,
# and/or sell copies of the Software, and to permit persons to whom the
# Software is furnished to do so, subject to the following conditions:
# 
# The above copyright notice and this permission notice shall be included in
# all copies or substantial portions of the Software.
# 
# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.  IN NO EVENT SHALL
# THE XFREE86 PROJECT BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
# WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF
# OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
# SOFTWARE.
# 
# Except as contained in this notice, the name of the XFree86 Project shall
# not be used in advertising or otherwise to promote the sale, use or other
# dealings in this Software without prior written authorization from the
# XFree86 Project.
#
# **********************************************************************
# Refer to the XF86Config(4/5) man page for details about the format of 
# this file.
# **********************************************************************
# NOTE:  This is a NEW IMPROVED version of XF86Config-fbdev that uses the vesa
# driver instead of the fbdev driver.  Thanks to Kenneth Fanyo who pointed
# this out to me. :)
# This XF86Config file is designed for use with the VESA framebuffer.
# This generic interface should work with nearly all video cards
# (although not every card will support every resolution).
# With the new driver, it should no longer be required to have frame buffer
# support in the kernel, or to run it on the console.
#
# Enjoy! :)
# -- volkerdi@slackware.com
#
# **********************************************************************

Section "ServerLayout"
    Identifier     "Simple Layout"
    Screen         "Screen 1" 0 0
    InputDevice    "Mouse1" "CorePointer"
    InputDevice    "Keyboard1" "CoreKeyboard"
EndSection

Section "Files"
    RgbPath         "/usr/share/X11/rgb"
    FontPath        "/usr/share/fonts/local/"
    FontPath        "/usr/share/fonts/misc/"
    FontPath        "/usr/share/fonts/OTF/"
    FontPath        "/usr/share/fonts/TTF/"
    FontPath        "/usr/share/fonts/Type1/"
    FontPath        "/usr/share/fonts/CID/"
    FontPath        "/usr/share/fonts/Speedo/"
    FontPath        "/usr/share/fonts/75dpi/:unscaled"
    FontPath        "/usr/share/fonts/100dpi/:unscaled"
    FontPath        "/usr/share/fonts/75dpi/"
    FontPath        "/usr/share/fonts/100dpi/"
    FontPath        "/usr/share/fonts/cyrillic/"
EndSection

Section "Module"
    Load           "dbe"
    SubSection     "extmod"
        Option         "omit xfree86-dga"
    EndSubSection
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    Identifier     "Keyboard1"
    Driver         "kbd"
    Option         "XkbLayout" "hr"
EndSection

Section "InputDevice"
    Identifier     "Mouse1"
    Driver         "mouse"
    Option         "ZAxisMapping" "4 5"
    Option         "Buttons" "5"
    Option         "Protocol" "PS/2"
    Option         "Device" "/dev/input/mice"
EndSection

Section "Monitor"
    Identifier     "My Monitor"
    HorizSync       31.5 - 50.0
    VertRefresh     40.0 - 90.0
EndSection

Section "Device"
    Identifier     "VESA Framebuffer"
    Driver         "nvidia"
EndSection

Section "Screen"
    Identifier     "Screen 1"
    Device         "VESA Framebuffer"
    Monitor        "My Monitor"
    DefaultDepth    24
    SubSection     "Display"
        Depth       8
        Modes      "1680x1050" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "1680x1050" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "1680x1050" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Depth       32
        Modes      "1680x1050" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection
 
Old 05-08-2008, 02:45 PM   #2
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 32bit
Posts: 722
Blog Entries: 3

Rep: Reputation: 76
You can have a look at the X log (/var/log/Xorg.0.log) for any error during start-up of X.

Otherwise, you can also try to modify the mouse protocol in /etc/X11/xorg.conf to "Auto" to see what X automatically selects.
 
Old 05-08-2008, 02:53 PM   #3
n0p.cracker
Member
 
Registered: May 2008
Location: Croatia
Distribution: slackware 12.1
Posts: 39

Original Poster
Rep: Reputation: 15
look like no problem there:

Code:
(II) GLX: Initialized MESA-PROXY GL provider for screen 0
(**) Option "CoreKeyboard"
(**) Generic Keyboard: Core Keyboard
(**) Option "Protocol" "standard"
(**) Generic Keyboard: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Generic Keyboard: XkbRules: "xorg"
(**) Option "XkbModel" "pc104"
(**) Generic Keyboard: XkbModel: "pc104"
(**) Option "XkbLayout" "hr"
(**) Generic Keyboard: XkbLayout: "hr"
(**) Option "CustomKeycodes" "off"
(**) Generic Keyboard: CustomKeycodes disabled
(**) Option "Protocol" "ImPS/2"
(**) Configured Mouse: Device: "/dev/input/mice"
(**) Configured Mouse: Protocol: "ImPS/2"
(**) Option "CorePointer"
(**) Configured Mouse: Core Pointer
(**) Option "Device" "/dev/input/mice"
(**) Option "Emulate3Buttons" "true"
(**) Configured Mouse: Emulate3Buttons, Emulate3Timeout: 50
(**) Configured Mouse: ZAxisMapping: buttons 4 and 5
(**) Configured Mouse: Buttons: 9
(II) XINPUT: Adding extended input device "Configured Mouse" (type: MOUSE)
(II) XINPUT: Adding extended input device "Generic Keyboard" (type: KEYBOARD)
    xkb_keycodes             { include "xfree86+aliases(qwertz)" };
    xkb_types                { include "complete" };
    xkb_compatibility        { include "complete" };
    xkb_symbols              { include "pc(pc105)+hr" };
    xkb_geometry             { include "pc(pc104)" };
(II) Configured Mouse: ps2EnableDataReporting: succeeded
now i will try set it to Auto
 
Old 05-08-2008, 03:06 PM   #4
gegechris99
Member
 
Registered: Oct 2005
Location: France
Distribution: Slackware 14.1 32bit
Posts: 722
Blog Entries: 3

Rep: Reputation: 76
From the CHANGES_AND_HINTS.TXT file:

Quote:
The psmouse module is no longer blacklisted by default; instead, it is loaded
with the imps protocol per /etc/modprobe.d/psmouse -- if you need/want a
different protocol, edit that file. Note that options declarations have
no bearing on *if* a module is loaded - they only affect *how* it is loaded.
In other words, the module should now be loaded automatically (since it's no
longer blacklisted), and the options in /etc/modprobe.d/psmouse are the ones
applied when loading it.
It could be than the psmouse module is loaded and is the reason for your trouble.

Check if psmouse is loaded:

Code:
lsmod | grep psmouse
If so, try to blacklist the module.
 
Old 05-08-2008, 03:08 PM   #5
erickFis
Member
 
Registered: Jun 2003
Location: Brasil
Distribution: Slackware 13.1_64 Gold Edition
Posts: 205

Rep: Reputation: 32
Hi nOp!

I've just upgraded from 12.0 to 12.1
and my mice stopped working too.

To fix this I needed to recompile the kernel choosing the right options for my mouse, which seen to be not set by default on Pat's compilation.

Don't worry Pat: I still love u and slackware!
Before, in 12.0, my amarok and gxine used to be buggy,
but they are ok now XD
Slack 12.1 is awesome - stable as hell!

Thank u Pat!!!!!
 
Old 05-08-2008, 03:17 PM   #6
n0p.cracker
Member
 
Registered: May 2008
Location: Croatia
Distribution: slackware 12.1
Posts: 39

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by erickFis View Post
Hi nOp!

I've just upgraded from 12.0 to 12.1
and my mice stopped working too.

To fix this I needed to recompile the kernel choosing the right options for my mouse, which seen to be not set by default on Pat's compilation.

Don't worry Pat: I still love u and slackware!
Before, in 12.0, my amarok and gxine used to be buggy,
but they are ok now XD
Slack 12.1 is awesome - stable as hell!

Thank u Pat!!!!!
well what were that options, I am a newbie in complinig kernel, this was my first upgare in slackware
 
Old 05-08-2008, 03:38 PM   #7
erickFis
Member
 
Registered: Jun 2003
Location: Brasil
Distribution: Slackware 13.1_64 Gold Edition
Posts: 205

Rep: Reputation: 32
ok, lets go:

- download the new linux kernel (kernel.org)
- unpack it (can be in your home dir, doesn't matter)
- cd to the unpacked dir
- edit Makefile and set the install path (i.e: /boot/k25)
- edit /etc/lilo.conf to include the new kernel image
- copy /boot/config-huge-smp-2.6.24.5-smp or config-huge-2.6.24.5
to .config
- run $make oldconfig
- run $make xconfig
- now go in Device Drivers > Input device support
- set anything related to your mouse here.
- save
- run $make
- turn to root
- create the kernel destination dir (/boot/k25)
- cp the lilo.conf that u have edited to /etc
- run $make install
- run $make modules_install

Good luck!
it's not so hard as it looks XD
 
Old 05-08-2008, 03:54 PM   #8
n0p.cracker
Member
 
Registered: May 2008
Location: Croatia
Distribution: slackware 12.1
Posts: 39

Original Poster
Rep: Reputation: 15
thx on this, i will try it now
 
Old 05-08-2008, 03:56 PM   #9
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
Quote:
Originally Posted by gegechris99 View Post
From the CHANGES_AND_HINTS.TXT file:



It could be than the psmouse module is loaded and is the reason for your trouble.

Check if psmouse is loaded:

Code:
lsmod | grep psmouse
If so, try to blacklist the module.

Um, you've got that backwards. If the psmouse module is NOT loaded, then loading it will almost surely fix the problem.

The snippet you posted from CHANGES_AND_HINTS.TXT is correct, however, and that's the part the original poster needs to read.
 
Old 05-08-2008, 04:17 PM   #10
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
It's so nice to have someone from Croatia here,welcome n0p!
About your problem,you should first try what gegechris99 has suggested.Pozdrav.
 
Old 05-08-2008, 04:43 PM   #11
n0p.cracker
Member
 
Registered: May 2008
Location: Croatia
Distribution: slackware 12.1
Posts: 39

Original Poster
Rep: Reputation: 15
well that module isn't loaded, and i think that there is a problem, i have removed it from blacklist, and again it wasn't loaded.. the same problem is with ndiswrapper module :S..


p.s. (alane nemoj zezat da si iz rijeke , ja sam 45min od ri, selo bribir xD )
 
Old 05-08-2008, 04:52 PM   #12
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
Quote:
Originally Posted by n0p.cracker View Post
well that module isn't loaded, and i think that there is a problem, i have removed it from blacklist, and again it wasn't loaded..
Do you have a backup of the old /etc/modprobe.d/blacklist still in the same directory?
If so, remove it. That's why I said to read CHANGES_AND_HINTS.TXT.

Quote:
the same problem is with ndiswrapper module :S..
That one has to be loaded manually.
rc.modules is one option, but there's a better one - again, see CHANGES_AND_HINTS.TXT.
Seriously, the documentation is there for a reason.
 
Old 05-08-2008, 04:53 PM   #13
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
Quote:
Originally Posted by n0p.cracker View Post
p.s. (alane nemoj zezat da si iz rijeke , ja sam 45min od ri, selo bribir xD )
Je stari,baš iz Rijeke,vidiš kako je svijet mali,e baš mi je drago .
Izgleda da ćeš morat kompajlirat kernel,samo naprijed,ako zapneš samo postaj ovdje.
Inače ja imam Slackware 12 i nisam imo tih problema.
 
Old 05-08-2008, 09:07 PM   #14
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,455

Rep: Reputation: Disabled
Quote:
Originally Posted by rworkman View Post
That one has to be loaded manually.
rc.modules is one option, but there's a better one - again, see CHANGES_AND_HINTS.TXT.
Seriously, the documentation is there for a reason.
Are you referring to rc.netdevice? If so, how is it better? If not, could you elaborate?

Thanks,
Brian
 
Old 05-08-2008, 11:32 PM   #15
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 1,913

Rep: Reputation: Disabled
Quote:
Originally Posted by BCarey View Post
Are you referring to rc.netdevice? If so, how is it better? If not, could you elaborate?
Indeed I am.

There are two good options, actually. One is to use rc.modules.local, but you would need to include the top section of the stock rc.modules (the section from the top that updates module dependencies) at the top of the custom rc.modules.local. For example, here's mine (yes, I use this method):
Code:
#!/bin/sh
# rc.modules 12.1  Wed Mar  5 23:51:09 CST 2008  pp (rb), pjv
# Customized version for rc.modules.local -- 20080323 rlw
#
# This file loads extra drivers into the Linux kernel.
#
# Determine the version of the running kernel:
RELEASE=$(uname -r)

### Update module dependencies ###
# If /usr is mounted and we have 'find', we can try to take a shortcut:
if [ -x /usr/bin/find -a -e /lib/modules/$RELEASE/modules.dep \
     -a /lib/modules/$RELEASE/modules.dep -nt /etc/modules.conf ]; then
  NEWMODS="$(/usr/bin/find /lib/modules/$RELEASE -type f -mindepth 2 -newer /lib/modules/$RELEASE/modules.dep)"
  # Only rebuild dependencies if new module(s) are found:
  if [ ! "" = "$NEWMODS" ]; then
    echo "Updating module dependencies for Linux $RELEASE:"
    /sbin/depmod -a
  else
    echo "Module dependencies up to date (no new kernel modules found)."
  fi
else # we don't have find, or there is no existing modules.dep, or it is out of date.
  echo "Updating module dependencies for Linux $RELEASE:"
  /sbin/depmod -A
fi

# ACPI Stuff
modprobe acpi_cpufreq
modprobe thinkpad_acpi
modprobe ac
modprobe video
modprobe thermal
modprobe processor
modprobe fan
modprobe button
modprobe battery
modprobe nvram

# Power scaling
modprobe cpufreq_ondemand
modprobe cpufreq_conservative

# Modules for PPTP VPN
modprobe ppp_mppe
modprobe nf_conntrack_pptp
That's probably a bit of overkill now with 2.6.24.x, as it's supposed to load most acpi modules automatically, so just call me crufty.

The easier way to do it is with rc.netdevice though. The original purpose of that script (which will probably not exist on a fresh installation) was to load networking modules early in the boot process so that the network scripts could finish successfully. Since udev came along though, that's just not needed anymore. However, support for the file is there, and since it's run early in the boot process if it exists, it's a great place to sneak other non-network-related modules in if you need them loaded.
* I have to credit Pat with hammering a clue at me on this one - while it's obvious to me now, I'd never considered rc.netdevice for this purpose before.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Making the 'wheel' work on mice tuxuser19 Debian 1 10-15-2005 05:54 AM
Can I configure two mice to work at the same time? njschroe Linux - Hardware 4 02-01-2005 08:42 AM
/dev/input/mice doesn't work Bogdan29 Linux - Newbie 3 05-07-2003 11:19 PM
Mice - how they work? johan the olive Linux - Hardware 3 02-28-2003 04:13 PM
Argh! My mice dont work! curator Linux - Software 2 02-12-2001 09:14 AM


All times are GMT -5. The time now is 08:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration