LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-08-2009, 04:58 AM   #16
alexiy
Member
 
Registered: Jul 2009
Location: Germany
Distribution: Slackware-current x86_64,
Posts: 51

Rep: Reputation: 18

Hi,

It is necessary to switch on an internal mic and enable capturing on this device.

1. Go kmix mixer->Settings->Configure channels
2. Tick "Capture", "Internal Mic" channels
3. On kmix main window tick "Capture check-box"
4. In "Input Source1 and 2" select "Internal mic"

Hope it helped you.
 
Old 09-08-2009, 05:03 AM   #17
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
No KDE on my T61, but I will see what I can do with alsamixer or something else.

Edit: alsamixer shows no "capture" -- all say [Playback].

From the first day I owned this laptop, it's had the lowest sound volume and the
poorest quality of any computer I ever owned. The sound in Vista or XP on it is
considerably better, so perhaps the culprit is alsa.

Last edited by Bruce Hill; 09-08-2009 at 06:44 AM.
 
Old 09-08-2009, 10:42 AM   #18
alexiy
Member
 
Registered: Jul 2009
Location: Germany
Distribution: Slackware-current x86_64,
Posts: 51

Rep: Reputation: 18
Quote:
Originally Posted by Bruce Hill View Post
No KDE on my T61, but I will see what I can do with alsamixer or something else.

Edit: alsamixer shows no "capture" -- all say [Playback].

From the first day I owned this laptop, it's had the lowest sound volume and the
poorest quality of any computer I ever owned. The sound in Vista or XP on it is
considerably better, so perhaps the culprit is alsa.
I agree with you on the quality of this laptop. In my company I was last one who got it. Now they switch on Dell completely.

As to my solution, yes, that is related to KDE.
 
Old 09-08-2009, 10:48 AM   #19
alexiy
Member
 
Registered: Jul 2009
Location: Germany
Distribution: Slackware-current x86_64,
Posts: 51

Rep: Reputation: 18
Quote:
Originally Posted by alefmk View Post
This is similar to my problem. Sound works perfectly when starting runlevel 3 and than starting X, but not when starting directly to runlevel 4. What runlevel are you starting with?
I'm using runlevel 4. I had an issue not with sound but with my internal mic.

In your case, maybe you are running KDE under root when you start as level 3 and as a local user when you starting level4?
 
Old 09-08-2009, 11:42 AM   #20
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Rep: Reputation: 100Reputation: 100
@Ahmed: Please run alsamixer, press [TAB] or F4 to switch to [Capture] settings and post the screenshot here.
 
Old 09-11-2009, 09:38 AM   #21
Ahmed
Member
 
Registered: May 2005
Location: München, Germany
Distribution: Slackware
Posts: 386

Original Poster
Rep: Reputation: 41
@Quanta: Sorry for the delay. Here it is, with all available options:

alsamixer.png

And to answer a previous question: I start runlevel 4 directly..

-A

Last edited by Ahmed; 09-11-2009 at 09:39 AM.
 
Old 09-12-2009, 12:34 PM   #22
quanta
Member
 
Registered: Aug 2007
Location: Vietnam
Distribution: RedHat based, Debian based, Slackware, Gentoo
Posts: 724

Rep: Reputation: 100Reputation: 100
Quote:
Originally Posted by Ahmed View Post
@Quanta: Sorry for the delay. Here it is, with all available options:

Attachment 1479
-A
- Move to Capture channel and press Space bar to make it the same Mic channel
- Save the settings with: sudo alsactl store
- Try with external mic

Quite strange to me when you have no Input source channel?
 
Old 09-12-2009, 01:16 PM   #23
Ahmed
Member
 
Registered: May 2005
Location: München, Germany
Distribution: Slackware
Posts: 386

Original Poster
Rep: Reputation: 41
Quote:
Originally Posted by quanta View Post
- Move to Capture channel and press Space bar to make it the same Mic channel
- Save the settings with: sudo alsactl store
- Try with external mic

Quite strange to me when you have no Input source channel?
YES! That one did it. I can now hear my recordings from arecord/aplay and Skype Test Call works. Had no idea about this selection thing.

Thanks a million!

-A
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Sound (Mic) not working in Fedora 9 pulseaudio MikeyCarter Linux - Software 0 07-30-2008 11:01 AM
pulseaudio +Mic problems setlec_seta Mandriva 4 06-08-2008 07:07 PM
Can't record from Mic sabre307 Linux - Hardware 10 05-27-2006 07:06 PM
how to record from mic ginda Linux - Newbie 1 05-24-2006 03:57 AM
Unable to record mic-in with SoundBlaster Live! while able to record other sources max76230 Linux - Newbie 2 03-14-2005 05:31 AM


All times are GMT -5. The time now is 10:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration