LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Menu icons in Xfce 4.4: Where did they go? (http://www.linuxquestions.org/questions/slackware-14/menu-icons-in-xfce-4-4-where-did-they-go-469282/)

cwwilson721 07-31-2006 12:38 AM

Menu icons in Xfce 4.4: Where did they go?
 
Upgraded Xfce to the '4.4' beta (installed from a package. That maybe my issue). Everything seems to be ok (minor issues, it is beta after all).

One irritant, though: The icons I used to have on my menus, etc are mostly gone. There are very few on my menus.

Any ideas on
  • A universal setting that tells Xfce where the icons are? (Was thinking like /opt/kde/share/icons/whereever
  • Or do I have to specify each and every one?
I would prefer the first option, because 80-95 percent of the icons are missing, and I'm lazy...lol

Ideas?

piete 07-31-2006 01:17 PM

Primarily the problem is that xfce depends on the hicolor icon theme ( http://icon-theme.freedesktop.org/wiki/HicolorTheme ) which is installed to /usr/share/icons/ (or should be). The problem with xfce is that by default it doesn't itself *come* with the icon theme, so any package hand-built may omit this dependency.

For reference, xfce default themes are stored in /usr/share/themes and both icons and themes can be per user, and are stored in ~/.icons and ~/.themes respectively.

Hope that's the answer you're looking for!
- Piete.

cwwilson721 07-31-2006 01:33 PM

Thank you.

That worked perfect.

I wish that was posted on the XFce website forum...


All times are GMT -5. The time now is 07:39 AM.