LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-08-2012, 01:31 PM   #1
escaflown
Member
 
Registered: Apr 2009
Location: Canada
Distribution: Slackware
Posts: 237

Rep: Reputation: 30
mediatomb slackbuild with libmp4v2 support


FYI:
In order to have the mediatomb slackbuild to build succesfully with libmp4v2, you will need this patch.
Without the patch, you can only build mediatomb with mp4 support disabled.
 
Old 10-08-2012, 03:11 PM   #2
Mark Pettit
Member
 
Registered: Dec 2008
Location: Cape Town, South Africa
Distribution: Slackware 14.1 64 Multi-Lib
Posts: 428

Rep: Reputation: 123Reputation: 123
Can you elaborate a little further : like how exactly you modified the slackbuild.
 
Old 10-08-2012, 06:29 PM   #3
escaflown
Member
 
Registered: Apr 2009
Location: Canada
Distribution: Slackware
Posts: 237

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Mark Pettit View Post
Can you elaborate a little further : like how exactly you modified the slackbuild.
- Copy the patch in the slackbuild folder and rename the file to "mediatomb-0.12.1-libmp4v2_191_p479.patch" (or whatever else you want as long s you reuse the same file name in the patch line in the slackbuld script).
- Then modify the slackbuild script by adding the following line after the gcc4.7 patch:
Code:
# Fix building with libmp4v2
patch -p1 -i $CWD/mediatomb-0.12.1-libmp4v2_191_p479.patch
Hope it helps.
 
Old 10-09-2012, 12:09 AM   #4
Mark Pettit
Member
 
Registered: Dec 2008
Location: Cape Town, South Africa
Distribution: Slackware 14.1 64 Multi-Lib
Posts: 428

Rep: Reputation: 123Reputation: 123
Confirmed. I can't get it to build without the patch. With the patch it compiles fine. Of course, whether it still works is another matter :-) Thanks.
 
Old 10-09-2012, 04:04 AM   #5
ppr:kut
Member
 
Registered: Aug 2006
Location: Netherlands
Distribution: Slackware
Posts: 361

Rep: Reputation: 93
Fixed in my branch. Will be part of the next update. Thanks for the notice!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fedora 15 mediatomb dappa Linux - Desktop 9 08-31-2011 12:55 PM
Trying to FIND mediatomb 0.12.0 tomlin Linux - Software 3 02-19-2010 12:44 PM
[SOLVED] libmp4v2-v1.5.0.2 in slackware64-current escaflown Slackware 5 02-14-2010 04:06 PM
Mediatomb+subtitles. ohadbasan Linux - Software 2 01-18-2009 01:04 PM
libfaad2 libmp4v2 source download kaon Linux - Software 1 11-08-2005 04:06 AM


All times are GMT -5. The time now is 07:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration