LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-15-2010, 03:17 AM   #1
mister2
LQ Newbie
 
Registered: Jan 2010
Posts: 1

Rep: Reputation: 0
Mediatomb install slackware 13 help


So up until now i've been using Ubuntu, which has a great dependency system, it does it for me. Now i'm working on installing mediatomb which requires several things it doesn't detect. These would be sqlite 3, ffmpeg, and libjs. The funny thing is i'm certain i already have ffmpeg installed (i can run it). Same with sqlite 3. Now i assume i have to point the configure file from the source folder to where my sqlite 3 and ffmpeg files are located, but i don't know how. I tried to use --with-ffmpeg-libs= and direct it to /usr/bin/ffmpeg but that didn't work. Also, what is libjs? How do i get it? Also, for finding slackware packages i've only been able to find a couple repositories (slackbuilds.org and linuxpackages) and i was wondering if there was somewhere where literally everything is findable (a universal repository). Thanks for any help.
 
Old 01-15-2010, 06:36 PM   #2
bgeddy
Senior Member
 
Registered: Sep 2006
Location: Liverpool - England
Distribution: slackware64 13.37 and -current, Dragonfly BSD
Posts: 1,810

Rep: Reputation: 227Reputation: 227Reputation: 227
Hi mister2 and welcome to Slackware !

I tried building mediatomb and I found the same results as you with one exception - you have missed mozilla's javascript libraries which are here in SlackBuild form (this is the libjs).
I couldn't get the configure to work with the standard sqlite version - however as mysql is the alternative and Slackware ships with this I settled for this.
Next problem was where the configure was looking for certain ffmpeg headers. The quick (and dirty) fix to this is to create a link called /usr/include/ffmpeg to the /usr/include/libavformat directory like this:
Code:
su -c "ln -s /usr/include/libavformat /usr/include/ffmpeg".
After this the configure will succeed but then the compilation fails (running make) with this error :
Code:
../src/url.cc:78:53: error: macro "curl_easy_setopt" requires 3 arguments, but only 2 given
This is possibly to do with the version of curl. I gave up then ! Maybe someone else can help with this.
 
Old 01-15-2010, 08:42 PM   #3
marnold
Member
 
Registered: Dec 2005
Distribution: Slackware64 14.1
Posts: 258

Rep: Reputation: 32
I got it compiled, but I couldn't figure out how to get it to detect sqlite, which is a pity because using mysql seems to be overkill. Anyway, to find the js stuff, add this after ./configure

--with-js-libs=/usr/lib64/seamonkey --with-js-h=/usr/include/seamonkey/js

This is assuming you are using Slackware64. If you aren't, just change remove the "64". If anyone knows why you can't get it to detect the version of sqlite3 that comes with Slackware 13, I'd be interested. Here's what was in my config.log:

configure:21868: checking for sqlite3.h
configure:21875: result: yes
configure:22170: checking for sqlite3_open in -lsqlite3
configure:22205: g++ -o conftest -g -O2 -I/usr/include -L/usr/lib64 -lrt conftest.cpp -lsqlite3 >&5
/usr/lib64/libsqlite3.so: undefined reference to `dlsym'
/usr/lib64/libsqlite3.so: undefined reference to `dlerror'
/usr/lib64/libsqlite3.so: undefined reference to `dlopen'
/usr/lib64/libsqlite3.so: undefined reference to `dlclose'

If it's the same problem as this one the only solution is to recompile sqlite3.
 
Old 01-15-2010, 09:26 PM   #4
larryhaja
Member
 
Registered: Jul 2008
Distribution: Slackware 13.1
Posts: 293

Rep: Reputation: 76
In order to use the Slackware sqlite with mediatomb just add this to configure.
Code:
LDFLAGS="-ldl" ./configure
 
Old 01-15-2010, 10:58 PM   #5
marnold
Member
 
Registered: Dec 2005
Distribution: Slackware64 14.1
Posts: 258

Rep: Reputation: 32
Quote:
Originally Posted by larryhaja View Post
In order to use the Slackware sqlite with mediatomb just add this to configure.
Code:
LDFLAGS="-ldl" ./configure
Awesome! That did the trick.
 
Old 01-15-2010, 11:15 PM   #6
larryhaja
Member
 
Registered: Jul 2008
Distribution: Slackware 13.1
Posts: 293

Rep: Reputation: 76
Quote:
Originally Posted by bgeddy View Post
Next problem was where the configure was looking for certain ffmpeg headers.
For newer ffmpeg try this patch.
http://sources.gentoo.org/viewcvs.py....patch?rev=1.1
Quote:
Originally Posted by bgeddy View Post
After this the configure will succeed but then the compilation fails (running make) with this error :
Code:
../src/url.cc:78:53: error: macro "curl_easy_setopt" requires 3 arguments, but only 2 given
This is possibly to do with the version of curl. I gave up then ! Maybe someone else can help with this.
For newer libcurl try this patch.
http://sources.gentoo.org/viewcvs.py....patch?rev=1.1
You'll probably have to run autoreconf after applying the ffmpeg patch so configure will be able to find ffmpeg.
 
Old 01-16-2010, 12:10 PM   #7
lumak
Member
 
Registered: Aug 2008
Location: Phoenix
Distribution: Arch
Posts: 799
Blog Entries: 32

Rep: Reputation: 109Reputation: 109
You should only need libjs if you want m3u/playlist support. It's not used for anything else (according to my research when I first installed it)

If you manage to get it installed, you will need to create an empty data base. Read the top hashed section of /etc/rc.d/rc.mysqld on how to set up MySQL. Additionally, if you want to run it on start up from an rc script, I would create a mediatomb user and group.

To create the database, log into your mysql server as root (not your computer
root, the mysql server root account)
shell> mysql -u root -p

create the database
mysql> CREATE DATABASE mediatomb;

create the mysql user mediatomb, give them permission to mediatomb database,
and give them the password mediatomb (please be more inventive for security).
mysql> GRANT ALL ON mediatomb.*
TO 'mediatomb'@'localhost'
IDENTIFIED BY 'mediatomb';

Other notes! the web interface is insecure. It allows anybody to view the names of all files on your system assuming the user running the daemon has read access to that directory. Change <ui enabled="yes"> to <ui enabled="no"> inside the settings file to avoid this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems compiling mediatomb z3rosh0t Linux - Software 8 01-11-2010 07:36 AM
mediatomb won't display iTunes albums Robert S Linux - Software 2 12-28-2009 07:22 PM
Mediatomb and Sqlite in Slackware 12.2 marnold Slackware 1 01-22-2009 11:43 AM
Mediatomb+subtitles. ohadbasan Linux - Software 2 01-18-2009 02:04 PM
Serve Media with MediaTomb jeremy LQ Articles Discussion 0 09-07-2007 04:39 PM


All times are GMT -5. The time now is 10:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration