LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Maybe a bug in dhcpcd-6.0.5-x86_64-2 on Slackware64-current (http://www.linuxquestions.org/questions/slackware-14/maybe-a-bug-in-dhcpcd-6-0-5-x86_64-2-on-slackware64-current-4175479303/)

jhw 10-02-2013 04:27 AM

Maybe a bug in dhcpcd-6.0.5-x86_64-2 on Slackware64-current
 
Hi there,

I think I have found a bug in the current dhcpcd build on current64. Since I installed this version (dhcpcd-6.0.5-x86_64-2) I am unable to receive an IP address via DHCP on my eth0. The interface is up, I receive UDP broadcasts, I even send out a DHCP request. However, I don't get a reply. This happens on different networks, i.e. at home and at work. I have reverted back to the old build dhcpcd-6.0.5-x86_64-1 and am now able to receive an address via DHCP again.

This issue ONLY occurs on eth0. The faulty dhcpcd DOES provide me with an IP on my wifi.

Here's my hardware (HP EliteBook 8470p):
Code:

# lspci
00:00.0 Host bridge: Intel Corporation Ivy Bridge DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Ivy Bridge PCI Express Root Port (rev 09)
00:14.0 USB controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)
00:1a.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 2 (rev c4)
00:1c.2 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 3 (rev c4)
00:1c.3 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Panther Point 6 port SATA Controller [AHCI mode] (rev 04)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Thames [Radeon 7500M/7600M Series]
01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Turks HDMI Audio [Radeon HD 6000 Series]
24:00.0 FireWire (IEEE 1394): JMicron Technology Corp. IEEE 1394 Host Controller (rev 30)
24:00.1 System peripheral: JMicron Technology Corp. SD/MMC Host Controller (rev 30)
24:00.2 SD Host controller: JMicron Technology Corp. Standard SD Host Controller (rev 30)
25:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 (rev 34)
#

If you need more information, just ask. I'll also see if I can debug this issue any further.

guanx 10-02-2013 06:08 AM

I believe you got no dhcp reply, but could you post the output from "dhcpcd -d eth0"? If you already have dhcpcd running, first kill it.


All times are GMT -5. The time now is 11:18 AM.