LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 07-02-2013, 07:30 AM   #61
lensilvan
Member
 
Registered: Jun 2013
Distribution: Arch Linux, Mintppc, Slackware
Posts: 109

Rep: Reputation: Disabled

For me, MATE is well installed. However, MATE don't appears in xwmconfig and there is no such things as a ~/.xinitrc file or /etc/skel/.xinitrc (like in Arch)... What shoud I do?
 
Old 07-02-2013, 07:42 AM   #62
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,384

Rep: Reputation: Disabled
The package "mate-session-manager" of the MSB package set contains the file /etc/X11/xinit/xinitrc.mate-session which should make MATE a visible choice in xwmconfig. I have no idea why it won't show up for you.

The xwmconfig script will create ~/.xinitrc for you. Slackware does not have /etc/skel/.xinitrc .

Eric
 
Old 07-02-2013, 10:52 AM   #63
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Rep: Reputation: 168Reputation: 168
@lensilvan - did you install MATE from the MATE SlackBuilds project and if so, did you use our install scripts to build the packages yourself or did you use our binary packages? Because if you installed MATE from MATE SlackBuilds then, like Eric mentioned, the xwmconfig should give you MATE as a desktop environment option.
 
Old 07-02-2013, 10:23 PM   #64
lensilvan
Member
 
Registered: Jun 2013
Distribution: Arch Linux, Mintppc, Slackware
Posts: 109

Rep: Reputation: Disabled
Quote:
Originally Posted by Alien Bob View Post
The package "mate-session-manager" of the MSB package set contains the file /etc/X11/xinit/xinitrc.mate-session which should make MATE a visible choice in xwmconfig. I have no idea why it won't show up for you.

The xwmconfig script will create ~/.xinitrc for you. Slackware does not have /etc/skel/.xinitrc .

Eric
Strangely, although set-mate was already installed, there was no mate-session-manager and I had to install it through slapt-get. Then, I find a mate entry in xwmconfig and selected it and it appeared on the ~/.xinitrc file. However, when I run startx, there was only a blank screen.
 
Old 07-02-2013, 10:33 PM   #65
cisneros
Member
 
Registered: Jul 2012
Distribution: Slackware
Posts: 95

Rep: Reputation: 5
Quote:
Originally Posted by lensilvan View Post
Strangely, although set-mate was already installed, there was no mate-session-manager and I had to install it through slapt-get. Then, I find a mate entry in xwmconfig and selected it and it appeared on the ~/.xinitrc file. However, when I run startx, there was only a blank screen.
I recommend you to compile and install the packages by yourself with the sources from the Git Repo
 
Old 07-02-2013, 10:36 PM   #66
chess
Member
 
Registered: Mar 2002
Location: 127.0.0.1
Distribution: Slackware, OpenBSD, FreeBSD
Posts: 728

Rep: Reputation: 168Reputation: 168
Quote:
Originally Posted by lensilvan View Post
Strangely, although set-mate was already installed, there was no mate-session-manager and I had to install it through slapt-get. Then, I find a mate entry in xwmconfig and selected it and it appeared on the ~/.xinitrc file. However, when I run startx, there was only a blank screen.
Hmm, it sounds to me like you are not using MATE SlackBuilds or our packages since our repo is not set up for slapt-get. Do you remember where you got your Mate packages from? What repo? Are you mixing packages from different repos?
 
Old 07-03-2013, 12:28 AM   #67
lensilvan
Member
 
Registered: Jun 2013
Distribution: Arch Linux, Mintppc, Slackware
Posts: 109

Rep: Reputation: Disabled
For the moment I used slapt-get but now that I have a graphical interface, I will try Slackbuilds.
In fact, many packages necessary for running slackware were missing. After I installed them, now MATE is displayed correctly, however with still some issues. Many icons are missing in the menus as you can see in the screenshot I added in my message. What should I do in this case?
Attached Images
File Type: jpg Capture_1.jpg (48.3 KB, 21 views)
 
Old 07-03-2013, 12:38 AM   #68
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,498

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912
Quote:
Originally Posted by lensilvan View Post
In fact, many packages necessary for running slackware were missing. After I installed them, now MATE is displayed correctly, however with still some issues. Many icons are missing in the menus as you can see in the screenshot I added in my message. What should I do in this case?
if you are not using a full installation you can meet dependency problems not only for the stuff installed but also for any third party, like MSB or the scripts from slackbuilds.org: if you are not able to resolve all dependencies yourself, you can try sticking to the only supported installation, the full one.

to add all the missing packages (you can still select to exclude what you prefer, but remember it's your choice so you have to live with the consequencies ), refresh slackpkg datas with
Code:
slackpkg update
and then, if you have slackware (32bit) issue as root
Code:
slackpkg install slackware
if you have slackware64
Code:
slackpkg install slackware64

Last edited by ponce; 07-03-2013 at 12:40 AM.
 
Old 07-03-2013, 02:54 AM   #69
lensilvan
Member
 
Registered: Jun 2013
Distribution: Arch Linux, Mintppc, Slackware
Posts: 109

Rep: Reputation: Disabled
I have installed all the missing packages, except those related to KDE. However, after rebooting, there are still menu icons missing. Also, in the system menu, I don't have the option of shutting down or reboot, only end the session and lock the screen. Also, the links to caja in the "Places" menu don't work, however I can open caja directly from the desktop...
 
Old 07-03-2013, 03:18 AM   #70
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,498

Rep: Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912Reputation: 912
if you're still using the salix packages and you are on slackware 14.0, try using the ones provided by chess and willy instead

http://slackware.org.uk/msb/

if you're using -current you should rebuild them yourself

https://github.com/mateslackbuilds/msb
 
Old 07-03-2013, 04:18 AM   #71
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,621

Rep: Reputation: 445Reputation: 445Reputation: 445Reputation: 445Reputation: 445
yes, we provide binary packages for Slackware 14.0 only, not Current since Current is a moving target. Although i used Current daily, but i build the binary packages on a VM with a clean installation of Slackware 14.0 only with official updates, no other packages are installed
 
Old 07-03-2013, 06:12 AM   #72
lensilvan
Member
 
Registered: Jun 2013
Distribution: Arch Linux, Mintppc, Slackware
Posts: 109

Rep: Reputation: Disabled
No problem, I use the 14 version.
After I installed the missing packages using that repo, now everything seems to work better. There are however still an issue: At each boot, I don't have in the menu the options of rebooting or shuting down.

Last edited by lensilvan; 07-03-2013 at 06:13 AM.
 
Old 07-03-2013, 07:00 AM   #73
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,621

Rep: Reputation: 445Reputation: 445Reputation: 445Reputation: 445Reputation: 445
which runlevel do you use?
 
Old 07-03-2013, 08:24 AM   #74
lensilvan
Member
 
Registered: Jun 2013
Distribution: Arch Linux, Mintppc, Slackware
Posts: 109

Rep: Reputation: Disabled
Well it is set on runlevel 4...
I thought that it was only a problem of permission. I added my user to the power group. However, after rebooting the same issue occurs, incredible. This is the output of 'groups':
Code:
users floppy audio video cdrom plugdev power netdev
Is it related to MATE or something else? (In this case, I should not pollute this thread )
 
Old 07-03-2013, 08:37 AM   #75
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,621

Rep: Reputation: 445Reputation: 445Reputation: 445Reputation: 445Reputation: 445
Can you try switch to runlevel 3 and see the result?
 
  


Reply

Tags
mate, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: The MATE desktop brings back the power of a real desktop environment. LXer Syndicated Linux News 0 03-27-2012 08:20 AM
LXer: How-To: Get My Desktop with MATE in Ubuntu LXer Syndicated Linux News 0 03-16-2012 12:00 PM
LXer: A Fork Of GNOME 2: The Mate Desktop LXer Syndicated Linux News 0 08-18-2011 07:20 PM
X server and desktop environment's packages on Sarge lixy Debian 5 02-23-2005 12:15 AM
Slackware desktop environment prob... Kebos Linux - Newbie 2 01-11-2004 06:45 PM


All times are GMT -5. The time now is 12:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration