LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Mate 1.10 (http://www.linuxquestions.org/questions/slackware-14/mate-1-10-a-4175498861/)

hpfeil 03-20-2014 10:04 AM

Mate 1.10
 
Mate 1.10 is live!

Odd, though, I can find no mention of it in the usual places. Following the instructions for getting mah-teh slackbuilds, there is is, the 1.10 release. The few mate packages I've been using are version 1.6. The administrators' work is never done. Never heard of a Linux admin who finished everything, then enjoyed a fortnight in Aruba.

git clone git://github.com/mateslackbuilds/msb.git msb
cd msb
<as root to install after each pkg is built>
sed -i '/dconf/d' mate-build-base.sh
mate-build-base.shh
mate-build-extra.sh

New Packages in MATE 1.10:
libgnomecanvas
zenity
galculator

Packages removed in MATE 1.10:
mate-calc
mate-dialogs

This is a list of dependencies for the packages in the /extra directory.

1. extra/mate-applets require deps/pygobject3, deps/libgtop, and
deps/gtksourceview

2. extra/caja-extensions requires deps/gssdp and deps/gupnp

3. extra/mate-netspeed and extra/mate-utils both require extra/libgtop.

4. extra/mate-text-editor requires extra/gtksourceview.

5. extra/mate-system-monitor requires deps/libsigc++, deps/glibmm,
deps/cairomm, deps/pangomm, deps/atkmm, deps/mm-common, and deps/gtkmm.

6. extra/mate-system-tools requires deps/perl-xml-twig,
deps/perl-net-dbus, deps/system-tools-backends, and deps/liboobs.

7. extra/pluma requires both deps/gtksourceview and deps/pygtksourceview

willysr 03-20-2014 10:19 AM

I believe you got it wrong
MATE 1.10 is not yet available
master branch of MSB is tracking the development that leads to MATE 1.10 and i'm documenting all changes for future MATE 1.10 in that master branch :)

you might want to switch to 14.1-mate-1.8 branch to get the latest MATE 1.8 release

hpfeil 03-20-2014 02:31 PM

See https://github.com/mateslackbuilds/msb

moisespedro 03-20-2014 02:45 PM

Quote:

Originally Posted by hpfeil (Post 5138224)

"Most users will want to build from the stable branch which is MATE version 1.8, released in March 2014"

55020 03-20-2014 02:57 PM

Quote:

Originally Posted by hpfeil (Post 5138224)

LOL... You've just told Willy to see his *own* github...

Totoro-kun 03-20-2014 04:13 PM

Oh my... Mate-1.10 shall be the funniest release ever! :D No offense, mate.

willysr 03-20-2014 08:39 PM

Quote:

Originally Posted by hpfeil (Post 5138224)

More precisely, see the README
Quote:

After cloning the initial Git repo, you will be using 'master' branch which
will build the development branch for MATE desktop. Building from the
development branch is not supported and may or may not work at any given
moment. Most users will want to build from the stable branch which is MATE
version 1.8, released in March 2014. Checkout that branch using 'git
checkout 14.1-mate-1.8' to build from the stable MSB branch.

hpfeil 03-21-2014 10:41 AM

Sorry, Mate! Didn't know you da boss. I wasn't looking for 1.10, those files just appeared when I ran the same old git-clone script.

I've been using the same build script since April 9 2013. The brain cells that copied those commands from an authoritative source went back into hiding. The secretary disavows all knowledge.

At the bottom of that file is the cryptic "git://github.com/gfunkmonk2/mate-games.git" - perhaps I was planning on adding a few games back then, but I can find no mention of it now.

Please accept my apology, willysr, I've an illness which prevents me from staying current with LQ. (That got me into trouble last month when I responded to a post without reading ahead to the end of the thread.)

Off to finish tying my latest fly lure which is sure to baffle trout as I whip it close to the surface above the bar where they hang out.

hpfeil 03-21-2014 12:30 PM

It's probably going to be a while to hunt down and update all those GTK-3.0 deprecated functions. Would that I could help!

Meanwhile, methinks the 1.10 release version will have these fixed:

--- MATE-1.10-DEPS.txt.a 2014-03-20 07:42:44.672000000 -0700
+++ MATE-1.10-DEPS.txt.b 2014-03-21 10:25:39.723000000 -0700
@@ -5,9 +5,9 @@

2. extra/caja-extensions requires deps/gssdp and deps/gupnp

-3. extra/mate-netspeed and extra/mate-utils both require extra/libgtop.
+3. extra/mate-netspeed and extra/mate-utils both require deps/libgtop.

-4. extra/mate-text-editor requires extra/gtksourceview.
+4. extra/mate-text-editor requires deps/gtksourceview.

5. extra/mate-system-monitor requires deps/libsigc++, deps/glibmm,
deps/cairomm, deps/pangomm, deps/atkmm, deps/mm-common, and deps/gtkmm.

willysr 03-21-2014 01:06 PM

Commited to master branch

Thanks

Quote:

commit 730bbe6dd87b0496c53693a7677f7ce1326cc917
Author: Willy Sudiarto Raharjo <willysr@slackware-id.org>
Date: Sat Mar 22 01:05:51 2014 +0700

Fix DEPS.

Thanks to hpfeil @ LQ.

Signed-off-by: Willy Sudiarto Raharjo <willysr@slackware-id.org>


All times are GMT -5. The time now is 06:21 PM.