LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-23-2010, 12:43 PM   #1
rm%rf
LQ Newbie
 
Registered: Oct 2009
Distribution: Slackware 13
Posts: 16

Rep: Reputation: 0
Many sbo repository errors


Hi All,

I seem to be getting a lot of errors when trying to install quite a few applications from the sbopkg 13.0 repository.

Just questioning if anyone else is having similar issues, is the site maintained ? 13.1 has been about for a while now and there is no active 13.1 repository yet ?

The error is similar in all applications

" MD5SUM check for ........ OK
error occurred with build. Please check log."

I am running slack current 32bit and am wondering if this is causing the errors.

Just wondering

Thanx
 
Old 09-23-2010, 01:05 PM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,380

Rep: Reputation: 839Reputation: 839Reputation: 839Reputation: 839Reputation: 839Reputation: 839Reputation: 839
which repository and which version of sbopkg are you using?
Code:
sbopkg -v
cat /root/.sbopkg.conf
you should see that repository in a file inside /etc/sbopkg/repos.d/
Code:
cat /etc/sbopkg/repos.d/*
sbopkg has no script repository, it uses by default the ones of http://slackbuilds.org, and there is a 13.1 repository active from quite some time now there.

Last edited by ponce; 09-23-2010 at 01:18 PM.
 
Old 09-23-2010, 02:50 PM   #3
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 201Reputation: 201Reputation: 201
Do you possibly have an older version of sbopkg or maybe just an older version of it's config file? You will have a TON of problems trying to build packages for 13 on current. There is definitely a 13.1 script repo and I have had very few issues with 13.1 slackbuilds on current.
 
Old 09-23-2010, 02:56 PM   #4
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.0
Posts: 2,239

Rep: Reputation: 602Reputation: 602Reputation: 602Reputation: 602Reputation: 602Reputation: 602
The SlackBuilds for 13.0 were designed for bash 3.x, which did not exit the shell (when `set -e` is set) when a subshell returns an error. bash 4 (included with 13.1) will exit if a subshell returns an error (when `set -e` is set). You'd have to throw `|| true` after certain commands to get SlackBuilds for 13.0 working in 13.1 -- but your best bet is, of course, to use the 13.1 repository.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
anyone got OpenShot SBo slackbuild to work? metageek Slackware 13 01-01-2011 05:20 PM
[SOLVED] Deleted Repository Now Get errors Keith_EE Suse/Novell 2 11-26-2010 06:58 AM
installing mpd 0.15.8 from SBo dumdadum Slackware 3 04-14-2010 09:22 AM
Opera 10.01 in SBo hitest Slackware 2 11-09-2009 02:14 PM
Slackware64, trying to compile wine with SBo suid0 Slackware 6 05-27-2009 09:48 AM


All times are GMT -5. The time now is 10:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration