LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-10-2007, 03:49 PM   #1
navic
LQ Newbie
 
Registered: Apr 2007
Location: NY
Distribution: Mint, Ubuntu, Debian, Voyage, Finnix
Posts: 22

Rep: Reputation: 0
Question Manual NIC Config


I'm running slackware 10.2, kernel 2.4.31 no GUI. I have a PCI rtl8139c NIC. netconfig does not even try to probe anything, but lsmod shows 8139too installed. dmesg|grep eth0 shows identification, but DHCP will not work. I used netconfig to set a manual IP, which not allows me to ping the router, but there still is no DNS.

What do I need to do to get this NIC working? I'd like to have it work on DHCP and load on boot automatically, but if a static IP is easier that's fine.

P.S. - how do I change the default LILO boot time?

Thanks in advance!
 
Old 06-10-2007, 04:10 PM   #2
Road_map
Member
 
Registered: Jan 2007
Distribution: Slackware
Posts: 341

Rep: Reputation: 31
If I remember correctly, in Slackware 10.2, for rtl8139c you need to load kernel module 8139cp. To load this module at boot time:
- create config file rc.netdevice in /etc/rc.d;
- chmod 0755 /etc/rc.d/rc.netdevice;
- add in rc.netdevice
Code:
/sbin/modprobe 8139cp
#/sbin/modprobe 8139too
- in /etc/resolv.conf add your Name Server (DNS Server):
Code:
nameserver aaa.bbb.ccc.ddd
- in /etc/rc.d/rc.inet1.conf:
Code:
# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="YES"
DHCP_HOSTNAME[0]=""

# Default gateway IP address:
GATEWAY="aaa.bbb.ccc.d"
 
Old 06-11-2007, 04:38 PM   #3
navic
LQ Newbie
 
Registered: Apr 2007
Location: NY
Distribution: Mint, Ubuntu, Debian, Voyage, Finnix
Posts: 22

Original Poster
Rep: Reputation: 0
Setting DHCP to yes didn't work, but adding the nameserver entry with manual IP worked. Thanks!
 
Old 06-12-2007, 02:06 PM   #4
odevans
Member
 
Registered: Nov 2005
Location: Columbus, OH, USA
Distribution: Slackware
Posts: 246

Rep: Reputation: 30
Quote:
Originally Posted by navic
P.S. - how do I change the default LILO boot time?
Have a look at /etc/lilo.conf - there's a "timeout" setting. After editing and saving lilo.conf, you'll need to run /sbin/lilo (as root) to re-install LILO.

There are manpages for both lilo.conf and lilo.
 
Old 06-13-2007, 01:16 PM   #5
navic
LQ Newbie
 
Registered: Apr 2007
Location: NY
Distribution: Mint, Ubuntu, Debian, Voyage, Finnix
Posts: 22

Original Poster
Rep: Reputation: 0
thanks odevans, worked perfectly!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Modem config manual choice error Deke1955 Linux - Hardware 0 09-20-2005 09:14 AM
Slack drops 'route' after reboot. Manual config required - but why? fireman949 Linux - Networking 1 09-07-2005 01:15 AM
Manual Config Editing for bttv sound device. cachinnare Suse/Novell 4 12-23-2004 06:13 AM
Help, Nic Config Illusion *BSD 4 07-15-2003 10:48 AM
manual network config chosmer Linux - Networking 3 07-26-2002 09:46 AM


All times are GMT -5. The time now is 03:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration