LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Manual NIC Config (http://www.linuxquestions.org/questions/slackware-14/manual-nic-config-560685/)

navic 06-10-2007 04:49 PM

Manual NIC Config
 
I'm running slackware 10.2, kernel 2.4.31 no GUI. I have a PCI rtl8139c NIC. netconfig does not even try to probe anything, but lsmod shows 8139too installed. dmesg|grep eth0 shows identification, but DHCP will not work. I used netconfig to set a manual IP, which not allows me to ping the router, but there still is no DNS.

What do I need to do to get this NIC working? I'd like to have it work on DHCP and load on boot automatically, but if a static IP is easier that's fine.

P.S. - how do I change the default LILO boot time?

Thanks in advance!

Road_map 06-10-2007 05:10 PM

If I remember correctly, in Slackware 10.2, for rtl8139c you need to load kernel module 8139cp. To load this module at boot time:
- create config file rc.netdevice in /etc/rc.d;
- chmod 0755 /etc/rc.d/rc.netdevice;
- add in rc.netdevice
Code:

/sbin/modprobe 8139cp
#/sbin/modprobe 8139too

- in /etc/resolv.conf add your Name Server (DNS Server):
Code:

nameserver aaa.bbb.ccc.ddd
- in /etc/rc.d/rc.inet1.conf:
Code:

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="YES"
DHCP_HOSTNAME[0]=""

# Default gateway IP address:
GATEWAY="aaa.bbb.ccc.d"


navic 06-11-2007 05:38 PM

Setting DHCP to yes didn't work, but adding the nameserver entry with manual IP worked. Thanks!

odevans 06-12-2007 03:06 PM

Quote:

Originally Posted by navic
P.S. - how do I change the default LILO boot time?

Have a look at /etc/lilo.conf - there's a "timeout" setting. After editing and saving lilo.conf, you'll need to run /sbin/lilo (as root) to re-install LILO.

There are manpages for both lilo.conf and lilo.

navic 06-13-2007 02:16 PM

thanks odevans, worked perfectly!


All times are GMT -5. The time now is 04:38 AM.