LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Making a DAC work correctly in Slackware64 14.0 (http://www.linuxquestions.org/questions/slackware-14/making-a-dac-work-correctly-in-slackware64-14-0-a-4175438928/)

Cultist 11-27-2012 11:27 AM

Making a DAC work correctly in Slackware64 14.0
 
I'm trying to get a USB DAC to work on my Slackware laptop (digital to analog converter, basically just a USB soundcard).

It was recommended to me to create a file named ~/.asoundrc. aplay -L gave me the following output: http://pastebin.com/1aZEH3d7

Using that, I created ~/.asoundrc, which has the following in it:
Code:

pcm.!default front:DAC
In KDE's system settings under multimedia hardware, in the Phonon menu (which appears to have a list of all the connected sound output devices), there were two or three DAC entries, which I moved to the top of the list on each Audio Playback header. I also rebooted for good measure.

Now, what happens is that only *some* of the sound I play actually goes through the DAC, while the rest goes through my laptop's internal sound card. When I have an audio player open, every other song I play goes through the DAC, while the rest go through the onboard card. So I might start a single album, and track 1 will be the DAC, track 2 will be the on board card, track 3 will be the dac again, and so forth. And each time a new track starts, it rotates, even if I just start the same track twice in a row, it will begin playing through the other card.

The end result that I'm aiming for is that whenever my USB DAC is plugged in, all sound output is routed through it, but when it isn't plugged in, everything goes through the onboard sound card.

I've researched online and I'm honestly completely lost at this point. I don't even see how this rotating effect is possible. Any help at all would be very greatly appreciated. Thanks!

EDIT: The alternating track thing now seems to be confined specifically to Clementine. Is this now a software problem or is it still a configuration issue?

dugan 11-27-2012 12:44 PM

http://alsa.opensrc.org/MultipleCards

Try, in /etc/modprobe.d/alsa.conf:

Code:

options snd slots=snd-usb-audio,snd-hda-intel
Or:

Code:

options snd-usb-audio index=0
options snd-hda-intel index=1

I always also disable OSS emulation by commenting out the load_alsa_oss_modules lines in /etc/rc.d/rc.alsa. It's amazing how many problems that solves.

jjthomas 12-06-2012 01:03 AM

Quote:

Originally Posted by dugan (Post 4838096)
I always also disable OSS emulation by commenting out the load_alsa_oss_modules lines in /etc/rc.d/rc.alsa. It's amazing how many problems that solves.

I've been pulling my hair out for the last two days trying to get sound back on my EMU1616. I disabled the load_alsa_oss_modules line, restarted rc.alsa and I have sound.

-JJ

EMU10K1


All times are GMT -5. The time now is 04:38 PM.